Does Anyone Use The Merlin Assembler?

1 reply [Last post]
Offline
Joined: Feb 10 2016
Posts: 2

I have been having trouble with Apple II Merlin version 1.34 for a LONG time. Running it on the Virtual II emulator with Apple II E ROM, I can enter 6502 assembly programs, no problem. But the OBJ command keeps returning an error upon assembly. Leaving that one out, I enter the Monitor through Merlin and try to run the program by entering '300G' (after inserting ORG $300) but all I get is a listing of that address, not an actual program run.

Does anyone have any solutions? Maybe the name of another good emulator?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
MarkO's picture
Offline
Joined: Dec 10 2011
Posts: 666
Re: Does Anyone Use The Merlin Assembler?

AppleCoder wrote:

I have been having trouble with Apple II Merlin version 1.34 for a LONG time. Running it on the Virtual II emulator with Apple II E ROM, I can enter 6502 assembly programs, no problem. But the OBJ command keeps returning an error upon assembly. Leaving that one out, I enter the Monitor through Merlin and try to run the program by entering '300G' (after inserting ORG $300) but all I get is a listing of that address, not an actual program run.

Does anyone have any solutions? Maybe the name of another good emulator?

Do you have a link to the Disk Image of Merlin your using??? I can try it on an Apple ][, Un-enhansed ][e or Enhanced //e or a ROM 1 ][gs..

I am using Merlin 8 v2.48 for DOS 3.3 right now, but have the Disk and Manual for Merlin Pro and I am using it on AppleWin 1.23.0.0 and on an Enhanced //e..

You might try the Off-Line Version of ActiveGS.. There is Win32, Mac and Linux clients.. I use this one for ][gs Emulation...

MarkO