Drive 2 connector not working on Disk ][ Interface card

9 replies [Last post]
Offline
Joined: Feb 25 2015
Posts: 4

Hello!

The Drive 2 connector is not working on my Disk ][ interface card.

The drives I'm using power on OK in the Drive 1 connector, so it must be the connector or some of the circuitry.

There does not appear to be physical damage to the connector - is there any particular IC I should check / replace?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
macnoyd's picture
Offline
Joined: Oct 15 2012
Posts: 234
Re: Drive 2 connector not working on Disk ][ Interface card

Physical or not, I would start with replacing the cable with the connectors first,
then step to the IC's if that's the direction this all takes. You can't always see
a bad connection on those cables, especially if you're referring to the ribbon cables.

__________________

macnoyd

Offline
Joined: Feb 25 2015
Posts: 4
Re: Drive 2 connector not working on Disk ][ Interface card

Hi, thanks for your message. Although it's possible the cables may be suspect, I would imagine it's less likely if they both work OK in the Drive 1 connector?

Just to clarify, I've got 2 drives,and have tried both in both connectors on the card.

In connector 1, they both receive power/whirr etc
In connector 2, nothing happens with either, it's as if no power is getting to them at all

macnoyd's picture
Offline
Joined: Oct 15 2012
Posts: 234
Re: Drive 2 connector not working on Disk ][ Interface card

Yup, acknowledged, sounds like a board issue.
FYI, it's cheapest to get the chips off evilBay but shop around. Or,

You can bite the bullet by searching for 142474514285 ... might be worth saving the hassle.
Your choice of course. Good luck!

__________________

macnoyd

Joined: Nov 20 2004
Posts: 42
Re: Drive 2 connector not working on Disk ][ Interface card

Try this discussion:
http://www.applefritter.com/content/apple-iie-problem

SpeedyG goes into some detail about possible faults on the disk controller card.
If the fault does not happen with another disk controller card, then focus on the Disk 2 circuitry of the suspect card.

If you can read the circuit diagrams that SpeedyG has provided, you will see that a lot of the circuit is shared by both the Drive 1 and Drive 2 connectors. But also you can isolate the components that are unique to the Drive 2 connector. That would be where I would focus your efforts.

SpeedyG's web site has a massive amount of resource material for this.
Hope this helps.
Laurie

Offline
Joined: May 27 2009
Posts: 948
Re: Drive 2 connector not working on Disk ][ Interface card

Can I assume that both disk drives work (read & write all tracks) when connected to the DRIVE 1 connector?

And that both disk drives fail when connected to the DRIVE 2 connector?

Does Drive 1 connector (on the interface) work completely (read/write) with both drives connected?

Does Drive 1 connector also work completely if you swap the drives?

If that is a definitive YES to all 4 questions then I'd begin by looking at IC A2, an LS132, on the Disk II interface card that plugs into the Apple itself. It controls which drive is active. It's a good place to start.

Ref: Chapter 9
ftp://ftp.apple.asimov.com/pub/apple_II/documentation/hardware/machines/understanding%20the%20apple%20ii.pdf

__________________

On a clear disk you can seek forever..

Offline
Joined: Dec 20 2003
Posts: 361
Re: Drive 2 connector not working on Disk ][ Interface card

What software are you using to check drive 2?

Dog Cow's picture
Offline
Joined: Dec 11 2008
Posts: 472
Re: Drive 2 connector not working on Disk ][ Interface card

These Apple II service notes may be useful. They cover the Disk II. If not now, then perhaps they may be useful later.

__________________

Email me: dog_cow@m acgui.com
Mac GUI Vault: http://macgui.com/vault/
Apple II Book: http://macgui.com/newa2guide/
Inside Allerton Park book

Offline
Joined: Feb 18 2015
Posts: 5
Re: Drive 2 connector not working on Disk ][ Interface card

I agree with Keatah, all the signals on the 20 pin header are the same for both connectors to drive 1 and drive 2 except pin 14 which is the Drive Enable line which comes from the LS132 as stated above. This is the signal that changes drives. I would look at cables before I start replacing chips especially if the chip is soldered in.
wm

Online
Joined: Jun 18 2010
Posts: 110
Re: Drive 2 connector not working on Disk ][ Interface card

Wayne wrote:

What software are you using to check drive 2?

Still waiting for the response to Wayne's question. How do you know Drive 2 is NOT working? It will not "whir" when the computer is booted like Drive 1. If you boot DOS with Drive 1, you can try to Catalog D2 and then it should turn on.