Garmin GPS & PowerPc Macs

No replies
Offline
Joined: Dec 13 2005
Posts: 264

For all of you that have just PowerPC Macs, and Garmin GPS's. You will no longer be able to update the maps via PowerPC. You will need an Intell Mac, with an OSx of 10.6 or better.

I was told be tech support that they just changed the software about a month earlier.

FireFox, will install the plugin and extentions, but Garmin site can not see them. Thur Safari you can register the GPS, but not update it. Had to take it to a friends house, with an old IBM. I think he was running Vista to do it. Had to D/L the Garmin Plug-in and NetFrame first.

Take Care