Help: CFFA3000 card

10 replies [Last post]
Mr.Fix's picture
Offline
Joined: Mar 22 2005
Posts: 100

Apple IIgs, Rom 03, 4mb, cffa3000 in slot 7 (only card i have in the iigs).

I havent used the iigs for about 6 months, last time i used it the CFFA3000 was operational and used as my boot drive to load GS/OS. I powered it today and i notice that the boot screen 'Apple iigs, Copyright apple computer, ROM version 3' will show and nothing else happens. when i openapple-ctrl-esc i notice that the 'cffa3000 menu' is not shown in the CDA. Going into control panel and slots, i have slot 7 as startup. The cffa3000 upon boot up, beeps and the green light is lit (switch 8 is off). I have a usb key attached and a CF card attached also. How can i get the cffa3000 menu show up again in the CDA?

For reference here is the slot configuration (if that helps)

Slot 1: your card
Slot 2: your card
Slot 3: your card
Slot 4: your card
Slot 5: your card
Slot 6: your card
Slot 7: your card (check marked)

Startup: Slot 7

any help will greatly be appreciated.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: Apr 11 2006
Posts: 1013
Re: Help: CFFA3000 card

For starters, let's get you into the CFFA3000 menu system... hit the "M" key right after you switch the power on.

Mr.Fix's picture
Offline
Joined: Mar 22 2005
Posts: 100
Re: Help: CFFA3000 card

tried the M key to no avail. Also tried accessing it through monitor and that did not work. Mind you, i did the monitor by breaking into prompt from the boot screen. Should this be done with dos loaded?

Mr.Fix's picture
Offline
Joined: Mar 22 2005
Posts: 100
Re: Help: CFFA3000 card

David:

After doing some troubleshooting, i found that if i disconnect my USB key from the card the system will now boot up into GS/OS and the cffa3000 menu will now show up in the CDA and i can do all the things i had done before with the cffa3000. If i reconnect the usb when the computer is shutdown, the original problem occurs. If i reconnect the usb when GS/OS is loaded it will sometimes break into monitor. Do you think my firmware is corrupt or do you think its hardware related problem? As an aside, i reformatted the usb and still causes the original problem. any thoughts on this?

Offline
Joined: Jun 15 2014
Posts: 305
Re: Help: CFFA3000 card

Sounds like a firmware bug that becomes obvious with certain USB storage devices...You'd better try with a different USB drive or with a CF card instead...

Offline
Joined: Apr 11 2006
Posts: 1013
Re: Help: CFFA3000 card

It's strange that it used to work (with this same USB stick, I assume?) but now doesn't. A firmware re-flash might help, but I'm not sure why it would start failing now.

magnusfalkirk's picture
Offline
Joined: Feb 18 2007
Posts: 269
Re: Help: CFFA3000 card

Mr.Fix wrote:

David:

After doing some troubleshooting, i found that if i disconnect my USB key from the card the system will now boot up into GS/OS and the cffa3000 menu will now show up in the CDA and i can do all the things i had done before with the cffa3000. If i reconnect the usb when the computer is shutdown, the original problem occurs. If i reconnect the usb when GS/OS is loaded it will sometimes break into monitor. Do you think my firmware is corrupt or do you think its hardware related problem? As an aside, i reformatted the usb and still causes the original problem. any thoughts on this?

This is liable to sound stupid, but do you have the Startup Disk set to slot 7? Beyond that suggestion I'm stumped as to the reason behind your problem.

Magnus

__________________

Think Different - Apple II Forever!

Mr.Fix's picture
Offline
Joined: Mar 22 2005
Posts: 100
Re: Help: CFFA3000 card

re: USB
yes it is the same usb that i have used before. I even tried another usb stick (different brand and different capacity) and it does the same thing.

the firmware on my card v3.1. should i re-flash with same version or step it down to v3.0? Also, I have never re-flashed the cffa so if i had to do would i need to reformat the CF or could i just put the firmware files onto the existing CF and it will auto flash itself?

for now the only way i can use the usb is to reconnect it after the computer has started and is in dos or gs/os but it is sometimes flaky and would break into monitor.

Mr.Fix's picture
Offline
Joined: Mar 22 2005
Posts: 100
Re: Help: CFFA3000 card

re: USB
yes it is the same usb that i have used before. I even tried another usb stick (different brand and different capacity) and it does the same thing.

the firmware on my card v3.1. should i re-flash with same version or step it down to v3.0? Also, I have never re-flashed the cffa so if i had to do would i need to reformat the CF or could i just put the firmware files onto the existing CF and it will auto flash itself?

for now the only way i can use the usb is to reconnect it after the computer has started and is in dos or gs/os but it is sometimes flaky and would break into monitor.

theart02's picture
Offline
Joined: Oct 30 2014
Posts: 49
Re: Help: CFFA3000 card

I have had the same problem with one of my CFFAs and solved it with a change of the USB stick. However, there is one more possibility - or compromise, if you will: Why don't you use ans USB extension and insert the stick only after booting (from a CF)? This way, you can close you GS and still have an easy way of installing new software.

__________________

"Never trust a computer you can't throw out a window."
Steve Wozniak

Mr.Fix's picture
Offline
Joined: Mar 22 2005
Posts: 100
Re: Help: CFFA3000 card

theart02 wrote:

I have had the same problem with one of my CFFAs and solved it with a change of the USB stick. However, there is one more possibility - or compromise, if you will: Why don't you use ans USB extension and insert the stick only after booting (from a CF)? This way, you can close you GS and still have an easy way of installing new software.

theart02, i have used a different usb (differnt brand and capacity) the problem still exists. My original setup prior to this problem was using an extension. I have also directly attached the usb to the card with same result.

For now, i have put immediate software i had on the usb that i frequently use to the cf card until i can get this problem resolved.