Memory Expansion card not working Apple IIe

19 replies [Last post]
Offline
Joined: Mar 25 2015
Posts: 5

Hi everyone,

I have recently bought a 80col 64K expansion card (see attached picture) for and unenhanced apple IIe.
I cannot make it work (PR#3 causes a lockup - I have to Ctrl-Reset to regain control)
so I figured out the problem may be that the Motherborad is Rev A.

Here are my questions :
- is there something to do with this card to make it work (mod it or whatever) ?
- is there any other like cards (80col/64K) that would work on a Rev A A2e ?
- should I upgrade my motherboard to rev B (I suppose apple dealers dont upgrade this anymore...)

Thanks very much for your advice,

Michel

AttachmentSize
EXP.jpg543.15 KB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
dorkbert's picture
Offline
Joined: Apr 12 2009
Posts: 270
Re: Memory Expansion card not working Apple IIe

nope, the board look stock and should work with all rev of IIe.

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2407
Re: Memory Expansion card not working Apple IIe

maybe the card was damaged by earlier owner who tried to insert card in wrong slot
or turned wrong way in slot ....
maybe the reason is visible at the solderside of the card ( damaged trace ? )
speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

ggb
Offline
Joined: Mar 13 2012
Posts: 31
Re: Memory Expansion card not working Apple IIe

Try placing jumper on J1

Offline
Joined: Mar 25 2015
Posts: 5
Re: Memory Expansion card not working Apple IIe

thanks for your help !
@dorkbert : I've read on http://apple2.info/wiki/index.php?title=RAM_Cards that this might be a Rev version failure OR hardware issue of course.
@speedyG : the card looks really in great condition. The previous owner is a vintage apple product reseller, and has tested it before shipping. He wants me to test it with appleworks, I'll give it a try.
@ggb : is there any risk of damaging the motherboard by doing so?

Michel

Offline
Joined: Jun 15 2014
Posts: 305
Re: Memory Expansion card not working Apple IIe

bonux wrote:

is there any risk of damaging the motherboard by doing so?

No. But for 0064-A motherboard the jumper should be removed. I would recommend you to try the card in another //e computer to find out if it is faulty or not.

Offline
Joined: Mar 25 2015
Posts: 5
Re: Memory Expansion card not working Apple IIe

Hi georgel,

good idea but I'm afraid I'll have a hard time finding another Apple Vintage amateur around here (I live in Toulouse, FR)...
Michel

Offline
Joined: Jun 15 2014
Posts: 305
Re: Memory Expansion card not working Apple IIe

If you're there you'd better study airbus Wink

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2407
Re: Memory Expansion card not working Apple IIe

Bon Jour Michel,
in this community is also a member "amauget"....
he is located in France and has quit good informations about Apple Users in France...
another member in France with good contacts is "Antoine Vigneau"
maybe he has knowledge about some member living close to your area....
i´d recommend to ask amauget here by pm or Antoine Vigneau by email....
sincerely speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

Offline
Joined: Mar 25 2015
Posts: 5
Re: Memory Expansion card not working Apple IIe

Thanks for the heads up speedyG

I'll give it a try.

In the meantime the guy I bought this card from will send me a newer one.
Very nice and professional from him.

@ georgel : I actually *teach* students to become future airbus engineers... Scares you a little bit now, heh ?

See you
Michel

Offline
Joined: Jun 15 2014
Posts: 305
Re: Memory Expansion card not working Apple IIe

Michael, no it doesn't sound frightening,
I passed my airbus training in Toulouse recently...

amauget's picture
Offline
Joined: Jan 3 2011
Posts: 244
Re: Memory Expansion card not working Apple IIe

Hello Michel,

I will contant you through PM.

__________________

Antony
Apple II forever

Offline
Joined: Mar 25 2015
Posts: 5
Re: Memory Expansion card not working Apple IIe

Thanks to everybody !

antony "amauguet" helps me fixing my card up. We are currently trying to replace the 74LS245 chip that might be faulty, after we made sure
the motherboard was OK.

All the best
Michel

amauget's picture
Offline
Joined: Jan 3 2011
Posts: 244
Re: Memory Expansion card not working Apple IIe

Hi to all,

The 74LS245 does not seem to be the culprit...
I'm waiting for Michel's card to go forward.

__________________

Antony
Apple II forever

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2407
Re: Memory Expansion card not working Apple IIe

Hello amauget,

2 paths to checkout:
1st: most common mistake is damage to RAM while getting mailed without
being inserted in antistatic bag for protection...
or
2nd: next insert other 80 col card... if trouble is same kind -> damaged MMU ( 344 - 0100 at UE4 )
or in euro PAL version -> at location UC4 ( 344- 0010 )....
3rd: finally a damaged 74 LS 374

mistakes are listed in order of occasions ( most common at top - least common at bottom )
checkout of RAM may be performed with one of the disks from here:
http://mirrors.apple2.org.za/ftp.apple.asimov.net/images/disk_utils/diagnostics/

good luck....
speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

Offline
Joined: Jun 15 2014
Posts: 305
Re: Memory Expansion card not working Apple IIe

Speedyg, Bonux said motherboard was OK...

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2407
Re: Memory Expansion card not working Apple IIe

georgel wrote:

Speedyg, Bonux said motherboard was OK...

but not with the memory card....
the MMU chip wasn´t tested with other memorycard.....
and i have seen some misbehaving MMU´s working normal without memory cards but
failing when 80 col memory card was inserted....
and it´s not explained that the mainboard has been tested about that question....

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

amauget's picture
Offline
Joined: Jan 3 2011
Posts: 244
Re: Memory Expansion card not working Apple IIe

Hi to all,

A quick update.
The card is not working with my motherboard so Michel's motherboard is probably OK.

__________________

Antony
Apple II forever

Offline
Joined: Jun 15 2014
Posts: 305
Re: Memory Expansion card not working Apple IIe

speedyG wrote:

Hello amauget,

damaged MMU ( 344 - 0100 at UE4 )
or in euro PAL version -> at location UC4 ( 344- 0010 )....

speedyG

There is only one MMU for both PAL & NTSC apple 2e versions with Apple P/N 344-0010 !
I am still looking for the schematics of the internal logic of MMUs and IOUs. A 100% clones of these ICs were produced in my country but I can't get any info after so many years...

amauget's picture
Offline
Joined: Jan 3 2011
Posts: 244
Re: Memory Expansion card not working Apple IIe

The 74LS374 is also working. So definitely, it's a RAM issue.

__________________

Antony
Apple II forever