Mute Mac Classic

13 replies [Last post]
gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616

I decided to pull out my Mac Classic and get her up and running.
She has 4 Meg Of RAM and is running OS 6 and seems to come up and operate at a good clip.
She has one problem...
She's not talking.
Even with an external speaker connected.
I went to my Classic Manual (Troubleshoot and Take-Apart), but there is nothing about what you should do if you have no sound.

Does anyone have an idea of what the problem may be and what I can do about it?

Any assistance is greatly appreciated. Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Mute Mac Classic

Hello Steven,
i´ve first been waiting a while for the mac-experts to answer this question.... after no reply has been given yet, i´ll reply though i don´t have any mac classic but only a G3.... up to my experience such kind of malfunction is in 90% of the cases the result of a not installed driver or a driver not correct for the present chip. So first i´d check the setup in the driversection.
sincerely speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Mute Mac Classic

Speedy,

In that case maybe I should wipe the drive and reload the OS? Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Re: Mute Mac Classic

Just did some Googling, and very low or no sound on the Classic can be a symptom of bad capacitors.

Obviously, I'd rule out other simpler possibilities first, like making sure there is indeed the control panel and/or extension that System 6 requires. As long as you have OS disks that include support for the Classic, a fresh install will install any specific enablers, etc. for that model.

It's a cliche, and probably makes no difference, but installing a working battery and doing a PRAM reset is part of the usual regimen. I'd do that -before- you install a new OS.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Mute Mac Classic

Hello Steven,
i guess that eeun has much more experience to that stuff than i have.... i use the G3 sporadic and i solve problems on macs in my neigborhoood rather more rarely..... anyhow ... i´d recommend to follow his advice to reinstall and prior to that execute the reset at the battery to make sure that realy not a single bit remains in memory and then if the problem still remains after the reinstall and you have checked the controlpanel and the installed devices and the related optionboards related to that devices....
if the problem remains i´d start thinking about the second option and start hunting for that internetpost related to the capacitors..... in fact surrounding that chip are several capacitors and specially in the path connecting the chip to the plugconnector and the audioamplifierchip there are usually electrolytic capacitors used and they are dependent to ageing and failing.....
sincerely speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Mute Mac Classic

Speedy and eeun,

Thanks guys.
I'll get back into it this week for sure.

One question (Iknow it's covered several times here) what is the sequence again for reseting the PRAM Battery?

This is one of the reasons I have a "Golden Screw" in my belly button. It helps keep my butt from detaching itself from my body. lol Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Re: Mute Mac Classic

Cmd-Opt-p-r

Depending on the information source, it's sometimes advised to cycle through a few restarts. Personally I've never seen a difference if it doesn't work the first time.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Mute Mac Classic

Speedy and eeun,

Tried it out a few times with no joy. I'm going to wait a day or so to let the voltages dissipate, then I'm going to take her down to parade rest and check all the caps and do some more cleaning.I want to check all the connections too. Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Mute Mac Classic

Hello Steven,
if you have the circuitplan and some good pics from the board and mail them to me i can mark the related parts in the pictures where to pay attention to.....
for emailadress give a note by pm.....
sincerely speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Mute Mac Classic

Well...

I have the unit down to parade rest and am getting ready to put her back together.
Cleaned her up real good and she's on the bench for assembly.
Found out that the speaker is hardwired to the Analog Board, so the problem must be in the software.
I'm going to upgrade to System 7.5 as she is running System 6 right now.
All caps and other electronics look good.
Time to go to work. Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Mute Mac Classic

Hello Steven,
good luck with that task...
sincerely speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Mute Mac Classic

Imagine my surprize when I assembled everything, plugged her in, turned her on and heard the chime coming out of the speaker. It was very feint, but it was there.
I still have to pull the shell off so I can adjust the screen just a bit.

Does anyone have a small picture showing where the adjustment pots are on the board of a Mac Classic? What I need to see is where the Vertical and Horizontal screen adjustments are. Sound too, if that has a pot.

Thanks to one and all. Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Mute Mac Classic

Along with this Mac Classic, I have been playing on restoring a Mac Color Classic.
Well, the first two have been duds and I bought a third.
This one was from ebay and the picture showed it working.
When it arrived it powered on, but had no picture.
I soon discovered why...
The Picture Tube was completely broken inside from poor packing prior to shipping and very poor handling.
The one quirk that the seller said this color classic had was that the screen flickered.
I figured this cannot be that bad, so I broke out my MCC take apart manual and found out that you can pull the entire chassis out.
This was GREAT!
I pulled the chassis out out the MCC that I had just received, left the broken monitor and front case together.
Pulled the not-working chassis from another MCC (with good monitor) and placed the good chassis into it.
I finished doing the transplant about half an hour ago and turned her on.
She powered right up, BUT the screen is flickering.
I just shut her down and let her set.
I believe that this flickering problem may have something to do with the Analog Board.
Does anyone have experience with this type of problem?
Thanks,
Steven Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Mute Mac Classic

Hello Steven,
here a basic intro by a non mac expert:
there are 2 possible reasons for the flickering:
reason 1: a damage in the part that generates the high voltage for the cathode of the picturetube
reason 2: a protectionswitch ( usually a thyristor get´s ignited by mistake of highvoltage ignitions ) caused by bad isolation and switches off the power to protect the rest of the cicuits....

in most cases the reason is a damaged isolation in the highvoltage transformer.

solution for diagnostic: measure at the highvoltage transformer for seeking a shortcut of damaged isolation....

BUT BE AWARE: SUCH MEASUREMENT MAY ONLY BE PERFORMED AT A COMPUTER THAT IS POWERED OFF AND WHERE THE PICTURETUBE IS ENTIRELY DISCHARGED ! IN THAT AREA THE CIRCUITS HAVE AT CAPACITORS AND OTHER PARTS OF THE ELECTRONICS

UP TO 15000 Volt AND THATS LETHAL IF YOU MAKE MISTAKE

- even if the computer has been switched off hours before !!! Even changing that transformer may only be performed with entirely discharged electronics - if you don´t want to take risk of catching lethal schock !

so please be very very careful !
sincerely speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....