(null)

7 replies [Last post]
Offline
Joined: Sep 12 2010
Posts: 14

...

__________________

podcast: http://open-apple.net
blog: http://6502lane.net
scans: http://apple2scans.net

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Rev. 0 Apple II troubleshooting

Hello computist,

it seems that you are not familiar with the different stages of the booting process of the Apple II.

This is not a problem of the video timing. After powerup of the Apple II a very simple kind
of RAMtest is performed to determine the upper limit of the availiable RAM. (*)
Next then the computer tries to start loading the contents of ROM to the RAM.
Depending to the kind of language card you have in the computer
( is it equiped with F8( autostart ROM or not ? )
- it will start seeking slots downwards to detect if Diskinterface is present or not
and start to load DOS from disk to RAM if Diskinterface is detected
( - otherwise booting will stop at this point and beep is issued and promt will be displayed....)
and then make short break relocating parts of DOS before continueing the loading of next parts of DOS
and again relocating parts of DOS and then starting to load Hello from disk if the file is present....

Because of this procedures you better troubleshoot the system first without diskinterface and Disk II
till you end up with normal Apple II display and prompt
-
and then you may continue with inserted diskinterface further debugging...

The Apple II title will be displayed at the stage i marked with (*).

In fact the description you have given about the board is not complete
and some parts of the booting behavior will change dependent to the circumstances...

therfore its recommended to first pass over further information:

1 ) Is your board still equipped with the Integer Basic ROM set ( 4 ROM chips D0, D8, E0 and E8 and maybe additional the Programmers Aid ?

2) Do you have a Apple ROM-card in your system with either Integer on the card and the ROMs on mainboard upgraded to Applesoft ( all ROMs - D0,D8,E0,E8, F0 and F8 present on Mainboard ) ???
If you are not sure list the numbers of the ROMs here ( example 137-0001 or 137-007 and so on ...)

3) What kind of language card is in your computer ( with Autostart ROM or not ?)

Otherwise set here links to pictures of mainboard and from language card and if possible also language card
in position of slot 0 inserted correct.....
Please make precise pictures that we are able to zoom in
- resolution at least 2 MPixel
- with good light ( not to dark )
and good focus - without shaky parkinson effect )...

this are requirements for further diagnostics -
because futher behaviour and diagnostic of the system are dependent to your answers.....

sincerely
speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

resman's picture
Offline
Joined: Feb 9 2006
Posts: 213
Re: Rev. 0 Apple II troubleshooting

Hi Mike-

Is this the one you were trying to debug at KFest? The F8 ROM and CPU you borrowed from me turned out to be bad, too. When I got home, I eventually pulled all the ROM chips and swapped with a working set. That ended up doing the trick. You are at least getting the reset "beep", I wasn't even getting that. Even plugging a firmware card into the machine didn't help - I had to pull the ROM chips off the motherboard. One of them may have been driving the bus just for fun. So, if you haven't swapped in for a set of working ROMs, I would start there.

Dave...

Offline
Joined: Sep 12 2010
Posts: 14
Re: Rev. 0 Apple II troubleshooting

...

__________________

podcast: http://open-apple.net
blog: http://6502lane.net
scans: http://apple2scans.net

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Rev. 0 Apple II troubleshooting

Hello computist,

Before we start with the job here a view to the ICs on the board
and the markups of their jobs....

at the other hand if you cant´t read the resolution or the
rotated text i recommend to download this map as PDF File from the link:

http://www.appleii-box.de/Bilder/Mainboardlayout.pdf

This will enable you to open the PDF File in Acrobat Reader and view details,
by zooming in the PDF. It also permits you to turn the page orientation
for better readability of rotated text !
I guess you are familiar with
the markings at the border of the mainboard from A to J and from 1 to 14
which will enable me to refer in the following text to that location
squares
.

At the beginning i also recommend you to carry out following tasks:

Remove all RAM chips in the rows D and E ( refered in drawing as 17 to 32 k
and as 33k to 48 k ) and settle them to a antistatic foam !
This is important,
because otherwise that chips might get damaged by static loadings!

For basic debugging the board only needs the first 16 kB in the C - row !

Make sure that keyboard is plugged in correct with no misaligned
plug ! Recheck again every chip for correct seating in its socket
without any pins bent below the chip and missing its socket place.....

I know its boring - BUT: 80% of all malfunctions are finaly detected,
to be caused by that kind of mistake !!!

First step of debugging will target just the computer to startup and stop finaly with
"Apple ][" message on top of the screen and short beep folloowed by display of the
prompt "]".

After that stage is solved, you may continue by adding each further step a row
of RAM
to the board and then after final working board without interface but with complete RAM
by adding the Diskinterface and the controller to
the slot to startup the "Apple Dealers Diagnostic Disk".

In last stage you might add the languagecard and continue by testing that card too.

Then you should finally have a working Apple II!

Lets first get a summary of the symptoms and the conclusions from that symptoms:

After startup the computer displays a screen of "garbage" consisting of letters
and questionmarks before it gets stuck....

Some conclusions from that symptoms:

A ) The clocking chips must be working - otherwise the computer would have got stuck
with black clear screen displaying nothing !

B) The access to the Character ROM must be working too - otherwise you would not see
readable Characters but instead white blocks - maybe with black pixels or vice versa !

C) This indicates also that the timing of the screen generation is in most parts working -
otherwise you would not have clear readable lines but instead a kind of left/right shifting
display or "running" sync or "squeezed" or "scratched" display...

You start recognizing that by this method the possible sources of trouble get smaller step by step
excluding the working parts of the circuits....

D) in fact because some letters are inverse or blinking tells us that the 555 at location
B3 is also working - otherwise the letters can´t blink !

From this sysmptoms we may now state the the CPU wanted to read from the ROM chips and write
some part of the so called zeropage of the RAM, when it got stuck.

One thing not clear is the behavior of the keyboard: you mentioned that the reset does
not really work correct...
this is something to be treated special at the Rev.0 board, because that board has no
true "power up reset"
( the transistor and the 555 chip at location A13 is not present
but instead there is only a kind of "prototype area"....

At the other hand there is a link at 2 IC´s between the keyboard and the RAM area:
That are the 2 x 74LS257 at location B6 and B7 !If they are bad the computer
can´t switch to the RAM-banks
!

This should be your first step in debugging process: Check chips for correct insertion
as explained above and in case of doubt change with chip´s known to be working correct !

It is recommended to use chips as "pair" meaning from same manufacturer and if possible
from same series ( identified by identic printing on top of the chips ). I have seen Board
with malfunction because from different manufacturers the spread in timing was that far,
that they did not cooperate together
!

Next step is similar: Check the two chips at B5 and B8 ( both 74LS174 ) .... they are the
buffers to the RAM access and here are same statements valid as to the two previous
checked chips
: same manufacturer and if possible same series... this two chips shall work
as simultanously as possible !

The third step will be the checkout for correct adressing of the RAM-rows:

I assume that you have previously checked that the plugs of the RAM-selction are inserted
correct for 4116 ( location D1,E1 and F1 ) ! In case you have DIY-made plugs this plugs must
have the following connections for the 16k chips: pin 10 connected to pin 14;
pin 9 must be connected to pin 13 - and pin 8 must be connected to pin 12 !

The chips for the row-selection of the RAM are:
at position C1 a 74LS153 .

At the following single steps mentioning each time only one or 2 chips the same procedure
as at the previous steps:

Checking correct insertion, possible change against known working chip !

Pay attention each time chip gets inserted not to make the common mistake of getting
a pin bending and slipping below of the chip instead of the socket.

The Chip for generating the timing clocks of the RAM and RAM refresh is the 75S195 at location:
C2 !

The Chips related to the selection of the RAM-rows are at position E2 and F2 ( both 74LS139 )
and related to the RAM SEL- signal is the 74LS20 at position D2
and the 74LS00 at position A2 !

Now we are getting close to the final chances of malfunction:
The switching from text display to the display of graphic-pages ( and therefor access to the upper
blocks of RAM ( that chips are marked in the drawing with the term "SOFT5" ), so that chips contain
in several stages the parts of the so called softswitching to the graphicpages and by that switching
to the rows D and E of the RAM !

The related chips are:
a) at location A11 and at B10 ( both 74LS74 )
b) at location C12 the 74LS257

The final guess i would make is the Read/Write control line or the correct adressing selectiion of the ROMs.
But im not realy sure - because in such cases the computer would get stuck in another way with other picture display-
but probably some part of ROM might be accessable and other part is not selected correct.... therefor you should
check the Read/Write signal
at location C14 ( the 74LS32 )
and the ROM selection by:
the 74LS138 at postion F12
and the 74LS08 at poosition H1 !

I wish you good success and would be glad to read response if problem is solved ....

Just besides: Of course you should measure at the power input plug of the mainbaord
also the voltages of -5 Volt and -12 Volt .... they are requsted by the RAM chips
and the RAM won´t work if that votages are bad....
if you need the pinout - see page:
http://www.appleii-box.de/H037_AppleIIupgradingPowersupllies.htm

otherwise just post the new symptoms if you could not solve the problem.

sincerely
speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

Offline
Joined: Sep 12 2010
Posts: 14
Re: Rev. 0 Apple II troubleshooting

...

__________________

podcast: http://open-apple.net
blog: http://6502lane.net
scans: http://apple2scans.net

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2406
Re: Rev. 0 Apple II troubleshooting

Hello computist,

just another idea, that leaped across my mind, related to the behaviour of the keyboard....
Are you sure that the keyboard isn´t the source of your trouble ?
Maybe it issues a bunch of reset or other unwanted signals and prevents the computer from correct booting ?
I´d give it a shot and try if the keybopard behaves correct at other alternate mainboard....
if the keyboard may be excluded from the list because it behaves correct, i´d continue with my todo-list...

speedyG

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

Offline
Joined: Sep 12 2010
Posts: 14
Re: Rev. 0 Apple II troubleshooting

...

__________________

podcast: http://open-apple.net
blog: http://6502lane.net
scans: http://apple2scans.net