OpenTransport Problems Performa 630

3 replies [Last post]
Offline
Joined: Dec 27 2009
Posts: 26

Hi everyone,

I have a Performa 630CD with:

A 68LC040/33 processor,
36mb of RAM,
An Apple ethernet card in the comm slot, connected to WiFi with a relay router
Two partitions - One with OS 7.6.1, and the other with OS 8.1

System 7 is able to load OpenTransport fine, and connect to the internet. OS 8 used to be able to, but for some reason stopped (nothing major changed around that time). The extension called OpenTransport 68k Library crashes startup every time. I have tried everything I know to do - reinstalling the extension, installing different versions, disabling unnecessary extensions and control panels, and even disabling every extension except the OT set. Sometimes it freezes, sometimes it bombs with a bus error, but it never works. I really prefer 8.1 to 7.6, and it would be great if I could get the web and email working again. Is there an alternative to OT or a better version? I've installed the versions from 8, 7 and a newer one that I don't remember. Does it rely on any other extension?

One point of interest, 7.6 and 8.1 share the same desktop for some reason. Probably doesn't matter.

Thanks for any help!

Will

__________________

Real Programmers don't write in BASIC. Actually, no programmers write in BASIC... after age twelve.

Apple Computer One Forever!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Re: OpenTransport Problems Performa 630

Have you tried deleting any preference files from 8 that reference networking or Open Transport? Start with extensions off before doing so.

That the two OSs are sharing a desktop file is odd. I've never experienced problems that I can recall, but I've read recommendations against having two different Classic OSs installed.

If your desktopdb files are corrupt, the OS 8 install may be reading some files from the other partition. Thing is, if the desktop files are corrupt, just rebuilding them may not sort out the trouble. This program will actually delete, then rebuild from scratch, the desktop file:
http://www.applefritter.com/node/12099

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

Offline
Joined: Dec 27 2009
Posts: 26
Re: OpenTransport Problems Performa 630

Thank you very much for your time. I deleted all the preference files dealing with internet and networking. Is there anything else that needs to go? Startup ended again with the bus error Sad
I'n new to the classic Mac OS world, I really have no idea how the desktop database works. How exactly would you reset it?

__________________

Real Programmers don't write in BASIC. Actually, no programmers write in BASIC... after age twelve.

Apple Computer One Forever!

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Re: OpenTransport Problems Performa 630

Download the link I posted above. Use Stuffit Expander to expand it. Read the enclosed instructions, drop the extension in your OS 8's Extensions folder (or on both systems, it's a handy utility), and restart the computer. As soon as you see a gray screen hold down the Command and Option keys. When the extension loads, it'll flash. Release the keys, and your desktop database files are deleted. They will be rebuilt as the system finishes loading. This can take a bit.

You could also try a pram reset, which resets the Mac's memory held by the internal battery. Occasionally this also gets corrupted. Restart the computer, and right away hold down Command-Option-p-r . After a few moments, it should restart and you'll hear the startup chime again.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)