Powers on immediately when back power switch set to "on," no video

4 replies [Last post]
Offline
Joined: Dec 20 2003
Posts: 67

I recently picked up a second Color Classic to try and fix my first one (which has a weird blue blotch in the top left of the CRT, which is not going away after being plugged in and "on" for a long time to degauss).

The machine boots immediately when the power switch on the back is set to "I", which the other one doesn't do (analogue board problem?). It also makes a periodic squeaking sound which doesn't sound like electrical arc'ing (as I've heard previously on a Mac Plus) but it does sound electrical in nature.

The speaker plays the boot chimes and beeps, so the computer is functioning properly. The monitor remains black the entire time, and doesn't feel "staticky" when I touch the glass, so I'm guessing it's not getting something it needs to power on.

The Color Classic progresses properly to the OS, and you can change the volume level through the buttons on the front. It will also respond to the three-finger salute as well as trying to zap the PRAM on startup.

If I push the power button on the keyboard after I imagine the boot process to have reached Finder, it doesn't beep like it should when bringing up the "Shut down?" dialogue box, so the OS is either stuck on some other dialogue box, the version of the OS installed doesn't have the "Shut down" dialogue box, or however the power button interrupt works isn't getting caught by the hardware. Since it works with the three-finger salute, I'm assuming the key works and the OS is just getting stuck.

The motherboard is good, as verified by swapping into my first Color Classic; both ADB ports work and the machine has the normal pseudo-softpower behavior.

I posted to the 68kmla already (see here) but I figured a Colour Classic specific forum might be of more help. I'm going to crack the case soon to take a look and see if there are any obviously blown caps or torched lines.

Any suggestions about what to check next would be greatly appreciated.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Dr. Webster's picture
Offline
Joined: Dec 19 2003
Posts: 1687
Re: Powers on immediately when back power switch set to ...

I've seen similar problems caused by a dying PRAM battery. The machine is old enough to need a replacement (assuming it still has the original installed) anyway. IIRC it's a 1/2 AA-size 3V battery like other Macs from that vintage use.

To try to get it going *now*, you can try the "jump-start" trick I discovered back in the day. Turn the machine on, let it chime, then immediately switch it off and back on quickly.

__________________

Applefritter Admin

Offline
Joined: Dec 20 2003
Posts: 67
Re: Powers on immediately when back power switch set to ...

Thanks for the post!

I should have mentioned, but I installed a brand new Newer PRAM battery prior to starting up the machine the first time (it came with no PRAM battery installed).

How does the "jump start" trick actually work? I thought the machine had already done a fair bit of hardware initialization prior to the startup chime.

Dr. Webster's picture
Offline
Joined: Dec 19 2003
Posts: 1687
Re: Powers on immediately when back power switch set to ...

Well, the "jumpstart" trick assumes you have a dying PRAM battery. I have no idea how it really works; the best I've been able to surmise is that the act of powering the system off and on again rapidly is enough of a jolt to provide the trigger voltage for the video to wake up. If you have a brand new PRAM battery in there though, this trick won't do any good -- I'd take a look at the analog board for dead/dying components (especially capacitors).

__________________

Applefritter Admin

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Re: Powers on immediately when back power switch set to ...

It's been a long time since I've been inside a Colour Classic.
Caps on the analog board, and I think there were also two large diodes or resistors that tended to go bad. You'll know them to see them, they look like big resistors and are often surrounded by a darker, slightly cooked area on the board.
Could be as simple as oxidized connections on the wiring loom that connects the two boards, so I'd eliminate the easy stuff first.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)