Rev 0 compatibility question/poll

4 replies [Last post]
Offline
Joined: Oct 9 2011
Posts: 1063

Ok here is what I'm trying to find out.

I have a Rev-0 with no auto-start ROM and both disk II and CFFA3000. I have a language card in it and I put a RamEx 16k "language card" which only provides 16k so that I still have to do 6 Ctrl P in monitor to boot from floppy on power up.

I ran all the test in APtest and all the apple dealer diagnostics disk tests that apply and it passes.

I also ran a modified version of one of Mike Willegal's memory tests, which did find a bad ram chip that I replaced with a good one.

So most programs run... However there are a couple I can't get working. I tried them on CFFA and on floppy (I tested with a known good drive also). For example I can't get Carmen Santiago working it seems to hang. It is a cracked copy so maybe the copy protection circumvention doesn't like something about the rev 0.

Has anyone found anything else that doesn't work on a rev 0. Mike Willegal said he has only found that stuff needing more memory won't work and he doesn't have a language card in his system so if it requires 64k it won't run, but 48k will. I have the extra memory card, the RamEx I borrowed from my Rev 4. I do also have the original Signetics 6502, which is dated 7807, so maybe there is a bug in the processor that is either screwing some stuff up from timing or an instruction perspective.

Just trying to figure out if there is something wrong with my system or is it normal. I was going to replace my everyday II plus with my Rev 4, but if my Rev 0 can pretty much do everything it looks much cooler in my office.

One note of interest to Rev 0 guys: My 1976 Sony trinitron doesn't have the messed up video on top that a lot of monitors have when hooked up to a rev 0.

Thanks,
Corey

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: Dec 20 2008
Posts: 211
Re: Rev 0 compatibility question/poll

Sandiego. Heheh - not Santiago. Smile

Anyway, some later stuff may need AppleSoft ROMs to work properly. Especially crackers were not very careful with compatibility.

However, it can happen. I have a Rev.4 II+ that won't run Skyfox but passes all the tests. It locks up right at the title screen. Same language card and all chips transplanted into another II+ and it works fine. Something subtle that would be very hard to find.

__________________

-
Peter Rittwage
Apple II/II+ Registry - Register yours today!
http://diskpreservation.com/dp.php?pg=apple_registry

Offline
Joined: Oct 9 2011
Posts: 1063
Re: Rev 0 compatibility question/poll

OK. Think I got it!!!

Without the CFFA card in place with the controller in slot 6 (rom card set to AppleSoft) works off of disk. Put the CFFA 3000 in slot 6, and set the patch dos speed setting thing to NO and everything works!!!!

Guess the "Carmen" is looking for slot 6 and the CFFA default mode wasn't compatible.

Cheers,
Corey

Offline
Joined: Dec 20 2008
Posts: 211
Re: Rev 0 compatibility question/poll

Ah.. You didn't mention that. Yes- lots of stuff won't load if disk card is not in slot 6. I found that out the hard way myself.

__________________

-
Peter Rittwage
Apple II/II+ Registry - Register yours today!
http://diskpreservation.com/dp.php?pg=apple_registry

Offline
Joined: Oct 9 2011
Posts: 1063
Re: Rev 0 compatibility question/poll

It was confusing because of the similar symptoms for two different reasons. Disk vs CFFA3000. Each had their own problems but for different reasons.

Cheers,
Corey