Suggestions To Help Me Get My Color Classic To Turn On

2 replies [Last post]
LisaD's picture
Offline
Joined: Sep 21 2015
Posts: 3

I had my Color Classic in storage for about 3 years. It didn't move. Just brought it in and the thing won't turn on and it used to work just fine. This is what I have done so far without any change in the machine:
checked connections,
checked wall plug for power,
tried to reset PRAM,
removed the logic board and used canned air to blow away any possible debris, (overall appearance of the logic board was fine, no leaks, etc.)
cleaned the contacts on the front edge,
reseated the logic board several times,
replaced the 3.6v battery inside,
left the machine plugged into a power source and turned on for 24 hours+.

There is no sound whatsoever. Suggestions?
I am not very computer savvy either, so if anyone does have some suggestions, I may ask you to clarify since I really don't understand these things very well.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: Oct 9 2013
Posts: 367
Re: Suggestions To Help Me Get My Color Classic To Turn On

You did not mention if you checked to make sure the Power switch on the back is turned 'On' (top is pressed in) and if you were trying to turn it on via the power button on the keyboard.

Also, when you pulled the logic board you did not mention pressing the CUDA switch (honestly, I cannot remember if the CC has one, so many older Macs do but my CC is in storage so I cannot check!)
How about reseating the RAM and VRAM?

That's what comes to mind last time I had to troubleshoot one.

Here's a link to the CC Service Manual as well.
Zan

PS - Dug into my bookmarks and found the Service Manual and the helpful info FROM THIS SITE
I have used in the past. There is a LOT of info about the CC online, this was but one of the sites I delved into when I got my first CC last year.

Offline
Joined: Oct 9 2013
Posts: 367
Re: Suggestions To Help Me Get My Color Classic To Turn On

Classicmacs.org has a good troubleshooting guide as well.
Zan