Why is transwarp not emulating/adding at least 128K of AUX RAM even when there is only 64K of aux RAM plugged in //e?

9 replies [Last post]
Offline
Joined: Jun 15 2014
Posts: 305

Why is transwarp not emulating/adding at least 128K of AUX RAM even when there is only 64K of aux RAM plugged in //e's AUX slot? After all, transwarp has the neccessary dedicated shadow RAM already on board. On the other hand TW adds/emualted a 16K language card when there is no one in the Apple. The same principle should apply to auxiliary RAM. Am I missing something?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
resman's picture
Offline
Joined: Feb 9 2006
Posts: 213
Re: Why is transwarp not emulating/adding at least 128K of ...

What are you using to look for the extra AUX memory? Most software won't see it unless you use something like AE's RAM disk driver.

Offline
Joined: Jun 15 2014
Posts: 305
Re: Why is transwarp not emulating/adding at least 128K of ...

On the contrary! 128K of AUX memory are quite useful! Locksmith fast backup copies diskette in one pass, other utilities make virtual disks there. My question was about something else! The memory is there on the transwarp card already...Why is it not active (the both banks) if an ordinary 64K physical AUX ram card (80 column card) is present in a //e system...

speedyG's picture
Offline
Joined: Nov 16 2011
Posts: 2407
Re: Why is transwarp not emulating/adding at least 128K of ...

I wonder about the fact that such a "sophisticated expert" about Apple II topics
posts such a question.....
ever thought about the differences between the signals present at the normal slot
availiable ( where the accelerator is plugged at ) and the signals availiable at the
auxconnector ? Hard to believe that such an "sophisticated expert" does not think about '
the concequences resulting from that differences.... then of course it´s wasting time to explain...
such "sophisticated expert" - like you - knows the answer by himself.... correct ?

__________________

In early days I had a lot of money but no time - now I have no money but a lot of time....
the second part includes less friends but a lot more joy on life....

Offline
Joined: Jun 15 2014
Posts: 305
Re: Why is transwarp not emulating/adding at least 128K of ...

speedyG wrote:

I wonder about the fact that such a "sophisticated expert" about Apple II topics
posts such a question.....
ever thought about the differences between the signals present at the normal slot
availiable ( where the accelerator is plugged at ) and the signals availiable at the
auxconnector ? Hard to believe that such an "sophisticated expert" does not think about '
the concequences resulting from that differences.... then of course it´s wasting time to explain...
such "sophisticated expert" - like you - knows the answer by himself.... correct ?

You are really stupid, which I never doubted by looking at your underlined advices! Now I guess you're going to complain again as a child to the moderator Wink

Offline
Joined: May 27 2013
Posts: 794
Re: Why is transwarp not emulating/adding at least 128K of ...

This thread stings like a bee.

gsmcten's picture
Offline
Joined: Oct 4 2005
Posts: 2616
Re: Why is transwarp not emulating/adding at least 128K of ...

georgel,

The only question I would pose at this time is:

Did you look at the Transwarp Manual first to see if
there was an answer there?

Steven Smile

__________________

Steven (gsmcten)

"Apple ][.....It's ALIVE!!!!!"

resman's picture
Offline
Joined: Feb 9 2006
Posts: 213
Re: Why is transwarp not emulating/adding at least 128K of ...

insanitor wrote:

This thread stings like a bee.

Yep. Back away slowly....

ggb
Offline
Joined: Mar 13 2012
Posts: 31
Re: Why is transwarp not emulating/adding at least 128K of ...

georgel,
A review can be found for the Transwarp which gives a description of the ram usage and can be found at the below link. Why does it behave like you describe and not how you would like/expect. Using the description in the review it would indicate that is how it was designed to behave with supporting the Ramworks in the AUX slot. Accelerating first two AUX banks if installed.

http://www.txbobsc.com/aal/1986/aal8603.html#a7

geoffB

Offline
Joined: Jun 15 2014
Posts: 305
Re: Why is transwarp not emulating/adding at least 128K of ...

I have read the manual. But technically there is no problem for transwarp to provide its second 64K AUX bank (like it does with the language card on a ][+) even if there is no such on the non-accelerated apple //e.