68k Java Work Enviornment

No replies
Vellos's picture
Offline
Joined: Dec 19 2003
Posts: 58

It seems that there are several Java compilers for MacOS running on 68k Macs, which run under Apple's developer's kit as an add-on, or standalone, one of those being MacJikes. While it depends on the JRE (also runs on 68k in the earlier versions), the standard of Java, at least at it's core, is pretty solid in those implementations enough to work on building a few base, non-AWT or SWING based apps.

The thing is, I've been working for a few days, and I simply can't get a working, compiling Java enviornment on a 68k Mac, even though it should be possible. In MacJinks, it seems to want the MRJ 2.1 classes, and I'm trying to use an older 1.5 version of the MRJ, I'm not even sure 2.1 would work on a 68k box! I'm wondering, can I use the classes from MRJ 2.1 with the older version of the runtime, or is there some other way?

I seem to remember older versions of CodeWarrior would support Java via extensions. Anyone have experience with this?

__________________

http://vel.ath.cx:8080/