problems after ipod nano linux

21 replies [Last post]
Offline
Joined: Jan 14 2006
Posts: 6

Hello all!

I've seen your website and am begging for some form of assistance. I have a black 2 gig ipod nano. I tried to install ipod linux on it and my ipod is now messed up. When i turn it on it tries to load linux but is missing some files so doesn't. If its turned on and the cable is plugged in it will load the apple firmware. But it wont communicate with my pc. It appears in windows but windows will not let me format it. I tunes will not recognise it, and the original software cd says it needs to be formatted but the progress bar just goes on for ages saying its resetting the ipod but nothing is happening.

I have access to an ibook would this make any difference? Ive also tried using killdisk to format the ipod but it says error reading sector 0 on E:

any advise would be greatly appriciated!

Thanks Mario Cirillo

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
cwsmith's picture
Offline
Joined: Oct 13 2005
Posts: 699
There have been several forum

There have been several forums regarding this issue -- the iPod Linux site specifically states that it does not support iPod nano -- and yet people keep on trying ...

I would try using the iBook -- presuming it's a recent (white, not colored) one -- to reformat and restore the iPod to its factory settings.

If this doesn't work, I'm not sure if an Apple store will be of much help -- you probably voided whatever warranty you had when you installed iPod Linux ...

__________________

Dozens of Macs; a handful of PCs; Apple ][e, ][c and ][gs; a few iPods; lots of parts
17 guitars, 2 baritone guitars, alto guitar, 6 bass guitars, bajo sexto, 3 ukuleles, mandolin, banjo, sitar
3/4 scale upright bass, 4pc drum kit, congas, travel congas, bongos, cajon, cabasa, 12 harmonicas
http://www.cwsmith.fmhttp://www.facebook.com/cwsmith2620

iantm's picture
Offline
Joined: Apr 2 2005
Posts: 709
Apple Store

Considering past experiences with the apple store, I don't believe you'll run into issues. I've tried doing iPod linux on my 4g 60gb photo. Couldn't get it to work, ran into the same issue, had to do a hard reset (can't remember how - use the power of google) ran the restore through the iPod updater and it works fine now.

__________________

- iantm
ACPT & ACDT (long expired)
BMW Certified Technician

Offline
Joined: Jan 15 2006
Posts: 1
getting that error in killdis

getting that error in killdisk is normal, just hit I for ignore to continue on with the instructions. Find ipodMe and kill it, most likely there will be no progress in formatting it once you tell it to kill the drive so close the window at 0% then disconnect the drive and plug it back in (preferably force it into disk mode if you know the trick) now if you double click on 'my computer' and right click on removable disk (usually e:) and go to format you will see now that it is a 1.92gb disk that you can format to fat32. Do so. Now you can use the ipod updater to restore your ipod back to factory default. Fresh as new.

Offline
Joined: Jan 14 2006
Posts: 6
I was able to get it working . . .

Ipod linux isnt all that bad,
Ok when the ipod messed up this is how i fixed it. You need to go to control panel, admin tools, computer management, disk management, u will then see there is a partition on the ipod, remove it, now it is in a stable state and windows can format it. Then use the apple updator to restore ipod to factory settings.

I was not going to be beaten tho and was determine to get avi files working on my 2gig nano

Check out this site
http://ipodlinux.org/forums/viewtopic.php?t=3847
these are the instructions i used - they are verygood and take you through how to set up ur ipod with linux, mine is now dual bootable so i have the best of both worlds, ipod linux and the orginial apple firmware.

Hope this was of help . . .

Thanks for replying to my post
Mario

Offline
Joined: Jan 15 2006
Posts: 5
I removed the partition and t

I removed the partition and tried to format it and it told me it couldnt, so then i unplugged it and plugged it back in and nothing.... it doesnt show any screen or take a charge, so now im stuck.

any help would be nice. thanks

Offline
Joined: Jan 15 2006
Posts: 5
alright i fixed that problem

alright i fixed that problem by just doin the menu + select reboot, now I formated and then restored it back to its original state, and then installed linux and put the podzilla and start in the main G partition, but when it goes to boot it scrolls through a bunch of blue lettering and then stops and says somthing about podzilla.

Offline
Joined: Jan 14 2006
Posts: 6
sounds like hardware fault

if its not powering up then it sounds like a hardware fault, leave ur ipod plugged in for a few hours, could be dead battery

Offline
Joined: Jan 14 2006
Posts: 6
cant find podzilla . . .

is that what it says, it seems like you havent installed it properly and havent copied the podzilla file to the root, therfore ipod linux is trying to load the podzilla file which isnt actually there, format the ipod and restore to factory settings then follow the instructions . . . carefully in the website i posted above, that should solve your problems.
Let me knwo how it goes
mario

Offline
Joined: Jan 14 2006
Posts: 6
Re: sounds like hardware fault

mariocirillo wrote:

if its not powering up then it sounds like a hardware fault, leave ur ipod plugged in for a few hours, could be dead battery

Offline
Joined: Jan 15 2006
Posts: 5
ok i have done everything pos

ok i have done everything possible to get linux on it. I finally got it back to factory settings and then tried to put linux on it and after i install it and i unplug it and go back into disk mode to put the podzilla and start files onto the root drive it tells me i have to format the drive. I've reformated and installed at least 10 times and the same thing always happends. I followed the istructions from that site to a t and still dont know whats wrong. I'm gonna try it on another computer and see what happends.

Thanks for the replys

Offline
Joined: Jan 15 2006
Posts: 5
it works!

well i have no idea what i did but i woke up this morning and tried to install it again and it worked! i was able to access the drive after the install and put the podzilla and start files in the root and it booted up perfectly. I did mess around a little with the partitions using 7tools partition manager but thats all. Thanks for all your help guys.

now my next question is, will the convertion of video files always output a larger file than the original. And is there anyway to make them smaller?

Offline
Joined: Jan 19 2006
Posts: 1
Damnit

Hi...been following these posts to make sure there was a way out of anything that went wrong. Well...Im screwed now. Made the same mistake joe did. It didnt really say WHEN to copy the podzilla and start files into the G drive. So I tried to format and it wouldnt let me. Then i did what the other guy said (cant remember the name at the moment). I deleted the partition which was about 35 megs or so. NOW my iPod looks like an OLD mac program in black and white and I still cant format like he said I could. I cant restore I cant do anything. I think I'm gonna slowly have to accept that i know longer have a nano. Any help would be greatly appreciated, but I'm sure u already know that.

Thanks

Offline
Joined: Jan 14 2006
Posts: 6
this is what to do now

mate uve removed the partition, try using a free app on da internet called killdisk, they have a free version, u can format it using that and then use the ipod recovery app from the apple website to install ur firmware back on it, u will not loose ur nano . . . there is always a way!

Offline
Joined: Jan 15 2006
Posts: 5
as long as you can get into d

as long as you can get into disk mode theres still hope, so just reboot and go into disk mode and partition it using eather the hp format tool, 7tools partition manager or some other partitioning program. Get to disk mode by pressing the play + select buttons as soon as the ipod displays the apple logo without the backlight on. I too thought i was screwed the first time, but got outta it.

Offline
Joined: Jan 24 2006
Posts: 1
my nano not work

hey can ne1 help me i used linux for my nano and now it doesnt work. i cant format my ipod because it says insert disk into drive E when its in there already, and i cant restore using the updater because it says insert ipod plz help

Offline
Joined: Aug 28 2006
Posts: 3
Re: I was able to get it working . . .

mariocirillo wrote:

Ipod linux isnt all that bad,
Ok when the ipod messed up this is how i fixed it. You need to go to control panel, admin tools, computer management, disk management, u will then see there is a partition on the ipod, remove it, now it is in a stable state and windows can format it. Then use the apple updator to restore ipod to factory settings.

I was not going to be beaten tho and was determine to get avi files working on my 2gig nano

Check out this site
http://ipodlinux.org/forums/viewtopic.php?t=3847
these are the instructions i used - they are verygood and take you through how to set up ur ipod with linux, mine is now dual bootable so i have the best of both worlds, ipod linux and the orginial apple firmware.

Hope this was of help . . .

Thanks for replying to my post
Mario

My Ipod is plugged in but I can't remove the partition cause it doesn't show up.

__________________

My Ipod nano is fucked up. I put on Linux but not podzilla, now I can't put music on or uninstall linux.

Offline
Joined: Aug 28 2006
Posts: 3
Re: I was able to get it working . . .

triple post

__________________

My Ipod nano is fucked up. I put on Linux but not podzilla, now I can't put music on or uninstall linux.

Offline
Joined: Aug 28 2006
Posts: 3
Re: I was able to get it working . . .

triple post

__________________

My Ipod nano is fucked up. I put on Linux but not podzilla, now I can't put music on or uninstall linux.

gobabushka's picture
Offline
Joined: Apr 26 2004
Posts: 494
Kiwi...

Just my opinion, but shouldn't this be in Kiwi?

__________________

"I reject your reality and substute my own!!!" -Adam Savage, MythBusters

Offline
Joined: Sep 6 2006
Posts: 1
im so scared

my ipod has this same message

alright i fixed that problem by just doin the menu + select reboot, now I formated and then restored it back to its original state, and then installed linux and put the podzilla and start in the main G partition, but when it goes to boot it scrolls through a bunch of blue lettering and then stops and says somthing about podzilla.

i dont know what to do please tell me, email me on

please

gobabushka's picture
Offline
Joined: Apr 26 2004
Posts: 494
ok, my suggestion would be to

ok, my suggestion would be to remove all oof the partitions, reformat it, and restore it using the ipod updater. then wait until ipodlinux supports the nano. thts what im doing with my 5g ipod!

__________________

"I reject your reality and substute my own!!!" -Adam Savage, MythBusters