Add a fan to Rev F iMac

1 reply [Last post]
Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804

The hack:
I'm going to put a fan in this fan-less iMac. I notices some solder points on the mobo near the filter board. IIRC it was a two pin header looking point labled J4. Anyone know if it's an unused fan plug, or should I just tap the HDD power connector?

The low-down:
I got a blueberry SL 350MHz iMac on Sat. It was a chore to troubleshoot all the various problems with it, but for the purchase price of $10 and the assurance that it was dead, I gave my hardware hacker-fu a workout this weekend. This is the first iMac I've laid a hand to except those at a store. Turns out that someone must have tried an OS X upgrade without RTFM, and butchered an iMac to get the HDD out of the iMac they "killed". Various things wrong with the iMac such as the missing HDD and RAM, and the symptoms of death lead me to believe that someone went in "the hardway" when their upgrade failed. The speakers were missing, and when I opened the case I saw that the wires were cut. They must have thought that you needed to pull the speakers to get to the HDD... Or they really liked the HKs. They left the cd-rom, but it was missing two mounting screws and it refused to take any CDs. There was a bent pin on the mobo drive connector, which I think they did it their hurry to pull the HDD.

When I got good RAM in it (two 64MB PC100 DIMMs) I found that it started without video most of the time. The problem was compounded by the fact that the cd-rom wouldn't work, and it wouldn't boot off my external USB cd-rom. I pulled the internal drive, disassembled it, saw the messed up mechanism (the magnetic disc retainer was loose inside the drive) and fixed it. Now it would take a cd just fine. It would boot a cd just fine. There was still no video. Not fine.

I played and played with stuff, thinking a hardware fault (it IS an iMac...) until I stumbled across the sleep/wake cycle restoring video on a booted system. I looked on the internet, and this is a sign of a borked firmware after a failed OS X install. If the FW isn't upgraded before OS X, then very strange things happen to iMacs. To top it off I also found out that the PRAM battery was flat, but that was the easiest fix fo them all. To fix the FW I needed a HDD.

I installed a 6.5GB 2.5" drive where the 3.5" goes, but turned slightly to catch a a vent hole so it is secured by two screws instead of one. Booted off an OS 9 cd, did the sleep/wake thing, and installed. The video pops on, but it is always messed up in some random way. Got on the 'net got the FW update. Didn't work, as it needs 9.1 to work. I didn't RTFM: Grrr! So I was lucky to have a copy of the 9.1 update on a Mac in the lab, err, basement. That saved me several hours on dialup... Updated the iMac, ran the FW update, and bingo! the video works.

Now it dual boots OS X.2/9.1 and soon will have YDL or something on it. I just need more RAM, and the speakers...

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
Thursday is hack day this wee

Thursday is hack day this week! I went to Micro Center and bought one of these because it was the only fan that listed the actual dBa for 5v power. I know other fans might be just as quiet, but at 20 dB @ 1400RPM I though the $9.99 for the fan and guard was a decent deal. Included in the package is a ZM-MC1 which powers 4 fans on a single molex. The problem with that is that the iMac only has one molex connector and I am not sure where a spare Y adapter is around here. It turns out I had this leftover from putting this Antec fan in a Gateway Celery Stick. I modified it to have the fan power going to 5v and put the 12v supply line for a Napolex Fizz-563 sound responsive EL strip kit. I mounted the fan onto the EMI sheilding where the VGA connector would be. The 80MM fan just fits into the opening when the cover if removed, blowing inward. A 60 or 40MM would fit very nicely. It required some finageling to get the fan and the case together. The case won't go on if the fan is installed first and the video heatsink was in the way of putting one mounting screw through when putting the fan on after assembling the case. I had to put that one screw in the hole before putting the EMI shield back on,then finish with the case, then install the fan. Mean while I had mounted the EL strip in the case in the area below the CD and below and between the headphone ports and the power button. I mounted the control unit/mic where the left speaker would go. Now after running the iMac for 1.5-2 hours the top of the case is warm, but not hot like it used to be. At 5v the fan is totally unnoticable over the laptop HDD, ie. the iMac is still nearly silent and has some nifty blue flashy stuff when sounds come out at a voice level or more. Cool Mac

Jon.

No one should be protected from the effects of his own stupidity. - Anton Szandor LaVey in 1988 (There is a certain irony in this quote... Tongue) Cool Mac

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls