My Replica Apple 1 (By Steve G.)

5 replies [Last post]
Offline
Joined: Sep 3 2005
Posts: 93

I have just finished building this.

Unfortunately it has a problem with the keyboard output. Basiacally, when I push a 'Q' a 'I' will appear on the screen.
As far as I can tell there is a problem with the 5th and 6th bit in the 8 bit sequence that the keyboard sends. They get scrambled somehow.

I'm racking my brain as to what it could be. I've checked all the soldering and it looks good. Checked the keyboard adaptor I built, no shorts or misconnected wires.

Anyway, enjoy the photo. Hopefully I can get it working soon.

Phil

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: Sep 3 2005
Posts: 93
Errr...how do I ad pictures?

Errr...how do I add pictures? I'll look into it...back in a while.

Offline
Joined: Sep 3 2005
Posts: 93
Figured it...

Ok, you can see it here:

http://www.applefritter.com/node/17740

Phil

My (Steve G) Replica Apple 1

Image added - Tom

Ex-parrot's picture
Offline
Joined: Dec 20 2003
Posts: 6835
Once again my congratulations

Once again my congratulations on a nicely finished computer.

__________________

Michael

6502enhanced's picture
Offline
Joined: Feb 23 2006
Posts: 252
Fantastic I Replica ! Cong

Fantastic I Replica !

Congratulations !

Offline
Joined: Sep 3 2005
Posts: 93
Thanks guys

I really tried hard to make it as simple and elegant as possible. Now I just need to get it working properly!

Phil