need help with cinema display 22" dvi

3 replies [Last post]
chris501's picture
Offline
Joined: Apr 5 2005
Posts: 232

hi fritterers!

as always, you are my last chance to get a bit of insight into this. here is the story:

a friend gave me his old non-working 22" cinema display with DVI connector as a present (well, i believe he gave it to me because he was to lazy to dump it himself Wink). if you connect it to the power supply no lights go on or something like at. seems like it's dead.

here is my question: does somebody have knowledge of the pinouts of that power supply? i just want to check if there's something coming out from it at all. the apple model number of the power supply was M5683. the model number of the display is M5662.

i hope it's not the mainboard, because then i can take it to the nearest landfill...

thanks, chris

__________________

PM G5 1.8GHz SP / PB 12" 800MHz / Acer 3.0GHz HT / Compaq 386@25MHz / Apple Certified Technician & Help Desk Specialist

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
chris501's picture
Offline
Joined: Apr 5 2005
Posts: 232
so far so good

ok. after fiddling around a bit (and disassembling the monitor) i decided to open the power supply. those two plastic shells weren't a problem, but the gray plastics on the rest of the power supply don't seem to go off. i tried to crack it open for over an hour, at the moment i would love to smash that thing on the next wall.

btw, the display looks good, no smell inside or visual damaged components.

any ideas???

__________________

PM G5 1.8GHz SP / PB 12" 800MHz / Acer 3.0GHz HT / Compaq 386@25MHz / Apple Certified Technician & Help Desk Specialist

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
Have you checked for blown fu

Have you checked for blown fuses and loose cables? Have you checked that the power jack is solid and the solder joints aren't cracked? What does he say is the reason it died? Did it just not come on one day?

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

chris501's picture
Offline
Joined: Apr 5 2005
Posts: 232
sorry for the late reply...

...but i had a lot of work and was on holidays too. no loose cables anywhere, it seems that a capacitor in the power supply has blown up. ordered one from the netherlands, plugged the display back in = TADAAA = works fine... thanks anyway!

__________________

PM G5 1.8GHz SP / PB 12" 800MHz / Acer 3.0GHz HT / Compaq 386@25MHz / Apple Certified Technician & Help Desk Specialist