Trayloader Imac 333

9 replies [Last post]
Offline
Joined: Oct 17 2006
Posts: 84

I picked up several Imac Trayloaders inexpensively at an end of life computer recycler (which might should tell me something?)

Anyway, I have a known good hard drive that I moved from 1 trayloader motherboard chasis to a second chasis. The second chasis will not boot from the known good hard drive (the memory specs, etc are the same).

Already re-set cuda a few times, made sure the pram battery is set fine, and tried it again.

The flashing ? then OS smiley then ? comes up each time.

Before I try substituting known good processor boards, memory board, and anything else that is swapable, I thought I would try to tap into the applefritter experiences to see if there is a recommended order to swap out the components, or other useful information.

I may need to think about parting them out, but I want to be sure that parting out is really the best thing going. I would prefer to keep them as reasonable lowend macs for people on dial up, etc.

Any background information would be appreciated.

BTW: I do have a range of hammer sizes if I need to resort to that ... hmmmmm.

Thank you.

David

__________________

David Johansson
DHJ'S LLC
1 person computer services co. in Pryor, OK.
[http://360.yahoo.com/dhjsllc]
G4 AGP 450 Sawtooth
1 Gig Ram 80G HD + Tiger
"Darkside:" Dell Inspiron 9300; 512 RAM, 60 G HD Win XP
Also Trayloader G3-333, EMac-700mhz

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975
you need to reinstall the system

I want to say this in general to people that ask this (Not to be as a bad remark, but an informative statement) if you see a flashing "?" it means it cannot find the Operating System. All you need to do is reinstall, or if you can't get the hard drive to work, get a new one and reinstall.
This might entail getting a new OS, or getting the original OS to work with.
in dhjsllc's case, all he probably needs to do is reinstall the system

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/

doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355
to follow on that...

Will the machine boot up with a CD for 8.1 or highgher (do not try OS X)?

If you can boot with the CD, see if you can then access the HD.

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'

Offline
Joined: Oct 17 2006
Posts: 84
Additional details/update on Trayloader issue(s)

In making a first pass through the 10 or so machines: Several would not boot and/or the cd drive was not operational. About 4 worked fine ... but I still did a clean OS install on those.

For the reamining computers, first I pulled, re-formated, and then installed OS 9.2 (using an Emac + external enclosure on the drives.

A known good hard drive was then installed into the logic board chasis, and that unit was then installed the same known good monitor chasis (one at a time (Smile). There were several logic bard chasis that did not work properly on the first round. Many would not boot either before or after the hard drive was re-worked, but a couple worked just fine after that.

I did not think to then try booting from the OS 9 CD-ROM on that round of testing ... (major oversight) ... but I will do that -- after carefully pulling, inspecting, and re-seating the cpu board, video memory, and anything else that plugs/unplugs easily in the next round of testing -- both above deck, and below in the metal housing. (Fortunately, I am dealing with a small number of computers, and no one is waiting on the machines.)

Hopefully some of the computers will spring to life after that round, if not all.

I enjoy helping people "swear" by their computers ... not at the computers. I appreciate the information provided so that I can be sure that the Imacs really are at the life cycle end, even if the true economics of the endeaver may be questionable. I am learning a lot, and enjoy both the hands on learning and challenges.

Off topic somewhat: Rumor has it that a newspaper press broke down at the start of the press run many years ago [Circa 1950?.] An engineer was called in immediately to try to meet the schedule. After about two minutes, the engineer looked around, pick up a near by sledge hammer, and struck the press with a mighty blow.
The press then worked perfectly. The engineer handed the owner a bill for $100.00. The owner was ready to protest ... until he read the itemization: Strike press with sledge hammer: $1.00 Knowing where and how hard to place the blow: $99.00.

David

__________________

David Johansson
DHJ'S LLC
1 person computer services co. in Pryor, OK.
[http://360.yahoo.com/dhjsllc]
G4 AGP 450 Sawtooth
1 Gig Ram 80G HD + Tiger
"Darkside:" Dell Inspiron 9300; 512 RAM, 60 G HD Win XP
Also Trayloader G3-333, EMac-700mhz

Offline
Joined: Oct 17 2006
Posts: 84
Tray Loaders update: Boot CD, Not HD

I did have this question ... until I dug on the Apple web site and found http://docs.info.apple.com/article.html?artnum=58042
Moderator: please modify that to be a clickable link ... (Smile

After reading that, and poking around some, the solution was found:

The computer needed to be told to use the hard drive as the start up drive ...

After making that change, and re-booting: No flashing ? sitting there!

I was hoping for a "simple" fix ... and found one!

I like it when the Macs have something to smile about when they are started up!

Thank you to everyone that passed on troubleshooting tips, things to try, and for the people doing all the behind the scenes things to keep Applefritter alive, well, and extremely helpful.

[And a Happy, Safe New years to all!]

_________ Original post that I found a solution to ____________

The one I am working on now will boot from the CD-ROM, let me install OS 9.2.1 onto the hard drive, then let me explore and open files on the hard drive, and seem to work fine so far.

HOWEVER, when I re-start the machine and remove the CD-ROM, the machine goes to the flashing ? OS Smile ? ... looking for the operating system.

What are the typical reasons this problem arises?

I am guessing: incorrect jumpers on a hard drive (slave vs master), bad cable from drive to logic board, bad IDE Controler for HD, but I do not know enough about these to know for sure.

These trayloaders had drives from three different companies:
Western Digital. [WD Caviar series jumper is in a neutral position on the bottom row. Bottom row left to right: ooXXo where XX is the jumper.]

Maxtor. Model 9064803 has 2 jumpers installed: XX is jumper 1 YY is Jumper 2
XYYoo
Xoooo

Quantum 6.0 G FBCRA 655-0695 ML915060BFJVA
Fireball CR

Xooo
Xooo

I am guessing that the jumpers were set by the school system that owned the computers ... but whether these drives were jumpered to not boot directly (in favor of a network connection) or not I do not know.

Any comments on the preferred jumper patterns for these drives as the only HD in the computers would also be appreciated.

BYTW: Any recommendations -- with availability information -- for service manuals for multiple Apple models (for purchase)?

I have seen some listed as available on CD for most of the Apple models. However some of those may be of better quality (added features?) than other ones.
I would prefer to hear what sources are recommended for someone just breaking into Apple Repairs ... other than the best/preferred source: official Apple Training.

Thank you.

David Johansson

__________________

David Johansson
DHJ'S LLC
1 person computer services co. in Pryor, OK.
[http://360.yahoo.com/dhjsllc]
G4 AGP 450 Sawtooth
1 Gig Ram 80G HD + Tiger
"Darkside:" Dell Inspiron 9300; 512 RAM, 60 G HD Win XP
Also Trayloader G3-333, EMac-700mhz

Offline
Joined: Jan 18 2007
Posts: 1
More on the Topic:

I recently acquired a Green iMac G3 333 Mhz from a friend. I took out the 6 GB HDD, put in a 160 GB. These computers can only recognize about 128 GB, but that's awesome for this computer anyway so we won't complain. I then partitioned the "128" GB HD. One partition being 28GB, the other being 100 GB, respectively. Despite what people say, this iMac, being nearly ten years old, runs Mac OS X 10.4 Tiger on 256 MB of RAM without a problem. It is a little slow, but regardlessly works fine. I installed Tiger on the 28 GB partition, leaving 100 GB of emptyness just for me. I set up the computer within my home network, giving my younger siblings personal accounts for homework, internet, music, etc. I also set up the computer to grant FTP access to me. This means that, through my wireless router, I can connect wirelessly to the iMac with my PowerBook and use the 100 GB partition as network storage. Not bad for an old iMac 333. Oh, and unless your home internet is dial-up, there's no need to restrict your internet use to that. With Mac OS X, setting up for broadband is not a problem- plug in the cable. Even if you don't want to upgrade the HDD's, 6GB is still plenty of space to run OS X and store a few files for, say, homework/internet useage. Heck, with sharing on (and the iMac itself as well), you can also use the iMac 333 as a print server. In OS X, just go to System Preferences>Sharing> and check the box for Printer Sharing. Great for multiple computer use with only one USB printer. On the other computers that want to use the printer, just use Printer Setup Utility and click Add Printer, or whatever it says. It should show up under "Bonjour" printers or "Rendezvous" printers on a Mac running 10.3.x or 10.4.x and maybe earlier ones as well.

Only regrets: ethernet port is a little slow, so wireless storage access is only good for so big of a file without being annoying, also the iMac can only handle a disk access speed of so much, again slowing things down. Not being able to read DVD's on my CD-ROM drive also is annoying, but could be upgraded if I had a good enough graphics card for it to matter. Frame Rate for visuals is like crap (same as back in th' day). And no FireWire Sad

Offline
Joined: Feb 19 2007
Posts: 1
howja do that?

Apollyon, My sis-in-law gave us a Green G3/333 imac as well. I want to set it up for the children but cannot figure out how to get it on our airport extreme network. What you've done is fascinating andexactly what I had in m iind except I had no idea how to do it being fairly new to Mac/Apple.

Any advice you can pass along would be welcome. The OS we have now is 8.6 and it has the original 6 gb hd.

Very much looking forward to learning some of your knowledge.

Tom

Offline
Joined: Sep 23 2005
Posts: 316
.....

Well, im not really sure what Apollyon is talking about, but if you want to run OS X on a trayloader machine the the drive must be formatted into at least two partitions, and the FIRST partition must be less than 8gb. The first partition (less than 8gb) is where OS X will be installed. Also to then use the wireless network you would ned a usb wireless adapter, plugged into one of the iMacs twwo USB ports.

Oelmuvun's picture
Offline
Joined: Nov 27 2005
Posts: 62
Re: More on the Topic:

Apollyon wrote:

These computers can only recognize about 128 GB, but that's awesome for this computer anyway so we won't complain.

Look into Intech's ATA Hi-Cap Driver, I have it installed on my Sawtooth for use with it's 250GB HD and it works well.

__________________

OS 9: Beige G3(AT case), 433MHz(350B&W CPU), 768MB RAM, 64MB Radeon 7000, 10/100 NIC, USB1, 80GB 7200RPM HDD
OS X: Digital Audio(ATX case), 1GHz 7455, 1.5GB RAM, 256MB GeForce 6200, SATA, USB2, 500GB HDD

Offline
Joined: Oct 17 2006
Posts: 84
Imac G3 - 333 fix/update

Hello all:

Summary: If you buy a used Imac that will not boot from the internal HD unless you have the install CD and install the OS first:

[no matter how many times you install the OS from CD, upon restarting you teh no OS found flashing indicator]:

See if the previous owner changed or removed the jumper on the back of the hard drive ... as was the problem in my case. The hard drive needed to have the jumper designating it as the master drive installed. It had apparently been removed when the Imac was used as a client on a school network.

Retelling in more detail:

When I booted from CD and installed OS 9.22 on the HD all was fine with the Imac trayloader 333mhz with 96 megs.

I could do what ever I wanted ... until I re-started the Mac.

Upon restarting the Mac w/o the OS CD in the CD drive, no operating system present (Flashing file folder/flashing ?) would come up. [Dang!]

Yesterday, I had one (of the 12 +) G3's apart. It would boot into the OS the previous owner left on the Mac. I then swapped out the HD for another HD that had a fresh install of OS 9.22 on it. The missing OS flasher came up. How does that happen?

The previous owner used the Imacs on a school network where they wanted the primary boot drive to be the server it was networked to.
The internal drive had the server client 9.22.

No jumper was on the internal drive, so the client os 9.22 started up. With no server to attach to, there were still things that could be done on the Mac.

But when I re-formated that drive with OS 9.22, the internal drive still had no jumper. The Imac now would not recognize the internal drive as the drive it could boot up on, even though it recognized the drive and booted when it had OS 9.22 Client installed.

After installing the jumper to indicate the 6 GB is now the master HD, everthing booted up perfectly in OS 9.22. I could now do what ever I wanted to do with no problems.

The same remedy should be able to be applied to the remaining 6 +/- computers that were behaving in a similar fashion, too!

Perhaps this posting will help others, too!

David Johansson

__________________

David Johansson
DHJ'S LLC
1 person computer services co. in Pryor, OK.
[http://360.yahoo.com/dhjsllc]
G4 AGP 450 Sawtooth
1 Gig Ram 80G HD + Tiger
"Darkside:" Dell Inspiron 9300; 512 RAM, 60 G HD Win XP
Also Trayloader G3-333, EMac-700mhz