dropping a Yikes! G4 into a B&W G3

4 replies [Last post]
coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975

I got a G4 CPU from another fritter, but when i put it into my G3, it gives out 5-beeps. I am not sure if I am doing this wrong, but I have set various speeds and can't figure it out. Is there a firmware patch i need to apply?

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Eudimorphodon's picture
Offline
Joined: Dec 21 2003
Posts: 1203
Yeah.

You're hitting the infamous Apple G4 firmware block. You need to put the G3 ZIF back in the machine and run a firmware hacker from a third-party upgrade manufacturer.

Googling should net you what you need. I think I used This one for XLR8 upgrades when doing this myself.

--Peace

coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975
any idea how to do this?

i followed the instructions, but I have the G3 1.x firmware in it now, and I see reports that these don't work with that.
I followed like it said, ya'know, press the front interrupt button when booting, yadayadayada, but it will boot right back up after it restarts, gets into OS 9, then says it didn't update

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/

Eudimorphodon's picture
Offline
Joined: Dec 21 2003
Posts: 1203
Well...

My G3 already had the newest Apple firmware installed before I started. You'll probably want to ensure that's the case?

I just followed the instructions and it worked. I think the key is following them *to the letter*. That whole interrupt button thing is bad voodoo.

--Peace

coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975
Hot damn!

it works! i got a G4!

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/