Slow boot up on clamshell w/ 9.2.2

7 replies [Last post]
doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355

Clamshell iBook running 9.2.2 w. WiFi and plenty of RAM:
During boot up, After the desktop is drawn with all icons, and all Finder windows are poped up (if any were left open at last shutdown) and before the control strip displays, the system freezes for up to a full minute.

The last time this happened, I trashed all my preferences and did a few other things, but the process was non-repeatable and destroyed many of my user settings to fix. Is there some app that will display the processes running as they run, especially during boot up?

I want to know what my Mac is doing when it is 'thinking' but not responding during this period. I also observe similar behavior during wake-up from sleep. The problem is not affected (clearly, at least) by the WiFi card.

Sometimes on wake-up, the system hangs entirely and requires full restart. I need to retune this machine but do not know where to start.

TIA

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
MacsBug

Dropping into MacsBug may give you some clues. You do have MacsBug installed and know how to use, don't you? Cool Mac

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355
sake of argument...

Let's "pretend" that I do (now) ... Wink

...and for the sake of the reader community, you are going to tell us all where to dowload a copy, aren't you?

*EDIT* here is the link.

...and how to use it, too.

*EDIT* RTMFM, ehh? Wink

*EDIT #3* Too bad the MFM does not tell how or where to read a log of boot tevents... [hint-hint]

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'

Macinjosh's picture
Offline
Joined: Feb 12 2004
Posts: 216
I'll Guess...

.. that it's the Web Sharing trying to gain a connection outward, and not being able to.

Is it enabled?

-- Macinjosh

doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355
Hmmm...

...that was an interesting idea. I checked and my Control Strip module for Web Sharing was disabled BUT my Extension for it was not. I moved it over and reboted.

After reboot, the time lag was still there. I have thought for some time that it was looking for a network connection of some kind and unable to find it (yet no error message).

a more exact time line:

  • Normal boot window, active extensions going across the screen
  • clock shows in menu bar
  • HD icon appears on destop
  • all other menu items and desktop icons appear as well as any open Finder windows
  • systems hangs about 90 seconds
  • Startup items run
  • Message from my DHCP server appears leeting me know it found my WiFi network
  • Control Strip appears

When no Finder windows need to be opened up, the hang occurrs after Startup items run (these are things like Darkside and IP Monitor)

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'

doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355
sigh...

...okay, so I invoked the "g" word and the magical incantation that it was spit back a few sites with some how-to-use-the-fool-thing info.

After I actually read it, I will try it out (later this evening).

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'

dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
macsbug article

Maybe this will help, an old article I found entitled MacsBug for Non-Programmers.
* (Reprinted from the 1998.03.09 and 1998.03.16 issues of MWJ, the Weekly Journal for Serious Macintosh Users.)

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355
Eureka!

william ahearn wrote:

Check the servers folder in your system folder. If it's full of server icons, trash them. Just a suggestion.

Well, it was not full, but it did have a server in there that is not currently an active machine in my network. Removing the offending icon solved the problem.

Thanks to all for the help, and a special thanks to William - I knew I was missing something obvious and simple.

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'