LC 475 Compatible Hard Disks

13 replies [Last post]
Offline
Joined: Mar 24 2007
Posts: 15

I posted a few months back about having an LC475 with a faulty internal SCSI drive. I've had no luck getting hold of a proper (i.e. Apple-branded Quantum ProDrive) drive for it but I recently won a 2.1GB SCSI Quantum Fireball off eBay.

I connected it all up, sorted out the SCSI ID (set it to zero) and termination but sadly my OS 7.5 install disks won't see the hard drive. I tried running Disk Tools with no success - it just says it's scanning the SCSI bus then reports "no suitable drives detected" or words to that effect.

The drive definately spins up and clicks a couple of times so both power and SCSI connectivity is physically there. I'm just wondering:

1. Can an LC475 handle a 2.1GB hard drive?
2. Do Quantum Fireball drives work on LC475s?
3. Is there a more serious hardware issue (e.g. blown SCSI controller, etc.)?
4. Is System 7.5 the wrong OS to be trying to install?

Would really appreciate anyone's views on all this!

Thanks

Chris

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Hawaii Cruiser's picture
Offline
Joined: Jan 20 2005
Posts: 1434
Why don't you try it with the

Why don't you try it with the SCSI ID set to something other than 0 or 7. It's been a long time for me, but I think I remember 0 being reserved for something on some older Macs. Do you have access to another Mac with a SCSI bus?

Offline
Joined: Mar 24 2007
Posts: 15
I can certainly give it a try

I can certainly give it a try, although looking at the old ProDrive I took out that seems to be using ID 0 (there are no jumpers in place). Unfourtunately the only other Mac I own is a Mac Mini so I can't try the drive out.

That said, I have a feeling I have an old ISA SCSI card so could fit it to and old PC and try it that way. I'm wondering if the 475 or System 7.5 simply doesn't support drives that size?

Offline
Joined: Jan 14 2007
Posts: 208
Drive size

Hey,

System 7.5 will handle the size of the drive with no problem. Make sure the ribbon cable is connected properly (all the way in, not upside down, etc), and try another utility like Mt Everything or a SCSI utility. This should be a pretty simple operation but you know how that goes.

William
www.williamahearn.com

Offline
Joined: Mar 24 2007
Posts: 15
Tried it set to ID 1 with no

Tried it set to ID 1 with no luck. I could keep working my way along but I get the impression it'll be the same. Does anyone have any suggestions?

dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
non-Apple branded SCSI drive

1: yes
2: yes
3: no (prob not anyhow)
4: no

Your problem is that Disk Tools won't 'see' non-Apple branded SCSI drives. The solution is to use either a hacked version of Apple's utility or another third-party utility to initialize the drive. Gamba's drive utilities page is a great place to start.

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

alk's picture
alk
Offline
Joined: Dec 20 2003
Posts: 373
Whither ResExcellence? For s

Whither ResExcellence? For shame!

They used to have a great page on how to modifry Drive Setup and HD SC Setup to work with 3rd party drives. Alas, the clowns (I would use harsher language, but this is a public space) at ResExcellence ruined it for everyone by fighting over the domain.

I'm glad to see that Gamba has info on the patch for HD SC Setup.

FYI, in my experience, Silver Lining and FWB HD Speed Tools are the best tools if you can't go with an Apple disk formatter.

Peace,
Drew

__________________

Read the 5300 FAQ: http://www.alksoft.com/5300_FAQ/
Join the Resistance! Enlist in the PowerPC Macintosh Liberation Army!

Offline
Joined: Mar 24 2007
Posts: 15
Right, I think I know what th

[edit: ah, I see someone beat me to it!]

Right, I think I know what the problem is. I'm guessing as the drive isn't an Apple branded one, Drive Setup is refusing to recognise it.

This is all documented here: http://lowendmac.com/sable/07/0425.html

The problem I have is that I have a Mac Mini with no floppy drive, a PC running Windows XP and my sad little 475 and for the life of me I can't get the patched version of Drive Setup onto a floppy disk! Can anyone assist? I'd love to get the 475 up and running again...

Offline
Joined: Mar 24 2007
Posts: 15
Excellent! Thank you very mu

Excellent! Thank you very much for that link. I'm going to try the patched version of HD SC Setup but do you know how I can get it onto a floppy?

cwsmith's picture
Offline
Joined: Oct 13 2005
Posts: 699
USB floppy drive?

CompUseless has a store-branded drive that works just fine under OS X. Plug it into an open USB drive and voila!

Be sure to format your disk for "Mac OS Standard" or "Mac OS Extended" so the LC 475 can see it.

__________________

Dozens of Macs; a handful of PCs; Apple ][e, ][c and ][gs; a few iPods; lots of parts
17 guitars, 2 baritone guitars, alto guitar, 6 bass guitars, bajo sexto, 3 ukuleles, mandolin, banjo, sitar
3/4 scale upright bass, 4pc drum kit, congas, travel congas, bongos, cajon, cabasa, 12 harmonicas
http://www.cwsmith.fmhttp://www.facebook.com/cwsmith2620

Offline
Joined: Mar 24 2007
Posts: 15
Is there an alternative way u

Is there an alternative way using a PC?

Offline
Joined: Mar 24 2007
Posts: 15
Okay! Have made some signifi

Okay! Have made some significant progress so I thought I'd post what I've had to do...

1. Downloaded a 7.5 Disk Tools image from Gamba's page

2. Used a Windows 95 VMware Server Virtual Machine and Gemulator Expander to write the image to a 3.5" floppy disk (Gemulator Explorer hangs under Windows XP but works fine when run in a Windows 95 VM)

3. Downloaded the patched HD SC Setup Utility from Gamba's site

4. Used TransMac to transfer the .bin over to the floppy

5. Booted the LC475 off the floppy

6. Launched the patch .sea file which unstuffed itself onto the floppy

7. Launched the patched Drive Setup utility

8. It detected the drive!!

9. Just ran an initialization (took about 5 mins to do 2.1GB)

10. Initialisation completed fine - was going to partition the drive but then realised it has already been formatted to 2.1GB so didn't bother.

Just about to install 7.5 now...

alk's picture
alk
Offline
Joined: Dec 20 2003
Posts: 373
Er, Mac OS Extended won't hel

Er, Mac OS Extended won't help.

HFS+ is available in OS 8.1 or later only, and at that, HFS+ disks are only bootable on PowerPC Macs. If this will be used in an LC 475, it's pretty unlikely that the OP wants and HFS+ disk. Wink

Peace,
Drew

__________________

Read the 5300 FAQ: http://www.alksoft.com/5300_FAQ/
Join the Resistance! Enlist in the PowerPC Macintosh Liberation Army!

Offline
Joined: Mar 24 2007
Posts: 15
Seems Disk 3 of my installati

Seems Disk 3 of my installation set is damaged as it kept failing when trying to install the New York font. I finally managed to get a minimal system installation on so at least I know the hard disk works.

I found a link from Gamba's site to the 7.5 install disks but neither Gemulator Explorer nor Transmac will write them to floppy (they decompress as .img files but the LC says they're unreadable) - any suggestions?