iBook G3 700 MHZ is now 500 MHZ

14 replies [Last post]
Offline
Joined: Apr 20 2008
Posts: 8

Hey guys, I was wondering if you could help me out with this.

I recently purchased an iBook G3 700 MHZ (eBay), to upgrade and mod. I took it all apart, spray painted the panels, then replaced the Hard Drive, upgraded the RAM to 640 MB, installed an Airport card, and loaded Tiger on it.

After putting it all back together (it actually worked), I happened to look at the CPU speed in the Hardware overview and now it reads as a 500 MHZ iBook. Everything runs ok, except for Quicktime movies (very choppy).

I'm 99% sure this was a 700 MHZ model, when I hacked it open. I mean, it has 16 MB of video RAM, which is indicative of only 600-700 MHZ models.

I read around the web and found some information about power PCs throttling back when not being utilized fully. I'm pretty sure that is not what is happening here, since the 500 MHZ display never differs, regardless of what tasks I perform.

What is going on? Did I damage something? Do I need to update some system profiles? Is this just a glitch?

I would appreciate any feedback on the matter...

Aaron

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
cwsmith's picture
Offline
Joined: Oct 13 2005
Posts: 699
Are you *certain* it was a 700?

Lift up the keyboard and check the system spec on the sticker inside. It should tell you the processor speed, along with the RAM, HD, and optical drive stats the machine shipped out with from the factory.

If you like, send me a private message with the serial number (don't post the SN in a public forum), and I'll check it against Apple's database for the machine's original specs.

__________________

Dozens of Macs; a handful of PCs; Apple ][e, ][c and ][gs; a few iPods; lots of parts
17 guitars, 2 baritone guitars, alto guitar, 6 bass guitars, bajo sexto, 3 ukuleles, mandolin, banjo, sitar
3/4 scale upright bass, 4pc drum kit, congas, travel congas, bongos, cajon, cabasa, 12 harmonicas
http://www.cwsmith.fmhttp://www.facebook.com/cwsmith2620

Offline
Joined: Apr 20 2008
Posts: 8
700 MHZ confirmed

Yeah, I should have checked that earlier.

However, it is (indeed) a 700 MHZ model.

How bizarre is this situation?

Any suggestions?

iantm's picture
Offline
Joined: Apr 2 2005
Posts: 709
Verify that the serial number

Verify that the serial number on the logic board - available by clicking on where it says the version in "About this mac" is the same as the one on the plastics. Also, verify the specs in Apple System profiler. It wouldn't shock me if a 500mhz board found its way into a 700mhz machine. (well, a 12" anyway - as there was no 500mhz 14")

__________________

- iantm
ACPT & ACDT (long expired)
BMW Certified Technician

Offline
Joined: Apr 20 2008
Posts: 8
They all match. I'm sure

They all match.

I'm sure I checked the speed after purchasing the iBook. It used to read as 700 MHZ. I would have returned it otherwise.

I'm at a loss. I updated everything. There is still no change.

Is it possible to knock off 200 MHZ by jostling the hardware? That sounds ludicrous to me.

cwsmith's picture
Offline
Joined: Oct 13 2005
Posts: 699
Force rescan of the system bus

• Shut down the computer. Remove any extra RAM from the expansion slot (or add a stick if there's none there).

• Restart the computer. When the system notices the RAM configuration has changed, it will scan the entire system for any other changes. Maybe it'll recheck the processor too.

• Report back with your findings.

__________________

Dozens of Macs; a handful of PCs; Apple ][e, ][c and ][gs; a few iPods; lots of parts
17 guitars, 2 baritone guitars, alto guitar, 6 bass guitars, bajo sexto, 3 ukuleles, mandolin, banjo, sitar
3/4 scale upright bass, 4pc drum kit, congas, travel congas, bongos, cajon, cabasa, 12 harmonicas
http://www.cwsmith.fmhttp://www.facebook.com/cwsmith2620

Offline
Joined: Apr 20 2008
Posts: 8
I popped out the 512 MB chip

I popped out the 512 MB chip and restarted.

The speed was listed as 500 MHZ.

I popped the chip back in.

The speed remains 500 MHZ.

This problem must be software related, right?

dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
reset PRAM and OF, boot to installer CD/DVD

Boot holding the cmd-opt-P-R keys to reset the PRAM - Mac will chime and restart

and

Boot holding the cmd-opt-O-F keys to boot to the OpenFirmware prompt.

type reset-nvram
type return
type reset-all
type return

Mac will chime and restart

Also, have you booted from an installer CD/DVD and run System Profiler, what's it say?

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

Offline
Joined: Apr 20 2008
Posts: 8
I'm learning all sorts of g

I'm learning all sorts of great stuff from you guys.
I really appreciate all of your help and suggestions.

I reset the PRAM and the firmware stuff--still no change.

I don't have a Tiger installer disc for this laptop. I do have one for my iMac G5, but I'm pretty sure it's system specific.

Anyone else want to take a crack at this?

Offline
Joined: Sep 21 2004
Posts: 74
Perhaps you accidentally knoc

Perhaps you accidentally knocked off a resistor or cap on the logic board that governs CPU speed?

Offline
Joined: Apr 20 2008
Posts: 8
That would be awfully stran

That would be awfully strange, but maybe.

I probably wouldn't be able to fix it, in that circumstance.

Offline
Joined: Apr 20 2008
Posts: 8
Does anyone know anything abo

Does anyone know anything about logic board repair, related to speed-governing?

Eudimorphodon's picture
Offline
Joined: Dec 21 2003
Posts: 1204
You could try this...

http://www.swieskowski.net/icook/

Assuming your iBook is one of the appropriate models with a 750FX CPU you could try forcing the CPU speed to a higher speed via software. If it works then it could be some stuck control panel option that's causing OS X to throttle the speed down regardless of the Energy Saver settings.

If all else fails, here's where the speed control resistors are. Look for damage?

--Peace

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
On my 600 the reported speed

On my 600 the reported speed doesn't changed, even if I set the speed to "reduced" in Energy Saver.

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

Offline
Joined: Apr 20 2008
Posts: 8
OK? Eudimorphodon, I co

OK?

Eudimorphodon,

I couldn't get iCook to work (I do have the correct processor), since I'm a terminal neophyte.

I'll rip it open and check the caps this weekend.

Thanks.