I-Mac g5 2.1 20inch I-sight w/power problems HELP!

5 replies [Last post]
Offline
Joined: Jul 25 2008
Posts: 3

I think it has something to do with the tree right outside my office being struck by lightning. I press the power button and it lights up for 1 blink. The fans try to start spinning but all they do is make a short jolt then nothing else happens. Does anyone else think its the power supply and if they do Is there anyway I can test the ps with a multimeter? This is my power supply, Power Supply 185W for iMac G5 iSight 17"/20" AC/DC 661-3780 614-0378. I took the ps out and It doesnt seem like theres any visible damage nor does it smell like it overheated.

Our Airport extreme base station and a 1tb external hard drive were also lost at the same time.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Dr. Webster's picture
Offline
Joined: Dec 19 2003
Posts: 1687
I don't think putting a billi

I don't think putting a billion exclamation points in the thread title is going to help much. Fixed that for you.

__________________

Applefritter Admin

Offline
Joined: Jul 25 2008
Posts: 3
OK smart guy. Any suggestion

OK smart guy. Any suggestions?

cwsmith's picture
Offline
Joined: Oct 13 2005
Posts: 699
I notice you're new here ...

... so I'll cut you some slack. But torquing off the mods is probably not your fastest way to make friends around here.

The power supply in the G5 iSight models is the same one used in the white Intel models. Apple's service manuals for these machines give a stern warning about powering these machines up without the LCD installed, specifically because the power supply is exposed. Certain circuits in the power supply carry extremely high voltage, and can seriously injure or kill you.

As a certified Apple technician, I feel confident in repeating Apple's advice: please proceed with extreme caution. Know what you're doing before you wind up flat on the floor.

Some other things you might take note of before trying a voltmeter on the PSU: have you tried simply reseating the RAM? The drive cables? The LVDS cable? When the unit is plugged in and the front bezel is off (but not the LCD), do any of the green diagnostic LEDs light up? How about after you push the power button?

Was the computer plugged into a surge protector when it took the hit? Have you tried a different surge protector, or have you tried plugging directly into the wall?

Try a few things and report back. And everybody play nicely, please.

__________________

Dozens of Macs; a handful of PCs; Apple ][e, ][c and ][gs; a few iPods; lots of parts
17 guitars, 2 baritone guitars, alto guitar, 6 bass guitars, bajo sexto, 3 ukuleles, mandolin, banjo, sitar
3/4 scale upright bass, 4pc drum kit, congas, travel congas, bongos, cajon, cabasa, 12 harmonicas
http://www.cwsmith.fmhttp://www.facebook.com/cwsmith2620

Dr. Webster's picture
Offline
Joined: Dec 19 2003
Posts: 1687
Re: OK smart guy. Any suggestion

shawnbalch wrote:

OK smart guy. Any suggestions?

Yeah, buy a new power supply. You already said you lost other peripherals, what makes you think your iMac's power supply escaped the same fate (but another internal component bit the dust instead)?

And seriously, a billion exclamation points in a title really screws with the layout (the sidebar won't wrap a long, unbroken string of characters).

__________________

Applefritter Admin

Offline
Joined: Jul 25 2008
Posts: 3
Power problem

I believe I actually unplugged the computer before I left for the weekend but I really cant remember now. I do know that the ethernet was plugged in.
No the green diagnostic lights do not light up even after its plugged in. I did try all the other suggestions you made.
I now have a different problem I know its gonna sound stupid but I plugged the ac power in into the psu backwards. I know what your thinking how could you do that? Well the plug is backwards if you connect it like any other plug and it locks together with plastic tabs, well its backwards here, the locking tabs go on opposite sides and the plugs do not lock together. Yes I know stupid.
The power light doesnt light up for even a second now. I tested the power supply after all this with a multimeter and I get nothing. No surprise seeing as I problably fried the thing if it wasnt allready.