B&W G3 Server, headless help...

3 replies [Last post]
Hokusai's picture
Offline
Joined: Dec 20 2003
Posts: 256

I've since set up my venerable B&W G3 as my general purpose server (web, printer, and whatever else I need to serve). I generally wouldn't mind keeping a monitor hooked up to it but they are few and far between here. So, I've got it somewhat running headless by having it hooked up to my TV via the 9200s (Radeon video card) S-video/RCA plug thing. I've even gone in the ATI control panel and checked the "Always Connected" button for the Mac2TV thing.

The thing is that every now and then I'll VNC into it just for it to reject it. It seems to be rejected it because there is no GUI running. It apparently forgot a display is connected. This seems to be a random, as far as I can tell. All the server stuff is still running and responsive, I just don't get any video even when I try to view what is coming out via the S-video.

If it is of any use, the G3 had a fresh install of 10.4 before I began using it as a server.

I usually wouldn't bother anyone else with this but it seems kind of quiet in here. So, here goes. Thanks in advance for any advice.

__________________

Macbook Pro 2.5GHz i5 / 16GB / SSD / eGPU GTX 960
Powerbase 360MHz G3 / 160MB / 80GB ATA / Radeon 7200

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
how about a display adapter instead?

I've never used the ATI TV-out thing, so can't address that directly.

I've never had problems using one of those old-tyme PC-to-Mac-video adapters plugged into the video port. It looks like a pukka display to the system and ensures your VNC server always has a desktop for the GUI. The problem for you with this approach of course is that if you have no physical display to attach for troubleshooting, you may require a reboot to use that TV as a display.

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

dvsjr's picture
Offline
Joined: Jun 8 2004
Posts: 135
I agree with Dan

His suggestion of adding an adapter to the video port on your Server is the advice I've always heard that helps run headless Macs.

d

__________________

--
http://newtonserver.no-ip.com

Hokusai's picture
Offline
Joined: Dec 20 2003
Posts: 256
Hmm...

Ya, I used such an adapter on my Beige G3 during its run as my server. Sadly, that same adapter doesn't fit on my B&W (It doesn't have the older style mac monitor port). I have heard of modifying a DVI to VGA adapter to be a dummy plug. I need some 75 Ohm resistors for that, though. I have been meaning to get on top of that. I suppose I'm just lazy.

__________________

Macbook Pro 2.5GHz i5 / 16GB / SSD / eGPU GTX 960
Powerbase 360MHz G3 / 160MB / 80GB ATA / Radeon 7200