Update: Wasteland will run on the Apple IIGS!

4 replies [Last post]
magnusfalkirk's picture
Offline
Joined: Feb 18 2007
Posts: 268

Greetings,

Last Friday I was messing with KEGS on a PC and decided to see if I could get Wasteland to work. I switched the ROM image it was using from the ROM 1 to ROM 3 and then started it up with the Wasteland boot disk. To my surprise, considering that it wouldn't work on the GS emulators I have on my Mac, it booted up.

In fact I was able to play the game through KEGS. So it seems Wasteland will run on a GS. I need to switch out the ROM image on my GS emulator on the Mac and see if it will work there. This might even make me decide to do brain surgery on my real GS and replace the ROM 1 motherboard I have with a ROM 3 motherboard to see if it works on the real hardware.

I'll update this message tonight after I've had a chance to see if changing the ROM image I use on the Mac makes any difference. I'll even try it on a few different GS emulators on the Mac.

Dean

__________________

Think Different - Apple II Forever!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
magnusfalkirk's picture
Offline
Joined: Feb 18 2007
Posts: 268
Sweet16 and Wasteland

I switched out the ROM image in my copy of Sweet16 on my Mac Mini, so it was emulating the ROM 3 GS instead of the ROM 1. I then tried booting the .dsk images of Wasteland. It came up with the screen full of 2's. I went into the Control Panel and turned on Alternate Display Mode and then rebooted. To my delight Wasteland ran.

The one problem I noticed was I couldn't start a new game. When I tried starting a new game it asked for disk 1, then 2, then 3 then 4, then 1 again and then 3 again, at that point it gave me an I/O error and wouldn't do anything else.

If I told it to start the last saved game it ran fine. I was able to start a new game in KEGS on the PC, so I'm not sure what the problem is. But this does prove that Wasteland will run on the GS, only a ROM 3 GS, but it will run.

Dean

__________________

Think Different - Apple II Forever!

Offline
Joined: Jun 28 2007
Posts: 80
Wasteland does work on a Rom 1 GS

Dean,
I started the original post about having problems getting wasteland to run on the GS. Two household moves in the last six months has kept me from posting, but I did find a solution. I changed my Rom 1 Apple II gs speed to normal and the display to 40 col in the graphic control panel. Of course Wasteland did not work and I got the famous 2's display.
I then booted up the original 3.1 OS and called up the old style control panel using the keyboard and changed to the alternate display mode (not sure why that option is not included with the graphic control panel?)and wasteland is now running great on my Rom 1 GS.

Jim

magnusfalkirk's picture
Offline
Joined: Feb 18 2007
Posts: 268
Wasteland on a ROM 1 GS

Jim,

Yeah I knew you started the original thread, I started this one thinking it might be the easiest way to let you know what I had discovered.

So which OS disks are you using and are they ones you had or downloaded somewhere? I'd like to be able to play Wasteland on my ROM 1 as well. Maybe I should try turning on the Alternate Display Mode in the Control Panel and see what happens.

Dean

__________________

Think Different - Apple II Forever!

Offline
Joined: Jun 28 2007
Posts: 80
Wasteland on Rom 1

Dean,
I am using the original versions of OS 3 and 5. The Wasteland diskettes are also original. Definately turn on your Alternate Display Mode...the program should then work on your Rom 1 GS.

Jim