iMac 233

11 replies [Last post]
Offline
Joined: May 31 2004
Posts: 24

hey I have an iMac 233 Rev A,

My question is, Is it possible to connect another drive to the IDE channel that the hard drive is on? I find that with the original CD-Rom connected it will only read the CD-Rom drive and not the hard drive so i've tried connecting both but all it will do is enter Open Firmware and when i try the mac-boot command it says Cannot OPEN.

Any Suggestions?

__________________

Smile

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: Sep 23 2005
Posts: 316
have you tried replacing the

have you tried replacing the hard drive? That sounds to me like the had drive itself may possibly be no longer functioning.

Eudimorphodon's picture
Offline
Joined: Dec 21 2003
Posts: 1204
Re: have you tried replacing the

evilrobot wrote:

have you tried replacing the hard drive? That sounds to me like the had drive itself may possibly be no longer functioning.

I'd second that. The main (40 pin) IDE bus is a normal master/slave port, completely separate from the proprietary-connector-ed CD bus. I've run dual hard drives and a single hard drive+DVD drive off of a disembodied 233 motherboard with no issues whatsoever.

--Peace

Offline
Joined: May 31 2004
Posts: 24
nah the hard drive is fully f

nah the hard drive is fully functioning, i used it in my hackintosh for ages. i've tried using it last night with the set up as i've described but its not really making any effort booting into my 9.1 or my 10.3 disks i'll figure it out.

__________________

Smile

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
How big is the HDD and how is

How big is the HDD and how is it partitioned? iMacs of that vintage have issues with drive over 138GBs, and also have issues with boot partitions that extend beyond the first 8GB of the drive.

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

Offline
Joined: May 31 2004
Posts: 24
6 gigs. I've managed to get i

6 gigs. I've managed to get it to boot (finally) What i did was attach the hdd to an external enclosure. and the CDrom to the internal connectors. Mac OS Being as picky as it is. tells me that I can't install to it because it's not bootable. DAMN USB!

__________________

Smile

Offline
Joined: May 31 2004
Posts: 24
as it turns out i needed to h

as it turns out i needed to have the removable storage medium as master and the hard drive as slave, why are things so backwards in the mac community? Everything's sorted. Thanks to all who gave suggestion Smile

__________________

Smile

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
Maybe that's because the opti

Maybe that's because the optical drive should be master on it's own ATA bus, and the HDD should be master on it's own ATA bus? Every PC I've owned with two ATA busses runs that way. Nothing backwards about it. Master/Slave is semantics and is just as easily expressed as drive 0 and drive 1 on the bus.

Often optical drives default to master, and are not easy to change, esp. for laptop style slim drives.

"Backwards" is based on point of view and experience, after all.

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

Offline
Joined: May 31 2004
Posts: 24
The optical drive i'm using h

The optical drive i'm using has jumpers, its just a normal IDE drive. I'm used to fixing wintels for the past 8 years. Macintoshes have been a thing on the side moreso.

__________________

Smile

doogie1303's picture
Offline
Joined: Dec 19 2003
Posts: 14
imacs and optical drives

On my imac rev A board, I tried four different CD and DVD drives on the IDE bus the hard drive is on. Master/Slave, no matter what I tried, the machine would not boot off the Mac OS X panther install disks (original, not a burned copy) or any other Mac OS disk. Two of them were normal PC tower drives and two were slim drives out of two broken ibooks I had lying around. However when booted into OS9 via the hard drive, the computer would see the CD-ROM drives attached on the IDE bus and read the OSX disc. So, I think this is an Open Firmware issue. It would only boot of a non-burnt CD with the original imac CD-ROM drive on the CD-ROM ATA bus. I even tried the slim CD drives from the ibooks on the CD-ROM ATA bus and that still didn't work.

Out of all the Apple and PC computer hardware I've dealt with over the years, the original rev A-D imacs are some of the pickiest when it comes to hard drive/CD-ROM hardware.

__________________

Macbook Core 2 Duo Poly White (wife's machine)
Ibook G3 800Mhz (baked and functioning again!)
Macintosh SE (3 in three machine, currently in a box somewhere in my garage)

doug-doug the mighty's picture
Joined: Apr 14 2004
Posts: 1355
Re: imacs and optical drives

doogie1303 wrote:

...the machine would not boot off the Mac OS X panther install disks (original, not a burned copy) or any other Mac OS disk....

Part of your problem may be right there. You will be lucky to get anything over X.1 to boot on those machines.

If possible, reformat your drive on a different Mac running some version of Classic and make sure it is good, then replace it to the iMac.

In answer to one of your original questions, yes - you can plug a normal 2-device IDE cable in instead of the original short IDE connector. If you stick it in backwards (with the long end going out side of the case), you can connect an second hard drive and run it just fine. You do need to make sure both drives are configured correctly for master/slave.

You have not stated the problem clearly enough for me to suggest that your IDE controller may be hosed, but that is not likely IMHO.

HTH

__________________

--DDTM ('Fritter Critter' since Apr 26 2004 - 18:16)

'If it ain't broke, take it apart anyways. If you can't take it apart, break it so that you can fix it.'

metzen01's picture
Offline
Joined: Jan 28 2009
Posts: 5
Doogie1303 question about color classic mod

Hey Doogie1303 I sent you mail within the forum but don't know if you read those. Could you at your convenience email me at . I had questions in regards to your color classic mod.

Thanks.