IIgs composite output color issue

8 replies [Last post]
Offline
Joined: Dec 20 2008
Posts: 202

Hi guys,

I recently pulled out my old GS and it seems the RGB monitor has kicked the bucket. Sad

Anyway, I plugged the composite output to an old Commodore 1702 (which has no problems) and the color is very strange.

In the control panel, all color options are shades of gray. Is this normal?

Apple II games have terribly wrong colors. Mostly pan-inducing clashes of purple and green only instead of the expected Apple colors.

Is this normal for the IIgs composite output?

__________________

-
Peter Rittwage
Apple II/II+ Registry - Register yours today!
http://diskpreservation.com/dp.php?pg=apple_registry

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
magnusfalkirk's picture
Offline
Joined: Feb 18 2007
Posts: 268
Re: IIgs composite output color issue

rittwage wrote:

Hi guys,

I recently pulled out my old GS and it seems the RGB monitor has kicked the bucket. Sad

Anyway, I plugged the composite output to an old Commodore 1702 (which has no problems) and the color is very strange.

In the control panel, all color options are shades of gray. Is this normal?

Apple II games have terribly wrong colors. Mostly pan-inducing clashes of purple and green only instead of the expected Apple colors.

Is this normal for the IIgs composite output?

No, it's not normal. Before I got my GS RGB monitor I had the GS hooked up to an Apple II color monitor, via the composite out, and it was fine. Is there any way you can test your Commodore monitor with something else to make sure it is working okay? Maybe a VCR or DVD player?

Dean

__________________

Think Different - Apple II Forever!

Offline
Joined: Sep 21 2008
Posts: 61
Sorry to hear about the monit

Sorry to hear about the monitor.

That is a nice monitor. Very useful and reliable.

If you mean background color and board color, then that is normal is seams for composite video. Mine does that as well [ROM 02]. It wouldn't do this I'm sure if it was connected to an RGB monitor. Other then that the color should be fine (well as fine as it could be using a crappy output like composite). I think if you do a self test it will cycle the background colors and boarder colors and it should display fine. It's just the control panel I think it does that. It's been a while, but what happens if you set it to something like blue, save and restart? Will you be able to see that it is blue in some place other then the control panel?

The composite output isn't the best on the GS. Are these original Apple II games or Apple IIgs games? How does it handle text only (when there is no graphics on screen)? White or a green, purple, white mix? Is this an early Apple IIgs (maybe a bad VGC chip)?

Could be, I know the composite tends to make everything look like crap and it makes all the colors over saturated. Well could you post some pictures and we can try to give you some hints on if there is a problem. One place I do agree with the other poster on is testing the monitor with another known good source (because someone could of messed with your settings on that monitor).

Offline
Joined: Sep 21 2008
Posts: 61
[quote]Before I got my GS RGB

Quote:

Before I got my GS RGB monitor I had the GS hooked up to an Apple II color monitor

That monitor was designed, or at least was built to Apple's specifications. There might be something the IIgs is doing to the color encoding in that control panel that is not standard and only that monitor will be able to compensate for it or at least be tolerant enough of it to display the color. As an experiment could you test your IIgs on another display device like a CRT TV with composite inputs. Not and LCD TV (those seam not to handle the Apple II (including the GS) or almost any retro computer very well (least using composite is seams)). Some LCD TVs handle different retro computers differently but I know my 32" Toshiba doesn't like my Apple II+ or my Apple IIgs very much (and so it's not what I typically use with my Apple IIs). What ROM version is your IIgs it may of been a change in the VGC or the ROM code itself.

Offline
Joined: Dec 20 2008
Posts: 202
HI guys, Thanks for all

HI guys,

Thanks for all the replies. The monitor works fine with video, C64, and Atari 8-bit computers using the plain front composite input, but from GS, I only seem to get the artifacting and not the "real" 16 colors. It's almost like my GS is only really outputting monochrome and not composite video. It's a ROM01 and works fine on the RGB out...

__________________

-
Peter Rittwage
Apple II/II+ Registry - Register yours today!
http://diskpreservation.com/dp.php?pg=apple_registry

resman's picture
Offline
Joined: Feb 9 2006
Posts: 213
control panel setting

Are you set up for color or monochrome in the control panel?

Offline
Joined: Sep 21 2008
Posts: 61
[quote]Are you set up for col

Quote:

Are you set up for color or monochrome in the control panel?

If his is doing the same thing as mine is with the composite it will do it regardless if it is setup for monochrome or color. Still haven't figured out why it does this. He says he gets color (but output is not correct or the colors are undesirable). Still I'd advise him to double check this setting though.

Is there any other setting that may cause this? Alternative display mode maybe?

resman's picture
Offline
Joined: Feb 9 2006
Posts: 213
Re: [quote]Are you set up for col

TheKisho wrote:
Quote:

Are you set up for color or monochrome in the control panel?

If his is doing the same thing as mine is with the composite it will do it regardless if it is setup for monochrome or color. Still haven't figured out why it does this. He says he gets color (but output is not correct or the colors are undesirable). Still I'd advise him to double check this setting though.

Is there any other setting that may cause this? Alternative display mode maybe?

If you look at the IIgs composite on a monochrome monitor, you can see the difference in the monochrome vs color output. The color setting modulates the chroma signal into the output, while the mono setting doesn't. I believe the mono setting also implements the color-kill to the output. If the monitor doesn't adhere to the color-kill signal, then it will continue to output the artifact colors (I have an LCD panel that does this). I believe the Commodore monitor will output black and white if the color-kill signal is present (or is it the absence of color-sync?). So, I would definitely look at the value of that setting.

Also, the alternative display mode setting is for certain video modes no directly supported by the IIgs, like the second page of lo-res graphics.

resman's picture
Offline
Joined: Feb 9 2006
Posts: 213
Re: [quote]Are you set up for col

hmmmm. multiple posts. [delete]