Quadra 605 Screen Issues

2 replies [Last post]
Offline
Joined: Dec 20 2003
Posts: 130

My Quadra 605 is having this weird problem. It started when I finally got the correct amount of VRAM (matched pair) in this machine and every second or third boot the computer would turn on but would never display anything. The hard disk would run and load Mac OS just fine. I tried reseting the PRAM and replacing the battery. I had a ColorSync 17" attached. I had OS 8.1 installed with 20MB RAM. I installed Timbuktu so I could remote controll the machine. This is how I knew it booted because I could remote login and use it fine.

Now, I replaced the original LC040 CPU and installed a slimline heatsink and it will boot after I clear the PRAM, but after the smiley mac is seen., the computer reboots and loads but all is black. Now it won't show an image period.

The VRAM is 2 pairs of 256KB. Could it be bad VRAM chips or a faulty CPU? I doubt the CPU is bad because the Mac shouldn't boot if the CPU fails it's own internal self-test. So maybe the VRAM is bad or the logic board needs replacement? I'm sure 512KB is enough to drive a 17" ColorSync.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
tmtomh's picture
Offline
Joined: Dec 20 2003
Posts: 568
Hmm...

Here's what I'd try, moving on to each next step if the prior step didn't help:

(1) remove VRAM, replace with other VRAM.

(2) Make sure PRAM battery is installed in the right direction.

(3) Test new PRAM battery to make sure it's putting out at least 3.1V.

(4) Swap out PSU (if you can) and replace from one with an other Q605 or LC/LCII/LCIII/LC475/Perf 475 or 476.

jt
Offline
Joined: Dec 20 2003
Posts: 447
MicroQuadras got battery powered . . .

. . . video subsystems. If the PRAM battery is dead, they'll boot up to a blank screen EVERY time! The workaround is a bit stressful for the PSU, but if you turn it on for a second and then flip the power switch off and right back on again, it'll boot up fine WITH video display.

We call that the MicroQuadra PowerToggle over at the barracks. If that makes your problem go away, you just need a new PRAM batt.

jt Wink

__________________

Perpetrator of the 68kMLA's text format impaired: Peripherals Links Project(tm)
. . . and LinksProjectClassic(tm)