Beige G3 logic board in ATX case Video issues

8 replies [Last post]
MacTrash_1's picture
Offline
Joined: Dec 20 2003
Posts: 318

I have been building an ATX box with a beige G3 logic board but I keep running into a problem with the on-board video. Is there a way to disable it ?

I removed the on-board video connector because the on-board video was not working right and it fits in the case better without it. I have a PCI video card (ATI Nexus) but sometimes it still thinks there are 2 monitors.
I also tried an ixMicro TT card with the same results. It will boot but I cannot get to the menu bar or see any of the dialog boxes that show up. No start-up screen, etc...

I had the same problem when it was in the beige DT case, but I could attach a monitor to the on-board connector and it worked well enough to mirror the screens, switch back to the PCI video and get by. Now the connector is gone, and I hoped that would disable it but no go. Sometimes a restart or two would kick it in the butt enough to work right and only show one monitor in the control panel. But that doesn't work anymore.

Any ideas ? The only idea I have at the moment involves a big hammer and a healthy release of pent up frustration ! LOL

This particular board has always been a PIA, so maybe the board is just junk and I should get another one.

This project started from getting a replacement board for my beige DT and I figured the old board can be hacked into the spare parts I have lying around from my dumpster diving excursions and Mac parts.

Tom, I'll post some pics when it's finished Wink
I may get a little Jiggy with some paint if I can get this damn thing working right.

__________________

Krow,

Apple Art & Project Black Mac LC5500/225 at:
http://krowmagnum.4mg.com/photo6.html

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
You have to tell the Mac whic

You have to tell the Mac which monitor port is the primary one. Thus you'll need to have a monitor connected to both ports, then go into the Monitors CP and move the menu and smiley Mac face (while holding Option key) to the new monitor. Then the Mac will boot with that monitor as the primary. It shouild keep those settings as long as your PRAM battery is still good, if not it'll lose the settings every time you tun it off IIRC.

You gotta approach this likeit's a Mac, not like it's a PC. PCs tend to defualt to what ever port has a monitor attached, Macs don't neccesarily.

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

MacTrash_1's picture
Offline
Joined: Dec 20 2003
Posts: 318
Re: You have to tell the Mac whic

Jon wrote:

You have to tell the Mac which monitor port is the primary one. Thus you'll need to have a monitor connected to both ports, then go into the Monitors CP and move the menu and smiley Mac face (while holding Option key) to the new monitor. Then the Mac will boot with that monitor as the primary. It shouild keep those settings as long as your PRAM battery is still good, if not it'll lose the settings every time you tun it off IIRC.

You gotta approach this likeit's a Mac, not like it's a PC. PCs tend to defualt to what ever port has a monitor attached, Macs don't neccesarily.

That won't work because there is no on-board video port. I can't change settings if I can't see or open the control panels.

I need some way to permanently disable the on-board video. Maybe yank the Rage chip ?

__________________

Krow,

Apple Art & Project Black Mac LC5500/225 at:
http://krowmagnum.4mg.com/photo6.html

martakz's picture
Offline
Joined: Dec 20 2003
Posts: 634
I suggest you solder it back

I suggest you solder it back on for this ocassion! What was wrong with it?

I really don't know if yanking the chip will work... sorry

__________________

Now using x86 machines. Bye bye iMac266 (Strawberry), G3 1400 and the G3 IIsi.

Offline
Joined: Dec 20 2003
Posts: 279
Removing the connector effect

Removing the connector effects the video chip itself in no way. All you did is make it so you cant connect a monitor. If the board is that messed up, get another one on eBay, they go for fairly cheap.

__________________

G4 in a G5 Case: http://www.mlode.com/~stuka/g45/
iMac in FlexATX Case: http://www.mlode.com/~stuka/imac-atx/

MacTrash_1's picture
Offline
Joined: Dec 20 2003
Posts: 318
Re: I suggest you solder it back

martakz wrote:

I suggest you solder it back on for this ocassion! What was wrong with it?

I really don't know if yanking the chip will work... sorry

Soldering it back on isn't an option, as this thing isn't worth the effort.

The video always worked fine for a while, but would start having vertical lines about an inch long following the mouse and the color would go funky.

I'll have to keep watch for another board and try again.

Thanks anyway,

__________________

Krow,

Apple Art & Project Black Mac LC5500/225 at:
http://krowmagnum.4mg.com/photo6.html

dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
openfirmware commands?

does the Gossamer's version of OF include support for controlling which video 'ports' are 'on' and which one to use and all that? In theory, using OF you should be able to tell the Mac to disable the onboard display. I know enough to know I don't know enough to be of direct help here, but if one were to research the supported OF commands . . .

eh?

Oh, BTW XPoStFaCto (whatever!) can set the desired input and output devices, simpler perhaps than using OF directly.

Also, I feel your pain WRT having access to only the secondary display. When I was dicking around with a LCD-less TiBook using an external display, I had to fish around for the &^*&)_*&#**!@# Displays main panel trying to grab it and drag it to the visible area. What a PITA that was. But eventually I got it and was able to change the settings (to mirror in my case.) It just required lots of blind mousing.

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

martakz's picture
Offline
Joined: Dec 20 2003
Posts: 634
Re: openfirmware commands?

dankephoto wrote:

Also, I feel your pain WRT having access to only the secondary display. When I was dicking around with a LCD-less TiBook using an external display, I had to fish around for the &^*&)_*&#**!@# Displays main panel trying to grab it and drag it to the visible area. What a PITA that was. But eventually I got it and was able to change the settings (to mirror in my case.) It just required lots of blind mousing.

Im impressed...VERY impressed!!!

__________________

Now using x86 machines. Bye bye iMac266 (Strawberry), G3 1400 and the G3 IIsi.

MacTrash_1's picture
Offline
Joined: Dec 20 2003
Posts: 318
Re: openfirmware commands?

dankephoto wrote:

does the Gossamer's version of OF include support for controlling which video 'ports' are 'on' and which one to use and all that? In theory, using OF you should be able to tell the Mac to disable the onboard display. I know enough to know I don't know enough to be of direct help here, but if one were to research the supported OF commands . . .

eh?

Oh, BTW XPoStFaCto (whatever!) can set the desired input and output devices, simpler perhaps than using OF directly.

Also, I feel your pain WRT having access to only the secondary display. When I was dicking around with a LCD-less TiBook using an external display, I had to fish around for the &^*&)_*&#**!@# Displays main panel trying to grab it and drag it to the visible area. What a PITA that was. But eventually I got it and was able to change the settings (to mirror in my case.) It just required lots of blind mousing.

dan k

LOL !

I tried finding the control panels when it was still a DT and managed to open and drag almost everything else to the 2nd desktop but the control panels.

Xpostfacto is an idea though........ This G3 won't let me install OS X anyway so I was going to go that route with the install. Now I'll have to keep playing with it until I can get video on the 2nd monitor and try using Xpost on it.

Thanks,

__________________

Krow,

Apple Art & Project Black Mac LC5500/225 at:
http://krowmagnum.4mg.com/photo6.html