[Free]Atto SiliconExpress IV--for hackers only

No replies
Offline
Joined: Dec 20 2003
Posts: 82

My Atto SiliconExpress IV has sadly come to the end of my desire to repair it. When I try to boot my 7100 with it installed, it does one of two things, depending upon the ROM version flashed onto it's serial EEProm:

2.1 (unreleased beta-contact me): Hang when executing DeclROM
1.65 (last released version): absolutely, perfectly nothing

When the 2.1 ROM is on it, I've booted the machine by removing the chip from the socket. After that, hot-installing the chip and the force-flashing with the 1.65 flash utility puts it back into do-nothing mode.

When the machine does boot with the card installed and in tact, the card doesn't seem to do anything, and the ATTO flash utility will NOT auto-detect it. Using the "force-flash" option and typing in the correct slot address reveals that the card can be successfully reflashed (the checksum checks and everything). slot-info programs reveal the card to be present and report itself properly.

I suspect failure in either the QLogic embedded controller or (hopefully) some of it's supporting circuitry. I'm presently learning more and more about PCB repair and could concieveably (eventually) revive it, but it's not worth the effort to me.

I know how rare these things are getting, so I feel really bad about throwing it away, even non-working, so instead I'll offer it up here in case a skilled SMD hacker can revive it and bring it back into the macintosh fold. You pay only for shipping. In the US I belive this would be $3.70 for USPS Priority mail.

PM me if interested.

Somebody please save this thing!

TylerEss