Canon Innova Book 350CD Power Problem

3 replies [Last post]
LTong's picture
Offline
Joined: Dec 19 2003
Posts: 141

Since I'm the "go-to-guy" for all things technical at my school, I get everyones bum PCs to fix. Here's the latest.

Canon Innova Book 350CD
100Mhz 5x86 CPU
8MB of RAM
Passive color VGA display
Swappable drive bay

The problem:

It won't turn on while plugged in. Only from the battery. Once it's booting I can plug it in and it runs off that while it charges the 12V battery. I do get a CMOS error each time I boot it.

So far I've disassembled it completely and all I can find wrong appearance-wise is a crusty discharge from the CMOS battery. I've removed it and cleaned the board of the discharge.

The laptop does have an independent power supply board, but it looks fine. My only other thought is that the fuse near the AC plug is blown, unfortunately it's got a chunk of aluminum around the center, so I can't see for sure if thats the problem.

Any suggestions?

__________________

Logan Tong

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
If the CMOS has had a dischar

If the CMOS has had a discharge of anything, it's probably dead or dying. Does it hold the time during a power-off w/o the main battery?

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

LTong's picture
Offline
Joined: Dec 19 2003
Posts: 141
Timeless

It doesn't hold any CMOS settings with or without the main battery.

__________________

Logan Tong

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
A fresh CMOS battery would fi

A fresh CMOS battery would fix that, and most likely the poweron problem too.

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls