Strange Software Issue

8 replies [Last post]
astro_rob's picture
Offline
Joined: Mar 19 2005
Posts: 320

My venerable 540c has begun acting up in the last couple of weeks, and I'm just a tad bit concerned due to the ever decreasing supply of repair parts and SCSI hard drives for it. I've been running an older copy of Norton (don't remember the version), and the machine began showing a virus with the scans. This puzzled me, since the machine doesn't connect to anything at this time. It was running 7.5.3, and soon not only were most of the applications showing an infection, the System itself affected. I had to reformat the machine, rescue what applications I could, save my documents and reinstall the OS. In fact, all of the applications ended up having to be tossed, including that copy of Norton.
After the reinstall, I decided to use the machine primarily for writing (it also was, but now more or less dedicated), and installed a small number of applications, mainly Nisus Writer, Tex-Edit Plus, Palm Desktop 1.0 (and the associated applications), and MacDOS (allows my Tandy Model 102 to use the 540c as a TDD). However, I needed to install a publishing app on the machine, so I pulled out my copy of Quark Xpress 3.2 and tried to install that. It took three times; the installer abended three times. Once I had it installed, I found that the application wouldn't launch; it said that it had become infected via a virus from System. I figured it was just a bad install, so I pulled out my copy of Aldus PageMaker 5.0, installed it. It ran once, with a warning that the application was modified by the System. Now, it won't run (Error 1).
Okay, folks, any thoughts? Just how many old Mac 68k virus' are there? Or is this the beginning of something... else?

Concerned,
Rob

__________________

Tinker Ergo Sum!
iBook G4 "Snowy", iBook Clamshell "Tang", Tandy Model 102 "Tandy", Tandy Model 200 "Deuce", Palm IIIxe "Xerxes", HP Jornada "Jordana"

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Hokusai's picture
Offline
Joined: Dec 20 2003
Posts: 256
Hmm...

An actual Mac virus. That's weird. I doubt it, maybe Norton is just mistaken. If it does somehow happen to be a virus, maybe it is something you keep reinstalling that infects your 540c.

__________________

Macbook Pro 2.5GHz i5 / 16GB / SSD / eGPU GTX 960
Powerbase 360MHz G3 / 160MB / 80GB ATA / Radeon 7200

dankephoto's picture
Offline
Joined: Dec 20 2003
Posts: 1900
sure could be a virus

Get a copy of the final version of Disinfectant, that venerable freeware app will take care of whatever malware has seized your 'Book.

dan k

__________________

|| web page gone - curse you Comcast! | Applish goodies servers offline, sorry! |
» email macdan at comcast.net

Offline
Joined: Dec 20 2003
Posts: 31
re: Strange Software Issue

You've got one of the old Mac viruses that spreads from disk to disk. There might be a way to use Norton to eradicate it, but the free Disinfectant program works well for me for both detecting and removing the old viruses. Any unlocked floppy disk that has been in that machine is probably infected, plus the original source of the virus which could be a locked floppy. Once you get the mess cleaned up, you need to keep the Disinfectant INIT in every 68k system folder.

astro_rob's picture
Offline
Joined: Mar 19 2005
Posts: 320
Thanks!

Going to look for a copy of Disinfectant... I have over 100 floppy disks, many that have been in that machine as well as my other Macs. Looks like I may have a lot of work ahead of me.
Better then the alternative...

Rob

__________________

Tinker Ergo Sum!
iBook G4 "Snowy", iBook Clamshell "Tang", Tandy Model 102 "Tandy", Tandy Model 200 "Deuce", Palm IIIxe "Xerxes", HP Jornada "Jordana"

astro_rob's picture
Offline
Joined: Mar 19 2005
Posts: 320
Follow Up (Post Disinfection)

Yup, thanks for the advice... turned out to be nVIR A. Massive infection, all the apps, System, etc. Now... geesh... comes disinfecting of all... those... disks... oh boy.
Gracias,
Rob

__________________

Tinker Ergo Sum!
iBook G4 "Snowy", iBook Clamshell "Tang", Tandy Model 102 "Tandy", Tandy Model 200 "Deuce", Palm IIIxe "Xerxes", HP Jornada "Jordana"

Offline
Joined: Jan 23 2005
Posts: 595
Maybe I'm Infected Too

Hey, maybe I picked up that disease on my venerable 7300... My 7300 is exhibiting almost the same problems. Did you have any problems with latency in drive mounts? That's another symptom that my venerable 7300 is exhibiting.

Gosh, my venerable may have a venereal... I better track down a copy of Disinfectant for my PU's.

astro_rob's picture
Offline
Joined: Mar 19 2005
Posts: 320
Mac VD...

Yeah, MR, there was a real sluggishness in mounting disks, especially floppies; even my CD was slow to open (I use an old Apple branded external that came, sadly, from a trashed Apple IIgs). This may very well be the reason my APS external harddrive failed as well... though I think it was age and massive amounts of data abuse (not only was it used for my Plus, it also held the Windows 95 disk image for my 6100/66 DOS).
I haven't yet begun the arduous task of looking at the floppies, preferring to instead surf the web and avoid that responsibility. But with as many computers as I own, and the realization that some may have been given away infected, I ought to get on the ball, eh?
By the way, Disinfectant 3.7.1, at least the version I downloaded, won't run on my 7200. There has to be a PPC version, going to look for it now...
...and you should do the same!

(This message brought to you by Citizens for Computer Abstinence. Only you can prevent Digital VD...)

Rob

__________________

Tinker Ergo Sum!
iBook G4 "Snowy", iBook Clamshell "Tang", Tandy Model 102 "Tandy", Tandy Model 200 "Deuce", Palm IIIxe "Xerxes", HP Jornada "Jordana"

Offline
Joined: Jan 23 2005
Posts: 595
I think I will. If I can ge

I think I will. If I can get my 7200 to unfreeze. It locked up and won't restart or shutdown. Looks like I'll have to pull the plug.

Thanks.