Working on My Beige G3 DT

5 replies [Last post]
Offline
Joined: Sep 13 2005
Posts: 5

Hiya all!

I am building my "dream system", dream from like 8 years or so ago anways, but at last I'll get to build it. I am making a low end video editing station out of a Beige G3-350Mhz DT I acquired. I've loaded it with OS 9.1 (taken from an Imac restore set) installed on a 4.3GB IBM SCSI 50pin 7200rpm drive. I have a 40GB IDE hard drive setup for storage. It also has an Apple DVD-Rom drive and a 100MB ZIP drive built in. Seperate USB and FireWire cards round out the basic set. 512MB of Ram are installed, I'll max it out later.

I have order an A/B "Wings" card to replace the Wisper card, hasn't arrived yet. I am told I need to have this card in before I Can play DVD's.

PROBLEMS
I can't upgrade the OS to anything higher than what's on there now (OS 9.1), the updates refuse to install.
I can't find any software that will work to play DVD's. I've downloaded and attempted to install DVD 2.2 and higher and it refuses to install.
Anyone have an OS 9.2.2 cd availble?

I *know* these little puppies were used to edit video when they were new, and I know they were using OS 9.x.x. If it could be done then, it can be done now. After it's going well, I may splurge and get a 1Ghz G3 or 1.1G4 upgrade card for it.

Some of you may ask why I am spending money on this old beast. I only have $24 in it so far, and even at $250 for a 1.1G4 (Which I will oc to at least 1.2) You can't get a G4 1.2 with this much stuff on it for under $300. (can you?)

Help me out folks!

Regards,

-Ev

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
madmax_2069's picture
Offline
Joined: Sep 24 2005
Posts: 664
sorry to tell you but you are

btw do you mean a/v personality wings card. it wont decode dvd all the a/v card is for is hooking the mac to a tv or to capture video and audio. sorry to tell you but you are going to have to buy a ati rage 128 or up to a ati radion 9200 pci before you can play dvd's the onboard ati rade ll or ati rage pro isnt compatable with the dvd player or the dvd decoder from apple .but yea once you buy a ati rage 128 pci video card or highter i dont think you will be able to play dvd movies on it. i got a beige G3 AIO with the a/v personality wing's card i use a program called Btv pro to capture video. i am trying to upgrade this but boy do i ever got my work cut out for me lol Smile

__________________

Beige G3 AIO,Yikes, Digital Audio, Performa 475, Newton MP 2100, Apple IIgs, HP D530 SFF, Wyse winterm 3360SE
http://www.Apple2online.com

Offline
Joined: Jan 23 2005
Posts: 595
If I'm not mistaken...

If I'm not mistaken, you have to install Mac OS 9.2.1 before you can install the 9.2.2 update. I have 9.2.2. installed on my Beige G3/233 and I didn't have any problems with the updates that I downloaded from Apple.com.

macg4's picture
Offline
Joined: Jan 18 2005
Posts: 311
G3 reply

Yeah u should be able to get os 9.2.2 and os x up to 10.2(nothing past that without using xposto). I have a beige desktop myself 266mhz g3/640ram/40 gig ide/40x cdr-drive/zip 100/usb 4port.

__________________

"keeping the mac legacy alive one day at a time"
PowerMac G5 1.8/1gig/300gb/Ati 9600/Superdrive/Airport extreme
http://macg4.biz.ly

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
There were some comments in t

There were some comments in this thread HERE about DVD playback on the beige G3. A Radeon 7000 seems to be a good option. As stated, the Wings card won't help you there.
Also note that OS X, if you choose to go that route, does not support the Wings card, so you'd need another video-in source for doing editing.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
Depending on where you start

Depending on where you start from you'll have to go 9.0 - 9.04 - 9.1 - 9.2.1 - 9.2.2. You can probably jump fom 9.1 to 9.2.2. X.2 has a combo update staight to X.2.8.

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls