New to the CC want to put in a 575 MB in and get 640x480

27 replies [Last post]
Offline
Joined: Oct 5 2005
Posts: 31

I just got a stock CC. I have modest plans for it.
1. install a 575 MB in it to get a bit faster machine
2. do the simplest proceedure to attain the 640x480 video resolution
3. install a apple//e emulator card and have the partitioned HD

Now, what i have is the CC, nice large HD, and the apple//e emulator card

What I need:
step by step instructions on how to first - get the 575 MB installed and working, second - steop by step instructions on how to do the simplest and most stable modification to get the 640x480 screen resolution.

I can go from there.

Any help is great.

Thanks

Kevin

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Welcome aboard! You'll fin

Welcome aboard!

You'll find the best guides for making those modifications in the Color Classic Mega-FAQ:
http://www.colourclassicfaq.com/

...and at Stuart Bell's site:
http://www.stuartbell.dsl.pipex.com/PowerCC/

...and a guide for doing the 'hi-res' 640 x 480 mod:
http://www.bekkoame.ne.jp/~t-imai/cce1.html

The general consensus is it's safer for your analog board to do Chris Lawson's VGA mod (60Hz) rather than the hi-res (67Hz refresh), but you may find one gives you a wider screen over the other.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

Offline
Joined: Dec 20 2003
Posts: 63
Amen to the 60Hz VGA mod... i

Amen to the 60Hz VGA mod... its also a good idea just in case you want to go with a 6500 board and mod all the way up to a 604CPU or a G3 card some day. You know there are SIS chipset Intel boards that fit in the CC and you can do a killer PC/Intel/Linux/Windows mod... just a thought...

http://www.applefritter.com/image/uid/823

Offline
Joined: Oct 5 2005
Posts: 31
I dont have any plans to go a

I dont have any plans to go all the way with the mods. i just want a stable CC running at 33mhz with the 640x480. The LC 575mb will be a nice board to do this on i think. Also the 575 has both the PDS slot and a slot for having a NIC. just what i need, as i want to keep the PDS for the Apple //e emulation card i have.

Thanks

Kevin

Offline
Joined: Oct 5 2005
Posts: 31
The LC 575mb will work seamle

The LC 575mb will work seamlessly in a CC if I am running OS7.5 i have read. If I want to run 7.1 I need enablers...

I also have read that 7.5 is a resource hog and is slow and buggy.
Is it really THAT bad? is it so bad that I should try to use OS7.1 and find those enablers? Where can I find the enablers? Where can I find OS 7.1 for that matter? Its not as easy to find it as 7.5 was. I have disks for 7.0, but I cant use those because the apple//e card needs 7.1 - 7.5

looks like the vga modifyer is the way for me to go. I dont need to up the power and fry the analouge board.

any tips?

Thanks
Kevin

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
System 7.1 has never been rel

System 7.1 has never been released by Apple for some reason. Gamba (Google for Gamba and Macintosh) had a link for 7.1, but I've found it to be corrupted. Maybe I just had a bad floppy.

I wouldn't describe 7.5 as a resource hog, and I've not had any trouble with it, but 7.5.5 is a bit more polished.

For 7.1, you can find System Enabler 065 HERE, courtesy of Jamal Hannah.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

Offline
Joined: Dec 20 2003
Posts: 63
If you do a fresh install of

If you do a fresh install of OS 7.5 you won't need enablers. At least I never have.

Offline
Joined: Oct 5 2005
Posts: 31
Ok, so I have a LC 575mb on t

Ok, so I have a LC 575mb on the way. I have a LC 575 32mb ram chip on the way too.
I have decided to stick with the OS 7.5.3
If i want to wipe my HD clean and start from fresh, should i do that BEFORE the new mb is put in? or can i have the 575mb installed and then start the 7.5.3 installation from the floppy and just run to town?

Can I do the LC 575mb upgrade and not do the video (640x480) video mod? can i do the video mod latter on?

with OS 7.5.3 is the 32-bit addressing the default? I want 24bit so i can run the apple//e emulator card that requires 24bit.
If i keep it in 24bit, will all my memory get used by the system?

Thanks

Kevin

Offline
Joined: Dec 20 2003
Posts: 63
I would do all of the work, g

I would do all of the work, get the new machine to boot, and then install a fresh OS. The reason the enablers are needed are when you first install an OS, the OS installs the appropriate enabler for the board in the machine and since old Macs are proprietary as heck, you need a new enabler to run the different motherboard. If you do a fresh install on a CC575 project, the OS installer thinks that it really is a 575... it can't see any differences since its a fresh install and the analog board mod that you did is transparent to the operating system.

Offline
Joined: Oct 5 2005
Posts: 31
Ok, now a question regarding

Ok, now a question regarding the video mod on a 575mb...I dont need to do the high-res video mod, just the low stress video mod. now, that mod, I have seen some instructions, to do the low stress mod, do i just modify the motherboard only? I dont need to modify the analog board right? or do i modify both boards?

Thanks

Kevin

Offline
Joined: Dec 20 2003
Posts: 63
There is a motherboard mod fo

There is a motherboard mod for the 575 but I think its only to allow 512 mode on the board... you need to mod the analog board. You really want to do the mod found here...

http://www.colourclassicfaq.com/general/vga.html

It is the best way to do it. You'll want to read everything you can to make this work... I have never done a 575 conversion... just lots of Power PCs and an Intel machine in a CC once. The analog board mod is pretty easy and required entry level solder skills. You will learn a lot just doing the mod yourself... make sure you google all you can on Power Color Classic and you should be just fine.

Good luck man.

Offline
Joined: Oct 5 2005
Posts: 31
scott- you have been a gre

scott-

you have been a great deal of help. thank you so far.
I am still waiting for my 575mb to arrive, once it does, I will get to work on the analog board, 'course there isnt anything keeping me from doing it now actually....hmmmm...maybe i will rip my CC apart today and get that analog board out to mod it the way it needs to be.

Thanks again.

Kevin

Offline
Joined: Oct 5 2005
Posts: 31
Scott- I have done the sli

Scott-

I have done the slicing part of the analog board, I believe i have isolated the pins that i need to. my slice isnt very wide as i used the edge of a small scraper, it did the job, just not a very wide gap, but i can see the white of the mainboard, not the copper. I need to get a sutable wire for my "jumper" the directions didnt really give a good description of what kind of wire to use...any paticular gauge? what kind of wire would one have laying around that would be sutable?

After this, all i have to do is wait for my 575mb to arrive, and slid that in. it should boot up. I can even use the HD from the donner 575, so the OS installation thats on is already a 575.

Kevin

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
IIRC I used a piece of wire f

IIRC I used a piece of wire from a hard drive power connector. Anything around that size should be fine. I don't think you'd want to go much smaller than that.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

Offline
Joined: Dec 20 2003
Posts: 63
Yah, power supply wire should

Yah, power supply wire should be good... thats about 16 to 18 gauge I think if I'm not mistaken.... if you can see white plastic, you went deep enough seperating the solder run on the board. Good luck. Hope this turns out for you.

Offline
Joined: Oct 5 2005
Posts: 31
OK, Great, i believe I have s

OK, Great, i believe I have some HD power wires layin around here unused. I will give the soldering a go tonight.

then i will be just itchin to get my 575mb...man, will it ever come?

I sure hope that i didnt do any more damage than i planned on when i was scraping the copper on the analog board, that was a very tight spot down there at points 20 and isolating point 25. I cant imagine doing it with dremmel as the instructions suggested.

Thanks again.

Kevin

Offline
Joined: Dec 20 2003
Posts: 63
You probably did fine.

You probably did fine.

Offline
Joined: Oct 5 2005
Posts: 31
the Video Mod is DONE! 'Co

the Video Mod is DONE!

'Course I wont know if it was done right until the 575mb arrives. I am also getting the HD that came from the same 575 with OS 7.5 installed. My theory is that if i put the mb and he HD in and boot, it should all work right? the installation of 7.5 on the HD will be looking for a 575 and it will be there and it will be looking for 640x480 and as long as i did the mod right, that should be there too. I will just have to wait and see.

If it all works, then I am on to phase 2 where i take the 530mb HD i have, format it, partion it and install OS 7.5.3 and Apple pro DOS on the 10mb partition. then I should have a working mystic color classic with the apple//e inside! ok, gotta calm down, getting excited over modifying a 12yr old computer is showing my geekside.

Kevin

Offline
Joined: Dec 20 2003
Posts: 63
Yah, it'll work.... (nerd)

Yah, it'll work.... (nerd)

LOL Laughing out loud

Offline
Joined: Oct 5 2005
Posts: 31
ITS DONE! AND IT WORKS!

ITS DONE! AND IT WORKS!

I just re-assembled the CC this morning. I have 640x480 and it is pretty snappy for a 33mhz machine.

Now what i need to do is get files from the 3 different HD's that i have consolidated on one HD. Format the 530mb HD I have with OS 7.5.3 (gonna stick with that one) and get it all installed and the apple//e card runnig and then sell my mac SE.

Thanks for all the help!

Offline
Joined: Dec 20 2003
Posts: 63
Nice to hear its working. Ve

Nice to hear its working. Very nice.

Offline
Joined: Dec 20 2003
Posts: 180
Congratulations!

Great to hear of your success. I pulled my VGA Mystic out of the cupboard recently; they are much faster than people expect from the clock speed.

Speaking of which . . . . you do know you can go to 40MHz+?

Stuart

__________________

Stuart Bell,
Developer of the PowerCC site a long time ago.

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
Likewise

I just unpacked the Mystic and followed TylerS's instructions on setting up 7.5.5 with Open Transport, etc.

36 MB, a massive (for the task) 2 GB hard drive...it's like I've met up with an old friend again.

Now I'll have to look into the 40 MHz clocking. It's been so long I can't even remember what speed I'm currently at. all I remember is it's a full '040 with a Q800 or 840av heat sink on it.

It's been great seeing some hacking and modding here again. We've been running low for a while.

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

Jon's picture
Jon
Offline
Joined: Dec 20 2003
Posts: 2804
If I get my iMac DV 400 going

If I get my iMac DV 400 going there'll be another case hack in short order. (evil laugh) ;D

__________________

I am not in this world to live up to other people's expectations, nor do I feel that the world must live up to mine. - Fritz Perls

Offline
Joined: Dec 20 2003
Posts: 354
Re: Congratulations!

StuartBell wrote:

they are much faster than people expect from the clock speed.

I also recall being pretty blown away by the speed relative to the original. Definitely faster than twice as fast.

__________________

"One day I shot an elephant in my pajamas. What he was doing in my pajamas I have no idea."

Offline
Joined: Oct 5 2005
Posts: 31
Re: Likewise

eeun wrote:

I just unpacked the Mystic and followed TylerS's instructions on setting up 7.5.5 with Open Transport, etc.

36 MB, a massive (for the task) 2 GB hard drive...it's like I've met up with an old friend again.

Now I'll have to look into the 40 MHz clocking. It's been so long I can't even remember what speed I'm currently at. all I remember is it's a full '040 with a Q800 or 840av heat sink on it.

It's been great seeing some hacking and modding here again. We've been running low for a while.

Why does one need special instructions to install 7.5.5?
Do i need to do anything special if i want to install 7.5.3?

This CC with a 575 runs really quick...if you didnt know it, you wouldnt have any idea that its only 33mhz. cripe, having it boot and launch prince of persia, it holds its own and keeps up with my daughter's Pentium 133mhz IBM Thinkpad 760ed.

Kevin

eeun's picture
Offline
Joined: Dec 19 2003
Posts: 1891
TylerS's instructions [url=ht

TylerS's instructions Here are for a 7.5.5 setup with TCP printing and file sharing capability. It also seems to make a nice order of installation for a stable setup.
You don't actually need any special plan for 7.5.5 or 7.5.3.

Mmmm...Prince of Persia...

__________________

"Give a man a fire, he's warm for a day. Set a man on fire and he's warm for the rest of his life."
(Terry Pratchett)

grannysmith's picture
Offline
Joined: Dec 20 2003
Posts: 178
Re: New to the CC want to put in a 575 MB in and get 640x480

kondre2000 wrote:

I just got a stock CC. I have modest plans for it ...

3. install a apple//e emulator card and have the partitioned HD

This last seems not to have attracted much comment. I use System Z1-7.5 in a CC (whereas Apple's manual is cast solely in terms of an LC) for the IIe card, with partitions 10MB and 1.2GB on the single HDD. Apple's own recommendation is not to use System 7 (by which I take it that 7.x is meant). The IIe Startup Disk has 6.0.8. You must be able to turn off 32-bit addressing, as you are aware, and this certainly rules out 7.6, but any 7.5.x is probably going to strain the friendship also. What you are planning may very well work for you, but keep Apple's limitations in mind.

de

__________________

IIe; 21x68K; 17xPPC; 6xG3; 5xG4. System 6.0.8 to OS 10.5.8