My Quicksilver will not power up

2 replies [Last post]
Offline
Joined: Oct 19 2005
Posts: 9

I bought a QS G4 yesterday, I cannot to start up. I push the power button and the fan goes and the button lights up and the board lights up too but it sguts down immediately. The light on the power button stays on as long as I keep it depressed. It seems like it won't catch or something.

I do not know how to verify the power supply. I read an article that indicated that was a troubleshooting technique. Then I tried a minimal configuration and it still did not work.

Any suggestions please?

__________________

Fixing old Macs is cool.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: Dec 20 2003
Posts: 234
Wow how odd. I just got a

Wow how odd.

I just got a call from work about a Quicksilver having that exact same problem.

I will likely know more tomorrow as I am out of the office today. I seem to recall hearing something about this before. My first though is that the PSU is bad.

__________________

The lazy man would rather exert himself than make two trips. -- Slovenian saying

Offline
Joined: Dec 20 2003
Posts: 234
The G4 was fixed before I got

The G4 was fixed before I got to work today.

Apparently that had not reset the CUDA like I had asked them to do. A couple of hours later they decided to do it and problem fixed.

So if your still having the problem. With the power off but still plugged in. Open the side and press the button behind the PCI slots. It should then power on.

__________________

The lazy man would rather exert himself than make two trips. -- Slovenian saying