PIII 800 shows wrong MHz

9 replies [Last post]
catmistake's picture
Offline
Joined: Dec 20 2003
Posts: 1098

This is a ThinkPad A22m, with a PIII 800MHz, but it constantly shows the wrong speed... it seems to be random... sometimes it says something like 797MHz, sometimes it says 600MHz...

What is wrong with this thing? Is this normal? Is there some software setting I don't know about? If so, how do I make it use all the available proc speed all the time?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975
It might be

it might be a chip that does stepping down and up when there are big loads, and times when the CPU is not doing anything. It seems it changes under loads. There might be something in the energysaver that allows you to configure the CPU Settings to not do powersaver.

Even Apple xBooks do this. Starting with the G3 (750vs series
(which BTW, was the test CPU in IBM's labs when they figured out how to do CPU Speed settings, and it was never released. I had a friend that worked on the design of it)

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/

macg4's picture
Offline
Joined: Jan 18 2005
Posts: 311
hmmmmmmmmm......

well its seems coius has solved the mystery

__________________

"keeping the mac legacy alive one day at a time"
PowerMac G5 1.8/1gig/300gb/Ati 9600/Superdrive/Airport extreme
http://macg4.biz.ly

coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975
lol

did that work out?
Did you set the speed adjustment

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/

catmistake's picture
Offline
Joined: Dec 20 2003
Posts: 1098
thanks

I'll check that out...

[rant]
my fluff IT employment notwithstanding, GOD I HATE WINDOWS... and just as much, I hate the excuses people use for its 'necessity'

I found out something recently... the resident Advanced Microsoft Group admin and MS rep where I work uses a dual 2.5 G5 at the office...

I have to wait another 2 years before I can replace the 50 or so Dell's in my department with Mac's, but, as God as my witness, it will be done.

For all their evils, I don't hate MicroSoft, per se, and frankly, I think Bill Gates is a pretty decent individual... but Windows is just out of hand. I'd really like to see Singularity entirely bury Windows, and that includes Longhorn, which will undoubtedly be just as craptastic as every previous version
[/rant]

catmistake's picture
Offline
Joined: Dec 20 2003
Posts: 1098
can't find it

I can't find anything like what you describe...

There is no processor adjustment in the Power Settings, and under System control panel, there is an "adjust for best performance," but that has always been set, so it isn't making any difference...

If you have an idea of where it is... let me know, because I see no way to adjust the proc speed...

coius's picture
Offline
Joined: Aug 25 2004
Posts: 1975
BIOS

What about BIOS? is it speed adjustable in the BIOS? And does it come up at full speed during the POST message?

__________________

See my PB540c 33Mhz serve a website! http://yui-ikari.coius.info/

catmistake's picture
Offline
Joined: Dec 20 2003
Posts: 1098
hmm...grrr....

its IBM BIOS (c.2001)... it says the proc is an 800MHz PIII

seems to be a setting for proc performance, but already set to maximum.
There is a note about certain settings only being available if other settings are set to "CUSTOMIZE," so I checked both... still reboots to 645MHz... just plain weird.

Is there a differerent utility I could use to check speed? Maybe properties is lying to me...

The Czar's picture
Offline
Joined: Dec 20 2003
Posts: 287
Run the machine under a good

Run the machine under a good strain - get your CPU utilization over 80% and keep it there for a bit (10 minutes or so). If you've got a DVD drive, rip a video to your HD or something like that. Then check the specs. Most Thinkpads from the late 1990's and onwards have Intel SpeedStep technology built in and turned on by default.

If that doesn't work for you, get a program such as SiSoft Sandra and look at the specs. If Sandra doesn't report the right speccies, run a benchmark on the processor and compare it to other processors (both the ~650Mhz PIII its reporting and the 800Mhz PIII its supposed to be) and see which benchmark your computer is closest to.

Cheers,

The Czar

__________________

iBook 14" 1.33Ghz/768MB/60GB/10.4.8
Quicksilver 2x1.6Ghz/1536MB/600GB/10.4.8 Server

catmistake's picture
Offline
Joined: Dec 20 2003
Posts: 1098
Solution found, in case anyone wondering

Found the solution:

1st, you have to disable it in BIOS... but that is not enough, it must also be disabled in Windows as well.

However:

Quote:

Note: Since Windows* XP has the Intel SpeedStep technology driver built into Windows, you will not see an icon on the taskbar and you will not see a tab for Intel SpeedStep technology using the power applet located in the Control Panel.

From Mobile Intel® Pentium® III Processors - Intel SpeedStep® Technology and about half-way down the page.

Which means there is no interface to do this in XP!!

The work around is:

Quote:

If you go into the Power Applet in Control Panel and select the Always On option it will disable Speed Step. Right click your desktop > Click properties > Click Screen Saver > Power button > Change the Power Scheme to always on.

From
Bay Wolf's Speedstep FAQ