New User, "New" Apple IIe: Greetings & Questions

20 replies [Last post]
jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15

Hi everybody,

I just registered here after looking for an Apple community focused on vintage machines.

As many of you here, I started programming BASIC in the mid 80s; at the time I used a Casio Pocket Computer, but also used IBM machines at school, though after that I didn't do any more programming.

Fast forward 30 years and here I am browsing the Facebook Marketplace where I see an Apple IIe with monitor, a Kensington System Saver and a mysterious external "card", all for $70.

It doesn't have floppy drives and for now I'm stuck with the internal Applesoft BASIC language.

The motherboard has a couple date codes stamped on, "K8422" and "8423" and it has 2 Apple Cards, one in slot C1 and one in slot C3; serial # under the chassis is 1A2S2 - 51xxxx.

After a good and thorough detailing, the computer seems to work fine, and I can also run some short programs.

But... there are some strange things happening, and here are my questions.

- What are those cards for?

- After running the command AUTO 300 (or any other numeric input), it gives a syntax error. Do someone know why?

- After a diagnostic by pressing Control/Open Apple/Solid Apple/Reset, I only get "RAM :" as a result. Why?

- The LOAD command doesn't give any cursor. After unsuccessfully trying to load a game from Apple Game Server by means of an iPad, the same diagnostic as above gives "IOU FLAG E5: 1" as a result. Why?

Sorry for having so many questions but I'm trying to see if it's worthy keeping the machine or it'd better to sell it.

Thanks in advance for any reply.

__________________

Juan Carlos

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
macnoyd's picture
Offline
Joined: Oct 15 2012
Posts: 183
Re: New User, "New" Apple IIe: Greetings & Questions

Hi jcmontero,
Welcome to AppleFritter.
There are a lot of folks here with various Apple][ backgrounds that I believe will be helpful in answering your questions.
It would be helpful if you could post some clear photos of your plug-in cards. If you can't sort out how to post them here,
at least post a reference to where we can view them. (such as DropBox, etc)

Are you working with an Apple ][e? Your description above seems to indicate this.
If you do not have a floppy drive with the computer, you're options are quite limited. You can run from a cassette tape or
from a cell phone (to load applications) but the hassle factor is something you'd have to deal with. ((my opinion)

If you have a working system, you would at least start off with Apple Basic and Dos 3.3. With that loaded, you can run
Binary programs by typing BRUN followed by the binary program name, or for Applesoft basic, simply RUN followed by the
program name. If they don't work, it might be because of a disk or memory error, or you didn't designate the Address (A$)and
Length L$ of the program you are loading, (from the iPad) or the program has errors or is expecting DOS or ProDOS.

The command AUTO 300 to me indicates you want to increment your basic program lines by 300. (not sure why you are typing this)
The command LOAD is something you would do with an Applesoft program located on a disk drive. You'd still have to type RUN
to get anything out of it. Most folks simply type RUN followed by the program name. (assuming you have a disk drive)

I hope some of this helps. Photos would be helpful for us to identify your plug-in cards.

__________________

macnoyd

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Hi macnoyd and thanks for your reply.

Yes, it's an Apple //e or 2e... there are lots of different spellings as I understand. Smile

The cards are actually 4: two Super Serial Card II, one AIIE 80COL/64K Memory Expansion and one Disk ][ Interface Card.

Here are some images of the cards:

https://www.dropbox.com/s/423zo7474l0rjx1/80col-64k_MEM_EXP-back.jpg?dl=0

https://www.dropbox.com/s/5o559pn9t63oq3m/80col-64k_MEM_EXP-front.jpg?dl=0

https://www.dropbox.com/s/4ph0v2dryw8vm3q/disk-2_INT_CARD-back.jpg?dl=0

https://www.dropbox.com/s/qoid2m0mfm47iwi/disk-2_INT_CARD-front.jpg?dl=0

https://www.dropbox.com/s/0kmmo61vbfn6acs/super-serial_1-back.jpg?dl=0

https://www.dropbox.com/s/u8qzibc93531lum/super-serial_1.jpg?dl=0

https://www.dropbox.com/s/lw9ysynl64f1gu5/super-serial_2-back.jpg?dl=0

https://www.dropbox.com/s/zc4hnw2xzhqqdne/super-serial_2.jpg?dl=0

I know I can't do much without floppy drives, but before I buy anything else, I want to check if this PC works well.

The command AUTO 300 comes from the "Apple ][ Basic Programming Manual" where it states that the command should number lines automatically instead of adding them manually for each new line.

Unfortunately it gives me a Syntax Error.

I will try moving one of the the Super Serial cards that now is in slot 3 to slot 2, as I seem to understand slot 3 is shared with the AUX, in which I currently have the 80COL/64K card. Maybe there's some conflict...

Many short programs I write are well executed, except maybe the PRINT one: PRINT "HELLO WORLD" is rendered HELLO WOR\D. I dunno why... Here's a pic:

https://www.dropbox.com/s/snycn6nr8p4yfwl/auto-hello.jpg?dl=0

Waiting to solve the diagnostic problem...

Thanks for now. Smile

__________________

Juan Carlos

macnoyd's picture
Offline
Joined: Oct 15 2012
Posts: 183
Re: New User, "New" Apple IIe: Greetings & Questions

Yeah, that Hello Wor/d thing is a strange one.

Suggestion,
UnPlug ALL cards,
Type in your Hello World program & see if it (now) behaves.

Type NEW then type AUTO 10. See if the Syntax error goes away.

Then turn off computer, plug in the memory card and do the same.
The error you get might be a memory chip error. Could also be a bad memory chip on the motherboard.

Let us know your result

__________________

macnoyd

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

OK,

I unplugged ALL the cards but the Hello Wor/d is still there.

Seems like the problem is in the motherboard...

But... something strange happened: With no cards, after turning on I got this screen:

https://www.dropbox.com/s/6mtgd0954225wew/no_cards.jpg?dl=0

Apple ][ on top center AND prompt cursor on TOP LEFT.

While before, which was normal for me, with all cards in (and in this test, after adding ONLY the Disk card) when I turned on I got first this:

https://www.dropbox.com/s/fjs86si2drbx592/disk_card-1.jpg?dl=0

Only Apple ][ on top center, and THEN after pressing Control-Reset, I got this:

https://www.dropbox.com/s/eod7st7h3cbachg/disk_card-2.jpg?dl=0

The prompt is on BOTTOM LEFT.

Very strange...

Any clue on why?

After a diagnostic (ctrl-empty apple-full apple-reset) I get "RAM:" on top left.

Thanks.

__________________

Juan Carlos

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

UPDATE

If I write a line number and then run the program, Hello World is spelled correctly.

https://www.dropbox.com/s/bztu9yl21m5klvo/hello-W-ok.jpg?dl=0

Adding more mystery... Smile

__________________

Juan Carlos

macnoyd's picture
Offline
Joined: Oct 15 2012
Posts: 183
Re: New User, "New" Apple IIe: Greetings & Questions

From your description above, it looks (to me) like the behavior is correct if the Disk Drive card is installed.
The card tries to auto-boot a drive that is (likely) not attached. (according to your earlier description)
Your screen images look normal.

The issue is the Hello Wor/d. That looks like a memory issue (bad bit) or a ROM issue, but likely a bad memory bit issue.
You will need to run the ][e diagnostic application to be sure. (if the computer can actually run it)
Definitely a unique issue but doesn't look too difficult to fix. You might need someone with desoldering equipment at some point ...

__________________

macnoyd

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions
__________________

Juan Carlos

Dog Cow's picture
Offline
Joined: Dec 11 2008
Posts: 451
Re: New User, "New" Apple IIe: Greetings & Questions

jcmontero wrote:

The command AUTO 300 comes from the "Apple ][ Basic Programming Manual" where it states that the command should number lines automatically instead of adding them manually for each new line.

Unfortunately it gives me a Syntax Error.

There are two versions of BASIC for Apple II. There's the old one called Integer BASIC and the new one called Applesoft BASIC. That manual that you have, and the AUTO 300 line, are both from Integer BASIC, which is not built-in to your Apple IIe.

Instead your Apple IIe has Applesoft BASIC built-in, which does not have the AUTO command.

You might find the book The New Apple II User's Guide, very helpful. It covers all these topics plus more. See the link for Apple II Book in my signature.

__________________

Email me: dog_cow@m acgui.com
Mac GUI Vault: http://macgui.com/vault/
Apple II Book: http://macgui.com/newa2guide/
Inside Allerton Park book

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Dog Cow,

yes, now that I've looked better it doesn't say specifically Applesoft BASIC. One problem solved. Smile

The book is "Apple II Basic Programming Manual" (1978) by Jef Raskin.

https://archive.org/details/Apple_II_Basic_Programming_Manual_1978_Apple

I'll check the book you mentioned for sure.

Thank you!

__________________

Juan Carlos

Offline
Joined: May 27 2009
Posts: 886
Re: New User, "New" Apple IIe: Greetings & Questions

jcmontero wrote:

After running the command AUTO 300 (or any other numeric input), it gives a syntax error. Do someone know why?

Yes. You have an Apple IIe, so it comes with Applesoft Basic. AUTO is not a feature in Applesoft Basic.

AUTO is auto line numbering. An aid to programming. It increments each line number as you progress through typing in your program.

It works in Integer Basic only, which is included in the roms of original Apple II. Not II+ or //e. By the way, Integer Basic is loadable into RAM for later models like the II+ and //e. To see how AUTO works - Boot a "System Master" disk and type INT. You get the ">" prompt. Type AUTO 300, 10.

The machine now starts printing line numbers for your basic program, beginning with 300 and incrementing each by 10. The next line number will be 310, 320, and so on.

Each line must contain valid Basic statements with correct syntax. Like A=A+1. Or PRINT "TEST".

When you've had enough of typing in your Integer Basic programs by hand you can use the "Control-X" + "MAN" command to quit auto-line numbering. Thus returning you to the ">" prompt with no further automatic increments.

-----

__________________

On a clear disk you can seek forever..

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Thank you Keatah,

Dog Cow replied to me before, but I didn't know that Integer Basic was loadable into RAM for the Apple IIe.

Will try that as soon as I receive the floppy drives I ordered.

__________________

Juan Carlos

Offline
Joined: May 27 2009
Posts: 886
Re: New User, "New" Apple IIe: Greetings & Questions

You also have an un-enhanced IIe. Not to worry though. It can be upgraded later once you get the lay of the land. Now.. When you run your built-in diagnostics, it should say KERNEL OK in the upper left-hand corner. The Enhanced models will say System Ok in the center of the screen.

If it says RAM: Then likely you have bad RAM. Less likely you could have a ROM issue, or something that controls the address/data bus. And then even less less likely, the CPU.

About 50-80% of the Apple IIe units I fix are RAM chips. Those from MT Micron Technologies seem to be the worst kind. Other vendors' chips have less problems. And later in the //e life they reduced the count from 8 chips to 2 in the Platinum version.

---

The cursor/prompt being on the top or on the bottom sounds just fine. Depends if there is a disk controller card, and when you press reset and all that.

__________________

On a clear disk you can seek forever..

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Interesting, I just bought a set of 10 MT chips to replace the ones I have now.

My current RAM array:

https://www.dropbox.com/s/ye4de5fk5bmhih0/ram-array.jpg?dl=0

The chips I ordered:

http://www.ebay.com/itm/Lot-of-18-MT4264-12-MICRON-4264P-RAM-RARE-16-PIN-DIP-NEW-IC-CHIPS-/111848800016?hash=item1a0ab53f10:g:XEcAAOSwfZ1WbSGK

I hope they aren't that bad, otherwise the PC will go on sale. Smile

__________________

Juan Carlos

Offline
Joined: May 27 2009
Posts: 886
Re: New User, "New" Apple IIe: Greetings & Questions

Well hopefully they'll all be of the same make, speed, and similar date code. That's something I like to strive for. From the looks of it I would say someone did a lot of memory swapping on your rig at one time.

__________________

On a clear disk you can seek forever..

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Yes, I just wanted them all the same.

And I also thought they had a lot of fun playing with those chips. Smile

BTW, I swapped the current chips, I placed alle the MTs nearby one another, then the two NECs and then the other two.

Result: The previous "HELLO WOR\D" error is no more, now it prints correctly.

But still has the "RAM: " error.... Duh!

__________________

Juan Carlos

Offline
Joined: May 27 2009
Posts: 886
Re: New User, "New" Apple IIe: Greetings & Questions

Something else is going to fail now. 1 out of 50 programs might give you a subtle error and drive you crazy!

__________________

On a clear disk you can seek forever..

ggb
Offline
Joined: Mar 13 2012
Posts: 23
Re: New User, "New" Apple IIe: Greetings & Questions

Try the command line memory test in this topic, it might help identify any further ram errors

http://www.applefritter.com/content/apple-ii-bad-memoryrom

Regards
Geoff Body

ggb
Offline
Joined: Mar 13 2012
Posts: 23
Re: New User, "New" Apple IIe: Greetings & Questions

I noticed that you have run that test on your machine and posted your result under that other posting.

The output shows
Address- source value (destination value)
From the output, it appears that bits 5,6 & 7 are showing errors, so the ram chips for those three bits should be replaced.

Regards
Geoff Body

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Quote:

Something else is going to fail now. 1 out of 50 programs might give you a subtle error and drive you crazy!

Keatah,
Yes, it's called The NeverEnding Story. They also made a song in the 80s. Probably the songwriter used an Apple IIe. Smile :) Smile

__________________

Juan Carlos

jcmontero's picture
Offline
Joined: Jun 14 2017
Posts: 15
Re: New User, "New" Apple IIe: Greetings & Questions

Quote:

From the output, it appears that bits 5,6 & 7 are showing errors, so the ram chips for those three bits should be replaced.

ggb,

I am going to replace ALL the RAM chips.

I got these from eBay:

http://www.ebay.com/itm/Lot-of-18-MT4264-12-MICRON-4264P-RAM-RARE-16-PIN-DIP-NEW-IC-CHIPS-/111848800016?hash=item1a0ab53f10:g:XEcAAOSwfZ1WbSGK

I hope they're good, since MTs are already installed on my mainboard.

https://www.dropbox.com/s/ye4de5fk5bmhih0/ram-array.jpg?dl=0

Of course there's a problem with some of them, which include the MTs, but these ones are all new and all the same.

Though in this Technical Service Data sheet they state the RAM chips are Texas Instruments TMS4164-15NLJ.

https://mirrors.apple2.org.za/Apple%20II%20Documentation%20Project/Books/Sams%20ComputerFacts%20-%20Apple%20IIe.pdf

https://www.dropbox.com/s/dtjaqtxu9vmhpn5/SAMS_Computer_Facts_Apple_IIe_Technical_Service_Data.png?dl=0

I am crossing my fingers...

__________________

Juan Carlos