Sacrilege- Apple II Rev 0 Running CPM 3.0

2 replies [Last post]
Offline
Joined: Oct 9 2011
Posts: 1044

Hi-Res Version of Pic

I finally got it going...
CPM is really picky about the cards in your system and what slot they are in (i.e. Serial in Slot 2). But the trick on a Rev 0 (without auto-start ROM, auto-reset doesn't matter) is that ALS "The CPM Card" can only reside in Slot 7. Any other slot it doesn't like, none of my other cards care (I even run a RamEx 16k card and a Apple ROM card at the same time). My Rev 4 Apple II supports other slots for CPM (4&5 even though only 4 should work) anyway...

Kinda cool running a 6 MHZ Z80 in an old Apple II.

Cheers,
Corey

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
transwarp II guy's picture
Joined: Mar 7 2013
Posts: 465
Re: Sacrilege- Apple II Rev 0 Running CPM 3.0

I love your set up, looks great! Nice to see a rev 0 in use. Running my z80 card is nice, it's allowed me so much more freedom to run CPM based software. I'm still searching for a PC transporter so I can run MSDOS.

Offline
Joined: Jun 5 2008
Posts: 380
Re: Sacrilege- Apple II Rev 0 Running CPM 3.0

The peripheral BUS on the rev 0, is slightly different than later rev motherboards. I think one or two of the peripheral pins are bussed to all slots on the rev 0 and not on later revisions. I can't remember details offhand, but it could account for some slot dependent issues, not seen in later revisions.

Regards,
Mike Willegal