Odd external hard drive issue, won't mount/not visable, yet Mac complians when I unplug!

13 posts / 0 new
Last post
Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
Odd external hard drive issue, won't mount/not visable, yet Mac complians when I unplug!

OK. Tell me if I am crazy.

My external drive stopped mounting after one of those annoying random "sorry unable to complete operation due to a disk error" things while copying some files. Now when I plug her in via firewire or usb she's a no show and YET when I turn off or unplug the drive from my mac it hollers at me "the drive named "drivewhatever" was unexpectedly disconnected, unplugging a drive without putting it away, data loss, blah blah, etc., etc., etc...."

Crazy. It uses the right name in the warning box, so it must "see" the drive at some level but I never get an Icon, a mount option, anything, even in third party ware. i am at a loss. same in os 9 or osx. any clues?

Offline
Last seen: 6 years 1 month ago
Joined: Dec 20 2003 - 10:38
Posts: 851
her?

Maybe a loose cable, probably a bad bridgeboard. You didn't plug in firewire and USB at the same time did you?

Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
yeah, the HD's are all grrrls

...and the mac is a boy.

so yeah, i thought of that and switched cases with my perfectly good and happy drive. same brand of case and the problem follows the wonky drive. could it be the architrcture of the bridge on this brand of HD case in combo with drive?

also, no, they are not plugged in at the same time. i had just noticed that it tried to mount once under os 9 but only with usb, so i've been trying both. this drive had some catalog file issues a while back. i am scared...

Offline
Last seen: 6 years 1 month ago
Joined: Dec 20 2003 - 10:38
Posts: 851
If the problem follows the dr

If the problem follows the drive, then you are probably hosed. Try norton only as a last resort as it often makes things worse, not better.

Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
yeah...

i figured that may be the case.

so here's a question: i do mac repairs, upgrades, etc for all my graphic designer buds and i was thinking of drumming up more business, my idea was data recovery. big business with sad designers who lost their client's stuff. so, maybe this drive would be a good test subject.

i've looked into buying set-ups for recovery and they seem to all be pc-only. does anyone know who makes the systems that recover mac drives. total tangent, but it seems serendipitous at the moment...

Dr. Webster's picture
Offline
Last seen: 3 days 2 min ago
Joined: Dec 19 2003 - 17:34
Posts: 1751
Did you ever go into Disk Uti

Did you ever go into Disk Utility? Did it see the drive? I've seen drives that won't mount but show up in Disk Copy. If it's there (and if the Mac gives a warning when the drive is unplugged, it probably is), try a good, old-fashioned Disk First Aid on it.

Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
disk utility...

...fails to see it.

the one time it showed up was in os9 under a third party app (tech tool maybe) with a usb cable. actually, under osx, like right now, i get the spinning beachball whenever the drive is plugged in and it applies to whatever program is "on top" when i plug in the drive. it just spinsssssss until i switch the drive off. then sometimes the computer just goes back to what it was doing or it warns with about a missing drive. odd. very odd. only os9 seems to get its name.

Jon
Jon's picture
Offline
Last seen: 13 years 5 days ago
Joined: Dec 20 2003 - 10:38
Posts: 2804
Does it show in Apple System

Does it show in Apple System Profiler at all? It may be that the machine recognizes the device is plugged in, but DU won't be able to work with it.

Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
nah...

don't see it in the profiler, it just hollers when i unplug it, but it uses the disk's name!?! oh, and recently i have gotten varying responses from plugging it in, most notabley "waiting for local disks" while booting into OSX and system hangs while already in system 9 (perma-clock) and OSX (beachball)...

Dr. Webster's picture
Offline
Last seen: 3 days 2 min ago
Joined: Dec 19 2003 - 17:34
Posts: 1751
If you have a copy of DiskWar

If you have a copy of DiskWarrior, I'd try booting from its CD and see if it sees the drive. My guess is that the directory structure is totally hosed on the drive.

Another option would be to plug it into a PC and see if whatever disk utilities you have can repair it.

Offline
Last seen: 17 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 4
My iPod did the same thing...

...At first it just had problems acting as a hard drive (exactly as demos-o has described), but eventually it stopped working as a music player, too.

I've fiddled with it a whole lot, and basically now I'm just waiting to have enough cash on hand to get it repaired.

Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
you know...

it's funny you should mention disk warrior. i actually ran out and bought it at my apple store, since the drive mounted for a hot second under os9, like i had mentioned before. well, when i rebooted from the DW cd it never saw the drive and it has failed to mount since. i'm pretty sure the directory is hosed, but i am also fairly sure the data is there. when i looked at the drive during it's last mount it gave me a ##GB at the top of the finder window. I know this is out of 80 total GB or so (the total drive size.) Despite the fact I could not drill down into folders, the disk "told" the mac my 50 or so gigs were being taken up out of the 80 gb. That was the last i heard from this drive... argh.

i know now (based on warning dialogues) that it is hanging my OS (9 and X) because it's trying to mount and never achieving it-- This, the use of the drive name when i unplug it in OS9, and the fact that the data usage was displayed the last (and final) time it mounted, I THINK means that the disk is just having trouble shaking hands swith the mac. I'm hopful the data is still there. Any more ideas? Will my PC recognize HFS or HFS+?

Offline
Last seen: 18 years 11 months ago
Joined: May 29 2004 - 00:50
Posts: 20
just wanna ask a dumb question:

if the "bad part" of my drive is the catalog files, etc in the header of the drive (hence the failure of my mact to recognize it) and the data is pretty much shot anyway, riddle me this--

should i thro it into a mac on an ide cable (where it ends to show up as "unreadable" and reformat it and THEN use one of the data recover softwares such as Data Rescue X to recover what I can once the catalog files, etc. are (hopefully) restored...? It's all academic at this point, but it may be worth a try, no?

Log in or register to post comments