512Ke, Continuous Chime

3 posts / 0 new
Last post
Offline
Last seen: 19 hours 25 min ago
Joined: Mar 31 2020 - 19:55
Posts: 387
512Ke, Continuous Chime

I was recently given a 512Ke, with an issue: On power-on, the machine repeatedly chimes, then resets, chimes, resets. The cathode tube never illuminates, nothing else occurs. the chime repeats about once/second.

 

I recall something with the power sweep boards on these. Other than that, before I crack her open, I figured it may be wise to ask if anyone else has encountered this issue. 

 

Is this a known problem with a solution, or some random fault that I will need to inspect at all stages?

 

Update: I tested the mainboard on a known good power/sweep board. It has the same symptoms. What on the mainboard would cause this, but fail to reach the sad mac fault indicator?

dorkbert's picture
Offline
Last seen: 10 hours 45 min ago
Joined: Apr 12 2009 - 16:33
Posts: 313
typically power supply

typically power supply problem.

you might want to check for cracked solder joints or loose/bad connector between the analog board and the logic board first.

Offline
Last seen: 19 hours 25 min ago
Joined: Mar 31 2020 - 19:55
Posts: 387
dorkbert wrote:typically
dorkbert wrote:

typically power supply problem.

you might want to check for cracked solder joints or loose/bad connector between the analog board and the logic board first.

 

I reflowed it, with no change. I also saw no broken or cold joints when I examined it. I have never seen this specific condition in the past, so I may just rule it as dead until or unless someone has any idea what to check. 

Log in or register to post comments