Apple II problems

18 posts / 0 new
Last post
transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Apple II problems

Hello, I have an apple II that is having some issues. The computer boots to the screen you see below. Does anybody recognize the below screen?

The motherboard is missing one chip, 74LS02. Could this be the problem?

Thanks for your time.

AttachmentSize
Image icon DSCN5325.JPG2.11 MB
Image icon DSCN5329.JPG2.06 MB
Image icon DSCN5322.JPG2.22 MB
Image icon DSCN5327.JPG2.21 MB
Image icon 01.JPG2.14 MB
Image icon 02.JPG2.07 MB
Image icon 03.JPG2.03 MB
Image icon 04.JPG2.23 MB
Image icon 05.JPG2.19 MB
Image icon 06.JPG2.1 MB
Image icon 07.JPG2.17 MB
Image icon 08.JPG2.14 MB
Image icon 09.JPG2.14 MB
Image icon 10.JPG2.06 MB
Image icon 11.JPG2.21 MB
Image icon 12.JPG2.16 MB
Image icon 13.JPG2.06 MB
Image icon 14.JPG1.99 MB
Image icon 15.JPG2.17 MB
Image icon 16.JPG2.05 MB
Image icon 17.JPG2.09 MB
Image icon 18.JPG2.24 MB
Image icon 19.JPG2.07 MB
Offline
Last seen: 2 years 8 months ago
Joined: Apr 10 2006 - 20:01
Re: Apple II problems

I don't know if it's the problem, but it's certainly a problem... you'll want to get one of those plugged in.

speedyG's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Nov 16 2011 - 07:45
Re: Apple II problems

Well just to show how important that chip is:
see page 217 in the "Apple II circuit description" from Winston D. Gaylor ( availiable at asimov or Apple Documentation Center ).... that chip is related to half a dozen video signals and the I/O SYNC.... and its closely related therefor to the timing of the clocking signals with the Apple II ! If you recognize that the RAM chips don´t get - due to the missing chip - a correct refresh signal and therefor loose content - i guess i don´t have to explain further.....

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

I'll find a replacement asap. Unfortunately I have no other II or II+ motherboard around the house right now.

speedyG's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Nov 16 2011 - 07:45
Re: Apple II problems

the 74LS02 is that common that you might find it on nearly every second board that contains TTL logic....
( so you may find such chip also on interfacecards or even simple controllogic within old clocks, old printers,
and so on..... and that IC is dirt cheap.... below half a buck....
sincerely speedyG

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

An amateur question for you Speedy; will a DM74LS02N work in place of the factory 74LS02PC? That is all I have currently, I have found no exact matches in my stash.

speedyG's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Nov 16 2011 - 07:45
Re: Apple II problems

yes it will do...
DM is just an indication to the manufacturer....
74LS02 is the specification of typ
and PC is again only marking to specific cases used by several manufacturers ...
sincerely speedyG

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

I installed the chip last night, and it made a slight difference. It shows the same exact screen, except now it just flickers as if the monitor is stuck on v-hold.

dorkbert's picture
Offline
Last seen: 2 hours 43 min ago
Joined: Apr 12 2009 - 16:33
Re: Apple II problems

try wiggling the rca connector, sometimes bad contact between the connectors does that. also cracked solder joints will do that. I recently reflowed solder points on a rev 4 board to fix that.

speedyG's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Nov 16 2011 - 07:45
Re: Apple II problems

hello transwarpIIguy,
under normel conditions the insertion of a working chip should at least cause the screen
to change that way that instead of 4 smaller display squares only one larger display sqare should
be visible....
and if only one display is visible the dotmatrix display indicates that at least one bad
RAM chip is at least in the first ROW ( one of the 4116 chips in ROW C ).....

maybe you can solve this by changing RAM from another ROW ( D or E ) to the C ROW....

You should first start examining the entire 3 ROWS of 4116 chips if one of them is inserted
badly
( wrong orientation with notch heading backward instead of heading to the front
or if the chip is not correct in the socket.... its one of the most common failures that
by inserting the chip in the socket one pin is bent and slipped beath under the chip instead of
being inserted correct in the socket ) !

Unless the mistake has been located it would be good idea to startup the system only with 16kB
(only ROW C of RAM inserted ) and the other 2 ROWs of RAM ( D and E ) seated in a antistatic foam or antistatic bag
besides apart from the board - it will protect the extracted RAM from being damaged by another damaged RAM-chip )

Under normal condition it is possible to startup system to prompt with only one ROW of RAM ( C ROW ) inserted....
when this is possible the next step would be to add next ROW ( D ) of RAM and if the ends correct
at promt finally inserting the last ( E ) ROW of RAM.

please report when the display changes ... this might help to track down the error....

and posting more general overview of the board might also help with diagnosis - if the picture
has high resolution, well lighting and good focus....

sincerely speedyG

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

Update:

I replaced Row C with some ram I have around the house (verified working), and removed Row D & E. The screen did not change; it still shows the 4 small squares like before.

I also examined the whole motherboard and have found no bent pins, and none are inserted backwards.

As for a general overview:

1. The original power supply does not work. It's possible the PS may have damaged the motherboard.

2. The motherboard was very dirty, so I washed it as I have done with many others. Just figured I would say so.

3. No sound comes from the speaker when booted.

4. With a disk drive connected to the computer, the drive does not respond.

5. I have reseated all the chips and nothing has changed.

6. The only change that has occurred was when I installed the 74LS02; which now results in the display flickering as described in post #7. The display looks as if the monitor is stuck on V-hold.

7. I have done a basic visual inspection, and have found no major corrosion, and no burned traces.

8. What little corrosion there is, is some light rust on a limited few of the IC's pin's.

Expect by tonight to have quite a few High res pics of the motherboard posted. I will try and get the best pics I can of everything.

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

dorkbert wrote:
try wiggling the rca connector, sometimes bad contact between the connectors does that. also cracked solder joints will do that. I recently reflowed solder points on a rev 4 board to fix that.

I tried wiggling the RCA connector and even changed the RCA cords to no avail. Also when the 74LS02 chip is removed the screen stops moving.

As for cracked solder joints, I will have to take a closer look.

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

transwarp II guy wrote:
dorkbert wrote:
try wiggling the rca connector, sometimes bad contact between the connectors does that. also cracked solder joints will do that. I recently reflowed solder points on a rev 4 board to fix that.

I tried wiggling the RCA connector and even changed the RCA cords to no avail. Also when the 74LS02 chip is removed the screen stops moving.

As for cracked solder joints, I will have to take a closer look.

One last tidbit. When I exchange the 74LS02's around (There's 3), the result is exactly the same. So I'm guessing the replacement 74LS02 is fine.

speedyG's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Nov 16 2011 - 07:45
Re: Apple II problems

I will start with troubelshoot process as soon as the pictures are availiable.
please make sure to use a working PSU for repair...
do you have an oscilliscope availiable ?

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

Sorry I've left y'all hanging. I will post up pics asap. I've been fairly busy these last few days.

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

speedyG wrote:
I will start with troubelshoot process as soon as the pictures are availiable.
please make sure to use a working PSU for repair...
do you have an oscilliscope availiable ?

Again, I'm sorry it took me so long to post the pics speedyG. It won't take this long again. My cameras batteries went dead, and along with several other projects I got going on right now I just kept procrastinating.

Starting from 01 down to 19 I have added pics. If you need any other pictures at any angle don't hesitate to ask.

I unfortunately gave away my only oscilloscope to my son for his birthday last year. Do you think I can even diagnose with out an oscilloscope?

speedyG's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Nov 16 2011 - 07:45
Re: Apple II problems

Hello transwarp II guy,
maybe he well lend you the scope for troubleshooting. its highly recommended and may save you several days of searching time...

but let´s start with the preliminaries....
the board suffered long time very high humidity.....
the caused a lot of severe oxydation....
2 chips have been changed in former days - that can be recognized by damages to the IC case....
i´s start with them first by changing them against one without case damage... if they have failed in former days and requested replacement lets start with them first. they are marked red.
the videoconnector is in very bad shape.... it should be replaced....( desoldered / removered / new soldered in....
then you should start to extract carefully all chips wit violett marked pins, carefully temove entire oxydation and
rust and reinsert them after cleaning befor next step should be performed and checkout results from this tasks.




for cleaning pins you might use very fine sandpaper ( grade 400 or 600 ) or really professional:
assk for this tool in the U.S.A. - it´s used for cleaning PCBs. Looks like stone
- but it´s in fact soft material and it removes oxydation perfectly !

http://www.conrad.de/ce/de/product/529419/Polibloc-SENO-2003

sincerely speedyG

transwarp II guy's picture
Offline
Last seen: 13 hours 39 min ago
Joined: Mar 7 2013 - 08:55
Re: Apple II problems

Well something interesting happened yesterday. I had someone over to check out an apple IIe I have on craigslist; and he noticed the keyboard to this computer sitting on my bench. (it’s one of those early one’s with the key style light) He offered me $400, a price I just couldn’t refuse.
So now I have no keyboard for this computer, I didn’t really think it through at the time because the offer was so good.

I went ahead and purchased a II+ mobo from ebay to use as parts for this computer.

Also my son said he would be willing to ship the oscilloscope but I’m going to have to think it through tonight.
Since I don’t have the keyboard anymore I’m kind of debating on whether or not just to sell it. I know, not very great of me. Admittedly the case is pretty bad, especially the apple ][ emblem. It looks like a damn paper clip was taken to it!

I’ll probably try swapping IC’s from the II+ mobo and if it doesn’t work out I’m just going to sell this mobo and keep the case for a future project.

Either way I’ll get back to you after the IC’s you pointed out are replaced Speedy.
Thanks for the awesome advice!

Log in or register to post comments