game port test

8 posts / 0 new
Last post
Offline
Last seen: 4 weeks 18 hours ago
Joined: Mar 15 2019 - 07:03
Posts: 21
game port test

Hi,

please anyone having an Apple IIe, could you try the below code and let me know what is the output?

On my Apple IIe I got 255 0 so i think that something on my game port is broken because I expect to get 127 127. What do you think about it?

Please try it without any joystick connected.

 

10 A =  PDL (0)

20 B =  PDL (1)

30  PRINT A;" ";B

40  GOTO 10

 

thank you

Online
Last seen: 1 hour 29 min ago
Joined: Jun 6 2020 - 10:50
Posts: 254
With nothing connected, you

With nothing connected, you should get 255 on both. Which is what my //c and IIe just gave me. I didn't type your program, I just did a "print pdl(0)" and repeated with 1 from the basic prompt. 

Offline
Last seen: 4 weeks 18 hours ago
Joined: Mar 15 2019 - 07:03
Posts: 21
confusion

thank you for your help, but now i'm a bit confused because on my apple IIe i got "255 0", you got "255 255". i tried on the emulator and i got "127 127". what's the right values?

 

Someone else could make the test and report the results?

cheers

Online
Last seen: 1 hour 29 min ago
Joined: Jun 6 2020 - 10:50
Posts: 254
The emulator was probably

The emulator was probably emulating a joystick. Which is why you got 127/127. That would be the reading of a centered joystick.

 

255 is the max value and what the Apple would report if there was infinite resistance (ie nothing connected).  

 

I just tested AppleWin after making sure the joystick was set to disabled. It also reported 255/255. 

Offline
Last seen: 4 weeks 18 hours ago
Joined: Mar 15 2019 - 07:03
Posts: 21
Hi Nick,so on my apple IIe i

Hi Nick,

so on my apple IIe i have a correct value of 255 on a pin, now i have to investigate why i have 0 on the other one. it is possible that the 558 is the culprit.

If someone had the same issue, please let me know, i'll do some check in the next days.

thank you

Online
Last seen: 1 hour 29 min ago
Joined: Jun 6 2020 - 10:50
Posts: 254
I've never had issues with my

I've never had issues with my joysticks. But from everything I've read, the 558 is almost always the culprit when there are issues. 

Offline
Last seen: 4 weeks 18 hours ago
Joined: Mar 15 2019 - 07:03
Posts: 21
tests

more info on the tests i made.

PDL(0) 255 - turning the potentiometer the value correctly change

PDL(1) 0 - turning the potentiometer  do not works

PDL(2) 255 - turning the potentiometer the value correctly change

PDL(3) 0 - turning the potentiometer  do not works

sw0 works, when i press it i got peek(49249) > 127

 

 does anyone have any idea about it?

 

 

Offline
Last seen: 4 weeks 18 hours ago
Joined: Mar 15 2019 - 07:03
Posts: 21
it works

Hi guys,

just to close the thread, i replaced the ne558 and now it works fine.

thank you

Log in or register to post comments