I can't type anything in the basic ] prompt

3 posts / 0 new
Last post
Offline
Last seen: 2 months 3 weeks ago
Joined: May 25 2018 - 22:10
I can't type anything in the basic ] prompt

Let me just start by saying I have never seen one of these machines in real life. This is my first time using one.

I found an Apple IIe being sold in "as-is" condition because the seller didn't have any of the peripherals to go with it - no disk drive, no hard drive, no monitor, etc. So I brought it home and hooked it up to my TV and decided to write some simple BASIC code. It starts up and shows me the Apple ][ text at the top and gives me a prompt, " ] " but when I type nothing shows up. The cursor moves but it looks like I hit the space bar. Occasionally another ] will show up on the screen or a white rectangle. Pressing return does not give me a line break. It behaves the same as the other buttons.

I ran the self test (both apple keys and the reset button) and it says "KERNEL OK". I'm not sure what else to do. Am I missing something? How do I troubleshoot this?

speedyG's picture
Offline
Last seen: 13 hours 33 min ago
Joined: Nov 16 2011 - 07:45
Check for good and firm

Check for good and firm internal cable connection between keyboard and keyboard-connector at mainboard
(front right side ) and probably make picture from that area inside and post here a link to that picture.Check for missing chips related to keyboard decoding.

Offline
Last seen: 2 days 16 hours ago
Joined: Dec 3 2015 - 20:45
Also try reseating the power

Also try reseating the power supply plug on the board. The -12v is a corner pin that on the IIe model only feeds the keyboard encoder chip so the symptom
of a missing -12v is a dead keyboard.

Log in or register to post comments