IIgs mono text mode?

6 posts / 0 new
Last post
Offline
Last seen: 3 months 1 week ago
Joined: Mar 15 2021 - 23:14
Posts: 2
IIgs mono text mode?

I have a Rom 01 IIgs which has been working fine.  But all of a sudden, the initial text mode is only showing up in monochrome over composite.  I have it set to blue but I only see gray.  I tried going back into the control panel and switch the colors but it is only monochrome.  I also tried unplugging the battery and going back to defaults but no change.

 

Weird thing is that games are still working in color.  Conan, Arkanoid 2, even GSOS still show up in color.

 

Any idea where I should start looking?

Thanks!

Tim

Offline
Last seen: 3 weeks 13 hours ago
Joined: Mar 31 2020 - 19:55
Posts: 848
What display are you using?

What display are you using, and have you tried other displays? It sounds as if colour burst is not being read properly in text mode, and I knof of nothing that would do that on the //gs itself. I suspect the display first. 

 

I think that I still have a //gs schematic if that'd help. 

 

Would also be good if you can check it on RGB to see if the same issue persists there. The default colours should be white on blue. 

Offline
Last seen: 3 months 1 week ago
Joined: Mar 15 2021 - 23:14
Posts: 2
I tried a Samsung TV over

I tried a Samsung TV over composite and I also have a Goldstar 13" CRT.  Both displayed monochrome on boot.

I may have seen elsewhere that this is normal for composite?  I don't remember this from before.  Weird too that colors still show up in games.

I don't have an RGB monitor but I was using the 15 pin port with a LM1881 to connect to a Samsung 710N monitor.  It was working until just recently as well.  Not sure if it is the monitor or the cable.

Tim

Offline
Last seen: 3 weeks 13 hours ago
Joined: Mar 31 2020 - 19:55
Posts: 848
//gs Schematics

//gs Schematics

 

Might be a fault of the VGC. If you have been using it with an alien monitor it is possible that you damaged that ASIC @H12, or it may be a known flawed version.

 

http://www.applelogic.org/files/344S0046.png

The P/Ns are: AMI: 344S0046-2 (also -3. -4, -B. -C, -D)

IMP: 344S0056-A (also -1).

 

https://www.digchip.com/datasheets/quote.php?action=search&pn=344S0046-2

 

Do not use AMI revisions 344S0046-A or 344S0046-1. If, you have one of these two revisions it is almost guaranteed to be the culprit.

Offline
Last seen: 3 weeks 13 hours ago
Joined: Mar 31 2020 - 19:55
Posts: 848
TimCross wrote:I tried a
TimCross wrote:

I tried a Samsung TV over composite and I also have a Goldstar 13" CRT.  Both displayed monochrome on boot.

I may have seen elsewhere that this is normal for composite?  I don't remember this from before.  Weird too that colors still show up in games.

I don't have an RGB monitor but I was using the 15 pin port with a LM1881 to connect to a Samsung 710N monitor. 

Also, composite text is normally white on black, iirc.  You stated that there was a sudden change, but if that is only from shifting from an RGB display to composite, then it is easily normal. You said monochromatic, so I may have been unclear on precisely what changed, or your symptoms.

Offline
Last seen: 3 weeks 13 hours ago
Joined: Mar 31 2020 - 19:55
Posts: 848
//gs Owners Manual on

//gs Owners Manual on Composite Displays If you see grey and not black, that is an issue. It should be white on black text. It could simply be your contrast settings, but photos would help.

 

Screen Colours on Composite

 

This may help to clear up your confusion. 

Log in or register to post comments