Macintosh 512k problems

2 posts / 0 new
Last post
Macintosh128k's picture
Offline
Last seen: 4 years 10 months ago
Joined: Dec 4 2010 - 01:47
Macintosh 512k problems

I recently purchased off ebay a Macintosh 512k, M0001WP as a parts computer.
I wasn't expecting it to work. I was however hopeful that the power sweep board would be usable for parts. When it powers up the screen does not light up at all, and there is a wisk wisk wisk noise emanating from the unit with the floppy drive continually seeking for a disk. It is like a pulsating sort of sound. It sounds like a power board failure of some sort inside the unit, any ideas? With my limit knowledge of electronics I didn't think that these symptoms would be associated with the main logic board.

Offline
Last seen: 6 years 1 month ago
Joined: Apr 8 2012 - 14:27
Re: Macintosh 512k problems

I had that problem with the Macintosh 512k that inherits from a deceased friend, gave the startup sound of mac itself but with additional noise and a smell like burning and high-voltage noise, the picture tube gives a wrong image, but if at the beginning gives the beep own Mac, I solved by removing the board and the screen and replace it with an SVGA (800 x 600) Unisys 9-inch-size and a source of old ATX PC that had out there, with a reading voltages and output pins for audio, video, (H) Horizontal, (V) Vertical and (S) sync signal, but you get to know something about electronics or else you burn it, then the weekend will send some pictures to see the progress, I am getting the keyboard and mouse OS original that I have not yet, and. do not know if that can help me.

Log in or register to post comments