Need Help With Apple IIGS Memory Error

12 posts / 0 new
Last post
Ahow77's picture
Offline
Last seen: 1 week 3 days ago
Joined: Dec 31 2019 - 16:21
Posts: 3
Need Help With Apple IIGS Memory Error

I have a rom 1 IIGS with a 4mb expansion card and I'm trying to get a music program called Sonix to work with it. I'm using Floppy Emu rev B to load the image. I get past the initial ProDos 8 title screen then it shows this memory error:

"Allocate 0101
***MEMORY ERROR***
Must be user #1
De-allocate all managed memory "

Then it gives me a command prompt and I don't know how to proceed. Any help would be appreciated.

Spectre's picture
Offline
Last seen: 5 days 23 hours ago
Joined: Aug 17 2018 - 23:26
Posts: 27
Ahow77 wrote:

Ahow77 wrote:

 

You posted an empty message?

Ahow77's picture
Offline
Last seen: 1 week 3 days ago
Joined: Dec 31 2019 - 16:21
Posts: 3
Not intentionally, I'm new to

Not intentionally, I'm new to the forum, please see edited post.

Offline
Last seen: 2 days 21 hours ago
Joined: May 20 2016 - 06:57
Posts: 72
Ahow77 wrote: I have a rom 1

Ahow77 wrote:
I have a rom 1 IIGS with a 4mb expansion card and I'm trying to get a music program called Sonix to work with it. I'm using Floppy Emu rev B to load the image. I get past the initial ProDos 8 title screen then it shows this memory error: "Allocate 0101 ***MEMORY ERROR*** Must be user #1 De-allocate all managed memory " Then it gives me a command prompt and I don't know how to proceed. Any help would be appreciated.

 

Remove the 4MB RAM card and try without it. 

Spectre's picture
Offline
Last seen: 5 days 23 hours ago
Joined: Aug 17 2018 - 23:26
Posts: 27
Casablanca wrote:

Casablanca wrote:

Ahow77 wrote:
I have a rom 1 IIGS with a 4mb expansion card and I'm trying to get a music program called Sonix to work with it. I'm using Floppy Emu rev B to load the image. I get past the initial ProDos 8 title screen then it shows this memory error: "Allocate 0101 ***MEMORY ERROR*** Must be user #1 De-allocate all managed memory " Then it gives me a command prompt and I don't know how to proceed. Any help would be appreciated.

 

Remove the 4MB RAM card and try without it. 

 

He's not going to have much memory without that expansion in there.  Although in P8 I guess its not such a big deal.  I'd try reseating the RAM on the expansion card.  Also give it the onboard diag test, ctl-o apl-reset..

 

Spectre's picture
Offline
Last seen: 5 days 23 hours ago
Joined: Aug 17 2018 - 23:26
Posts: 27
Ahow77 wrote: Not

Ahow77 wrote:
Not intentionally, I'm new to the forum, please see edited post.

 

Thats better, I can read your thoughts now :)

Spectre's picture
Offline
Last seen: 5 days 23 hours ago
Joined: Aug 17 2018 - 23:26
Posts: 27
http://www.whatisthe2gs

http://www.whatisthe2gs.apple2.org.za/sonix

 

Says it needs 1mb you'll need to have the 4mb card in to use it.  Out of interest, can you get anything that uses more memory to load?  GS/OS and an application for arguments sake? 

Online
Last seen: 7 min 51 sec ago
Joined: Jul 5 2018 - 09:44
Posts: 431
Spectre wrote:

Spectre wrote:

http://www.whatisthe2gs.apple2.org.za/sonix

 

Says it needs 1mb you'll need to have the 4mb card in to use it.  Out of interest, can you get anything that uses more memory to load?  GS/OS and an application for arguments sake? 

 

If it is a 4MB board that has removable memory he should try removing all that can be, and trying the board with minimum increments of memory using different chips/SIMMs if possible.

 

Also running a memory test program would be a good idea.  I think AE made one for their GS memory card.  It might work with others.  There may be other diagnosics software that can do it as well.

 

 

Spectre's picture
Offline
Last seen: 5 days 23 hours ago
Joined: Aug 17 2018 - 23:26
Posts: 27
softwarejanitor wrote:

softwarejanitor wrote:

Also running a memory test program would be a good idea.  I think AE made one for their GS memory card.  It might work with others.  There may be other diagnosics software that can do it as well.

 

Sounds like a good theory, I was going for keep it simple first up.. on said board you can probably play with 1Mb increments and test it one bank at a time.   The onboard tests ought to test the extended card memory also, although the AE Diag should probably show a specific chip or bank..

 

 

Online
Last seen: 7 min 51 sec ago
Joined: Jul 5 2018 - 09:44
Posts: 431
Spectre wrote:

Spectre wrote:

softwarejanitor wrote:

Also running a memory test program would be a good idea.  I think AE made one for their GS memory card.  It might work with others.  There may be other diagnosics software that can do it as well.

 

Sounds like a good theory, I was going for keep it simple first up.. on said board you can probably play with 1Mb increments and test it one bank at a time.   The onboard tests ought to test the extended card memory also, although the AE Diag should probably show a specific chip or bank..

 

The AE RAM test for their //e boards for sure does graphically show which chip it believes is bad.  The graphic representation of course might not be accurate to the layout of a non-AE board, but it might still be useful to figure out which bank/chip/SIMM might be the issue.  I haven't tried their IIGS stuff as I have less experience with the IIGS in general and the one that I have has an Apple RAM card in it, which I've never had any reason to suspect so I've never run any tests on it.  But their stuff was generally top notch so I suspect it should work similarly to the //e utilities which are very nice.

 

 

 

Spectre's picture
Offline
Last seen: 5 days 23 hours ago
Joined: Aug 17 2018 - 23:26
Posts: 27
softwarejanitor wrote:

softwarejanitor wrote:

The AE RAM test for their //e boards for sure does graphically show which chip it believes is bad.  The graphic representation of course might not be accurate to the layout of a non-AE board, but it might still be useful to figure out which bank/chip/SIMM might be the issue.  I haven't tried their IIGS stuff as I have less experience with the IIGS in general and the one that I have has an Apple RAM card in it, which I've never had any reason to suspect so I've never run any tests on it.  But their stuff was generally top notch so I suspect it should work similarly to the //e utilities which are very nice.

 

 

I've never seen any AE software for the GS to be honest.  I'll have to poke about and have a look.

Ahow77's picture
Offline
Last seen: 1 week 3 days ago
Joined: Dec 31 2019 - 16:21
Posts: 3
Thanks for your replies! The

Thanks for your replies! The ram expansion card I have is this one:

https://www.ebay.com/itm/Apple-IIgs-4-MB-RAM-Expansion-Low-Power-New-201...

I've run other programs that require more than 256K of ram (like Master Tracks Pro - 1mb) without any issues.
The only diagnostic program I currently have on my Floppy Emu SD card is A2gsDiagnostics, which just tells me that my ram expansion is the wrong size (because it's not 512K, 1mb, etc). I need to get a new SD card reader so I can download some different diagnostic programs and give one of them a try. I feel fairly confident though that the ram is good, being that it's new and was supposed to be tested before it was shipped out; and because I haven't this problem with any other programs.

Log in or register to post comments