Powerbook Woes - Please help!

9 posts / 0 new
Last post
TLAK's picture
Offline
Last seen: 11 years 9 months ago
Joined: Aug 3 2006 - 11:40
Powerbook Woes - Please help!

Hello. I am currently trying to install system 7.5.3 on an old Powerbook 540c. No matter what I try, the machine boots up, emits the apple chord, and shows the floppy with the question mark. If I insert a floppy, no matter what it contains (including the 7.5.3 installer), the machine clicks and whirs a few times, then spits it right back out. Is there any possibility that there is a hardware problem? Am I still not doing things right? Please help! This is my first Mac, so I'm still rather green...

thanks,
tlak

Offline
Last seen: 10 years 10 months ago
Joined: Jun 18 2005 - 14:52
Hello tlak,

I would check the HD and replace with a known to be good one if possible, and check all connections between. ( cables connections etc.
Of course the "?" means the machine can not find an approaite system folder to boot from.
The fact you are getting a chime is a good sign.
Do you see a pram battery you can replace?

Best Wishes,

David

TLAK's picture
Offline
Last seen: 11 years 9 months ago
Joined: Aug 3 2006 - 11:40
Powerbook woes update

I have obtained a copy of Norton diskdoctor, mac's official 7.5.3 installer, and mac's official disk tools. All three could not detect anything on the SCSI port (hard drive). I have made an attempt to open the machine to check connections, etc. I got to the ram and processor, but can't get any further (If anyone has a guide, etc to dissecting these buggers it would be really nice...), and of course the scsi interface is at the bottom of the stack... David has some very good advice, but I cannot obtain another HD. (thanks though). The fact that it runs fine from floppys containg system files is encouraging, but I don't now how I'm going to make my HD work. I sure hope it's just a loose cable...

pmjett's picture
Offline
Last seen: 4 years 7 months ago
Joined: Sep 4 2005 - 22:47
perhaps this will help in the take apart

TLAK,

I can't help you with the SCSI drive woes, but I have been directed in the past to take-apart guides on my 540c. This is the thread http://www.applefritter.com/node/18616. The links towards the bottom are for the repair/take apart and there are some accompanying comments on things NOT to break (always useful). Good luck.

Mike

Offline
Last seen: 10 years 10 months ago
Joined: Jun 18 2005 - 14:52
I could send you the service

I could send you the service manual for a 550c if that would help.

Regards,

David

TLAK's picture
Offline
Last seen: 11 years 9 months ago
Joined: Aug 3 2006 - 11:40
Thanks

Thank you for the dissassembly guide. It was a 404, but the site looks helpful. Does any one know if I can replace the HD with any SCSI drive that would fit (as in not apple certified (and therefore $$$$)) ?

TLAK's picture
Offline
Last seen: 11 years 9 months ago
Joined: Aug 3 2006 - 11:40
lame

Bad news - upon further investigation, the above mentioned guide has been removed from the site at the request of Apple's lawyers...
[sigh]

Offline
Last seen: 10 years 10 months ago
Joined: Jun 18 2005 - 14:52
Lucky I downloaded the entire

Lucky I downloaded the entire site earlier...

pmjett's picture
Offline
Last seen: 4 years 7 months ago
Joined: Sep 4 2005 - 22:47
grumble grumble

Yep. I'm completely out of help then- AND I didn't save the site like I should have.

ok. Google is my friend. TLAK, pm me when you get a chance. Macaholic- you where right on, I should have hoarded while the hoarding was good!

Mike

Log in or register to post comments