Strange MacBook Pro Audio out Problem

7 posts / 0 new
Last post
Offline
Last seen: 3 years 1 month ago
Joined: Sep 2 2004 - 23:45
Strange MacBook Pro Audio out Problem

I have a pair of KrK Rokit 5 speakers hooked up to the audio out on my mac book pro. I know the speakers are fine because when hooked up to my ipod everything is fine, but when hooked up to my MBP, the speakers work, but i am constantly getting a hiss/static sound. It is not imparing, but does get very annoying. It seems like something inside the MBP is not properly grounded, but it has had a new MLB. What SHould I do?

-eric

Offline
Last seen: 3 years 1 month ago
Joined: Sep 2 2004 - 23:45
well its definatly something

well its definatly something with the MBP, i pluged in my griffin imic, and used that to then go to the speakers, and it works perfectly (no bad hum).

so ill just use the imic.

protocol6v's picture
Offline
Last seen: 8 years 4 days ago
Joined: Apr 21 2006 - 20:58
Send it in, get it repaired.

Send it in, get it repaired. Free. Wink

Offline
Last seen: 3 years 1 month ago
Joined: Sep 2 2004 - 23:45
i will eventually, its weird

i will eventually, its weird too

as i plug in different peripherals the sound changes

like it goes from a hum to a while when i insert a firewire cable

definatly a grounding issue

Offline
Last seen: 9 years 4 months ago
Joined: Feb 10 2004 - 21:41
Re: i will eventually, its weird

peacefrog226 wrote:
i will eventually, its weird too

as i plug in different peripherals the sound changes

like it goes from a hum to a while when i insert a firewire cable

definatly a grounding issue

Almost all laptops make a hum noise on the audio output. Crank up the volume in the application and on the macbook as high as it will go, and only use the volume on the amplifiers feeding the speakers to control the volume. This will make the S/N ratio coming out of the macbook as good as it gets. Also, try running it on battery and see if that cuts the noise down. It usually does, because A/C inverter circuits are inherently noisy.

Offline
Last seen: 10 years 6 months ago
Joined: Dec 2 2007 - 10:56
Noise on the macbook pro...simple fix

I've got some bose companions which all of the sudden started picking up a very loud hum. This started right after I unplugged the network cable. I checked everything...played with the audio settings, mike settings, just about anythin you can think of.
It was obviously signal noise....just how was the noise getting to the speakers? I've got the right speaker (where the hum was) about 4 inches away from the laptop. And the firewire 800 cable runs even closer. I moved it an inch to the left, and viola, no sound. I'm lazy so I'm not going to unhook the firewire drive to confirm that the signal coming through a moderately shielded firewire cable was the culprit, but it wouldn't surprise me. The other cause might be the signal from the laptop itself, probably.

So, simple fix....don't park your speakers too close to your laptop and you probably won't get the same hum. Moving it a half inch made a difference for me but your milage may vary.

Jay

Offline
Last seen: 10 years 4 months ago
Joined: Jan 30 2008 - 19:12
disagreement

The odd thing I notice with this problem (which I experience too) is that it disappears while I use Windows XP through Boot Camp. This leads me to believe that it's a driver-related issue; as with Windows you are using a Realtek driver. What do you people think?

Log in or register to post comments