1400cs--replaced lcd not working.

3 posts / 0 new
Last post
Offline
Last seen: 9 years 11 months ago
Joined: May 26 2004 - 11:18
1400cs--replaced lcd not working.

I recently put a new lcd in my PB 1400cs--new dual-scan to replace the old one. I did so very carefully, and reassembled it in pristine condition--I thought. Now the screen won't turn on. The screen assembly is getting power--I know this because the standby green light on the top left of the case is on and blinking when I shut the computer. I just don't know what I did wrong. I went back and forth through the process again to make sure I didn't miss any connections--no problems there.

If any one has experience with this please help. I am thinking there might be a reset or something that I have read about, but can't find anything on Google or Apple support.

Thanks everyone!

grannysmith's picture
Offline
Last seen: 6 years 3 months ago
Joined: Dec 20 2003 - 10:38
1400 LCD

Check that the metal saddle that braces the display and inverter cable looms in the centre of the display's bottom edge, just at the point that the looms bend to descend to their connectors, is giving electrical continuity from the metal braids around the looms through the saddle and its retaining screw (and fingers, when the heatshield/heatsink is replaced) to 'common'. The wrapping of the looms may be interfering with that continuity.

de

grannysmith's picture
Offline
Last seen: 6 years 3 months ago
Joined: Dec 20 2003 - 10:38
1400 startup

Having the 1400 off the AC adapter and without its battery while you exchanged displays should have reset the Power Manager. What you have done subsequently, after reassembly, may have confused the PM. (It is easily confused.) Try this:

Remove the battery and the AC adapter overnight, just to be sure.
Plug the AC adapter into the wall outlet or distributor board, and switch it on.
Now, and not before, plug the adapter into the 1400. Always have the adapter powered before you plug it into the 1400.
If it doesn't start up from the power key, press and hold in the reset switch between the ADB and serial ports. Estimates vary, but use 40-60 sec.
If the sleep light comes on when you release the reset switch, turn it off with a brief press of the reset switch.
Use the power key to start up. The PRAM should have been well and truly zapped (bled?) by the overnight without power, but you can do no harm by rezapping if you wish.
If the 1400 starts, insert the battery. Let the battery charge fully, according to the control strip (which is notoriously inaccurate), plus 48hr. The backup battery charges only after the main battery is fully charged.
All of this assumes that the machine is ready to go, so, if you have any doubt, double-check (again) your reassembly.

de

Log in or register to post comments