Dead G4

8 posts / 0 new
Last post
Offline
Last seen: 13 years 3 months ago
Joined: Apr 9 2005 - 01:27
Posts: 4
Dead G4

Hi.
I have my friend's dead power mac g4 here and need some help. When i press the power button on the front, the light goes on but when i release the button it goes off. The display doesnt come on and it doesn't access the hard drive. I pressed the reset switch on the motherboard and that didnt help. This problem started after he installed a new DVD drive. Can anyone tell me what is wrong with this machiene and how to fix it? Thanks in advance, Chris

Offline
Last seen: 13 years 11 months ago
Joined: Oct 24 2004 - 00:43
Posts: 117
Cuda and Old CD

Hold down the CUDA switch (while plugged in) for five seconds. Then re-install the old CD or DVD drive and try it then.

Offline
Last seen: 13 years 3 months ago
Joined: Apr 9 2005 - 01:27
Posts: 4
I tryed that and unfortunatel

I tryed that and unfortunately it didn't work. I dont have access to the old drive because it is at the owners house. I did disconnect it and it still didnt work. Thanks.

chris501's picture
Offline
Last seen: 9 years 2 months ago
Joined: Apr 5 2005 - 04:35
Posts: 232
Testing...

If zapping the PRAM and resetting the CUDA (or PMU) doesn't work, then it's maybe the logic board itself. Are the fans and HDD spinning?

aladds's picture
Offline
Last seen: 6 months 2 weeks ago
Joined: Dec 26 2003 - 16:21
Posts: 297
This sounds serious

I think it's shorted out, the psu is realising this when you turn it on and immediatly turning off to save itself. Make sure the power leads are not touching the metal case in any way. I had this problem on a 7500, the plastic cap had fallen off of the back of one of the 4-pin power connectors and the cable connectors were pressed up against the case prividing the exact symptoms you describe.

Offline
Last seen: 9 years 8 months ago
Joined: Dec 14 2004 - 20:14
Posts: 122
Dead/weak Battery?

How old is the Mac? Could be that when the DVD drive was installed the Mac was disconnected from AC power & the internal memory battery died. Check this site for battery part numbers and sources.
Mac PRAM, NVRAM, CUDA/PMU & Battery Tutorial
http://www.geocities.com/texas_macman/pram.html

Cheers, Tom
Mac Troubleshooting, Maintenance & Tips
http://www.geocities.com/texas_macman/MacTroubleshoot.html

Offline
Last seen: 13 years 3 months ago
Joined: Apr 9 2005 - 01:27
Posts: 4
Ok, I tried to reset the PRAM

Ok, I tried to reset the PRAM but that didn't work because there is no startup tone. The HDD spins so i know it isn't the power supply the fan also spins also. I also removed all the ram and tried that. I put a brand new battery in and that also didn't work. I think maybe the motherboard is gone. Oh, there is a single red light on the motherboard that is on if that helps any. Thanks, Chris

chris501's picture
Offline
Last seen: 9 years 2 months ago
Joined: Apr 5 2005 - 04:35
Posts: 232
Red light ...

He, I've got a similar problem with a G4 Cube Mobo. A red light goes on and that's it. HD is spinning, but no boot tone and no video. I realized that the mobo has been shorted out due to a damaged USB bus... Dead Mobo = Very Expensive Repair!

It's a pity, but I had to give the cube up...

Log in or register to post comments